Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: phpbb3 admins are not recognized as admins in Coppermine  (Read 5301 times)

0 Members and 1 Guest are viewing this topic.

Animor

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
phpbb3 admins are not recognized as admins in Coppermine
« on: November 19, 2010, 04:05:29 am »

Hello,

I have tried to look for an answer but couldn't find one, perhaps someone here could help me.
phpbb - 3.0.7 fresh install
Coppermine - 1.5.8 fresh install
This is on my localhost for testing, so I cannot provide a test user.

I have bridged Coppermine to phpbb3 (Use bridge app custom groups = yes). All seem to work fine, except for one thing: phpbb3 main admins do not have admin privileges in Coppermine.
I know that the phpbb3 admins are in ADMINISTRATORS group in Coppermine, since I changed the settings and saw how they changed for them.

However, it looks as ADMINISTRATORS group is not recognized as Coppermine admin group.

Please advise.

Thanks :)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: phpbb3 admins are not recognized as admins in Coppermine
« Reply #1 on: November 19, 2010, 09:24:20 am »

What's the primary group of your admin users? Afaik it should only work if their primary group is the admin group.
Logged

Animor

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Re: phpbb3 admins are not recognized as admins in Coppermine
« Reply #2 on: November 19, 2010, 10:02:54 am »

Thank!
You are right, that was the issue. Being part of the "main admin" group is not enough. The user should have main admins group as his default group for being a Coppermine admin.

Is there another way to set Coppermine admins when bridging is enabled?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: phpbb3 admins are not recognized as admins in Coppermine
« Reply #3 on: November 19, 2010, 10:15:30 am »

Is there another way to set Coppermine admins when bridging is enabled?
See here.
Logged

Animor

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Re: phpbb3 admins are not recognized as admins in Coppermine
« Reply #4 on: November 19, 2010, 03:51:18 pm »

Thanks, issue is solved!
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: phpbb3 admins are not recognized as admins in Coppermine
« Reply #5 on: November 19, 2010, 07:02:19 pm »

Marking accordingly.
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 19 queries.