Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Invalid]: show albums error  (Read 3957 times)

0 Members and 1 Guest are viewing this topic.

boostdebugger

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
[Invalid]: show albums error
« on: October 15, 2010, 06:41:10 am »

user id: 2
bridge enable: NO

1) login as userid 2
2) create ablums
3) click my ablums, ref http://localhost/cpg15x/index.php?cat=10002
4) it show 0 pictures

print the sql statement:
$query = SELECT a.aid, count( p.pid ) AS pic_count, max( p.pid ) AS last_pid, max( p.ctime ) AS last_upload, a.keyword, a.alb_hits FROM cpg15x_albums AS a LEFT JOIN cpg15x_pictures AS p ON a.aid = p.aid AND p.approved = 'YES' WHERE a.category = 10002 GROUP BY a.aid ORDER BY a.pos, a.aid LIMIT 0,1

the key is: WHERE a.category = 10002, in fact it's category is 2
so, there is no result where execute this sql.

3ks
« Last Edit: October 15, 2010, 10:35:18 am by Αndré »
Logged

boostdebugger

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: show albums error
« Reply #1 on: October 15, 2010, 06:58:25 am »

user id: 2
bridge enable: NO
version:1.5.8

1) login as userid 2
2) create ablums
3) click my ablums, ref http://localhost/cpg15x/index.php?cat=10002
4) it show 0 pictures

print the sql statement:
$query = SELECT a.aid, count( p.pid ) AS pic_count, max( p.pid ) AS last_pid, max( p.ctime ) AS last_upload, a.keyword, a.alb_hits FROM cpg15x_albums AS a LEFT JOIN cpg15x_pictures AS p ON a.aid = p.aid AND p.approved = 'YES' WHERE a.category = 10002 GROUP BY a.aid ORDER BY a.pos, a.aid LIMIT 0,1

the key is: WHERE a.category = 10002, in fact it's category is 2
so, there is no result where execute this sql.

3ks
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: show albums error
« Reply #2 on: October 15, 2010, 10:35:05 am »

the key is: WHERE a.category = 10002, in fact it's category is 2
No. The user category is always 10000 + USER_ID, in your case 10002.

If you just create albums but don't upload any files, why should it display anything other than '0 pictures'?

Marking accordingly.
Logged

boostdebugger

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: [Invalid]: show albums error
« Reply #3 on: October 15, 2010, 11:16:07 am »

3ks for ur help
i have upload some pictures on it.
it show 0 pictres, but u can see them if click in.

but i open the database table, it shows category is 2.
what's wrong with me?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: [Invalid]: show albums error
« Reply #4 on: October 15, 2010, 11:25:29 am »

2) create ablums
Where exactly (in which category) do you create these albums? If you create them in your personal gallery, the category ID will be 10002. If you create them in a public category, the category ID will be the ID of that category.
Logged

boostdebugger

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: [Invalid]: show albums error
« Reply #5 on: October 15, 2010, 12:00:29 pm »

yes, the personal ablum shows 0 pictures?
is it right?? or by design?

3ks
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: [Invalid]: show albums error
« Reply #6 on: October 15, 2010, 01:16:00 pm »

Please answer my question:
Where exactly (in which category) do you create these albums?


Moving from bugs board to support board.
Logged

boostdebugger

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: [Invalid]: show albums error
« Reply #7 on: October 15, 2010, 01:46:45 pm »

i created these albums when i selected the *我的展厅*,
the lang key is: $lang_albmgr_php['my_gallery'] = '* 我的展厅 *'
page: \albmgr.php
version: 1.5.8
download date: yesterday
lang: chinese_gb
install lang: chinese_gb
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: [Invalid]: show albums error
« Reply #8 on: October 15, 2010, 02:09:21 pm »

Works for me as expected in my test gallery.

1. created album in '* My Gallery *'
2. uploaded picture to album
3. picture is visible in album (see attached screenshot)

Check your settings. Maybe you have enabled admin approval or something similar. As you don't give any information it's hard to help you.
Logged

boostdebugger

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: [Invalid]: show albums error
« Reply #9 on: October 15, 2010, 03:14:29 pm »

the user gallery shows numbers
but others category shows aways ZERO


admin approval option is be closed.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: [Invalid]: show albums error
« Reply #10 on: October 15, 2010, 03:27:26 pm »

Sorry, but I cannot work with your meaningless pictures and descriptions. Maybe someone else knows what you're talking about and what your actual problem is.

First you say your user gallery shows always '0 pictures'. Now you say that the picture count is correct for user galleries.

I'm out of this thread.
Logged

boostdebugger

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: [Invalid]: show albums error
« Reply #11 on: October 15, 2010, 03:30:29 pm »

i am sorry for my poor english.
thank you for ur help.
good day~
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 19 queries.