Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Mass deleting users  (Read 3579 times)

0 Members and 1 Guest are viewing this topic.

Josan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Mass deleting users
« on: October 03, 2010, 02:48:56 pm »

I used to check the last visited users on my coppermine and then mass delete whoever didn't visit in some period of time. But now I updated my coppermine to 1.5.8 and cannot mass edit anything anymore in the users section. Can't even delete one user. What am I overlooking? And I by now searched and browsed many of the topics in this forum but I simply cannot find any topic related to my question. Btw, your 'docs' page isn't updated to cpg1.5 ;) I'd no trouble updating my cp but I do notice the 'ter>' on the bottom of the page, would that be related to anything? My coppermine: http://simplybrad.com/images
Logged

Josan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Mass deleting users
« Reply #1 on: October 03, 2010, 03:08:36 pm »

Now I cannot login anymore, the 'OK' button won't do anything after signing in. I've not changed anything, I've deleted my cookies and rebooted my pc to attempt to log in again, but it does nothing. On the bottom of my browser it says that the page has loaded but with an error, no idea what error since I didn't do anything. Please help me.
Logged

Nibbler

  • Guest
Re: Mass deleting users
« Reply #2 on: October 03, 2010, 03:14:10 pm »

Looks like you have some corrupted files. Upload clean copies. What docs page are you referring to?
Logged

Josan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Mass deleting users
« Reply #3 on: October 03, 2010, 03:18:17 pm »

Thank you for replying so fast Nibbler. I am right now uploading the cpg1.5.8 again, I suppose those are the clean copies you were referring to? Though it's repeating the process since I did this the same way earlier. Updating the way that is described on the official cp page. Will reply soon, to let you know if that fixed the problem.

The docs I mentioned is the link you get from the Posting Rules ;)
Logged

Josan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Mass deleting users
« Reply #4 on: October 03, 2010, 03:25:35 pm »

Updated, still the same error. What to do?
Logged

Josan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Mass deleting users
« Reply #5 on: October 03, 2010, 03:28:40 pm »

Quote
Foutdetails webpagina

Gebruikersagent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6.5; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
Tijdstempel: Sun, 3 Oct 2010 13:30:40 UTC


Bericht: 'document.loginbox.username' is empty or no object
Regel: 126
Teken: 1
Code: 0
URI: http://www.bradpittgallery.com/login.php?referer=versioncheck.php

That's the apparent error?
Logged

Nibbler

  • Guest
Re: Mass deleting users
« Reply #6 on: October 03, 2010, 03:29:24 pm »

I think this is actually a bug. Please modify your copy of include/functions.inc.php and change

Code: [Select]
    $gallery_pos = strpos($template, '{GALLERY}');

    // Failsafe-option if JAVASCRIPT-token is missing from custom theme
    if (strpos($template, '{JAVASCRIPT}') === FALSE) {
        if (stripos($template, '</head>') !== FALSE) {
            $template = str_ireplace('</head>', '{JAVASCRIPT}' . $LINEBREAK . '</head>', $template);
        } elseif (stripos($template, '<head>') !== FALSE) {
            $template = str_ireplace('<head>',  '<head>' . $LINEBREAK .'{JAVASCRIPT}', $template);
        } elseif (stripos($template, '</title>') !== FALSE) {
            $template = str_ireplace('</title>', '</title>' . $LINEBREAK . '{JAVASCRIPT}', $template);
        }
    }

to

Code: [Select]
    // Failsafe-option if JAVASCRIPT-token is missing from custom theme
    if (strpos($template, '{JAVASCRIPT}') === FALSE) {
        if (stripos($template, '</head>') !== FALSE) {
            $template = str_ireplace('</head>', '{JAVASCRIPT}' . $LINEBREAK . '</head>', $template);
        } elseif (stripos($template, '<head>') !== FALSE) {
            $template = str_ireplace('<head>',  '<head>' . $LINEBREAK .'{JAVASCRIPT}', $template);
        } elseif (stripos($template, '</title>') !== FALSE) {
            $template = str_ireplace('</title>', '</title>' . $LINEBREAK . '{JAVASCRIPT}', $template);
        }
    }

    $gallery_pos = strpos($template, '{GALLERY}');

ie. move that first line so that it comes after that block of code instead of before it.
Logged

Josan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Mass deleting users
« Reply #7 on: October 03, 2010, 04:02:15 pm »

Nibbler, I did as you suggested but I don't notice a change, I still cannot login or press the 'OK' button to. It does recognize my login info though cuz when I /update.php it accepts the information. The same problem happens at my other coppermine.
Logged

Josan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Mass deleting users
« Reply #8 on: October 03, 2010, 05:43:42 pm »

My friend and everyone else seems to be able to log in so that's a relieve. But how do I fix my pc so I can login too, Nibbler?
Logged

Nibbler

  • Guest
Re: Mass deleting users
« Reply #9 on: October 03, 2010, 06:10:54 pm »

Logged

Josan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Mass deleting users
« Reply #10 on: October 03, 2010, 06:14:39 pm »

Thank you, that solved it for me, I can log in. Thank you very much.

That also fixes my original problem of not being able to mass edit users. Thanks Nibbler! Thread is solved :)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Mass deleting users
« Reply #11 on: October 12, 2010, 02:40:17 pm »

Thread is solved
Marking accordingly.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 21 queries.