Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Fatal Error/Debug won't work  (Read 6060 times)

0 Members and 1 Guest are viewing this topic.

HazelFlagg

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Fatal Error/Debug won't work
« on: September 10, 2010, 09:20:02 pm »

Hi---

I'm usually more of a lurker around here but I've read the docs and searched the forum and couldn't find an answer for this.

My gallery shows up "Fatal Error" when you pull it up. I came on here and did as the docs instructed, went to my phpMyAdmin, went in the config and changed the debug value to 1 instead of 0. Nothing has changed...still a white screen with "Fatal Error" and nothing else...it didn't show any more info, doesn't seem that debug is working.  :(

Here is my gallery: [urlhttp://dearmrgable.com/gallery/index.php][/url]

Any help would be appreciated!
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Fatal Error/Debug won't work
« Reply #1 on: September 10, 2010, 09:51:22 pm »

Try an upgrade as you seem to be running 1.4.24
http://dearmrgable.com/gallery/docs/
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

HazelFlagg

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Fatal Error/Debug won't work
« Reply #2 on: September 10, 2010, 10:49:20 pm »

I thought that might be it and tried to do that but when I point my browser to the update.php file, it displays a chart and everything next to it says "Ok" or "Already Done" and the bottom says "Update Completed" even though it isn't. And I can't do a version check either, says Fatal Error. ???
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Fatal Error/Debug won't work
« Reply #3 on: September 11, 2010, 12:32:12 am »

When I say upgrade I mean follow these instructions =>
http://documentation.coppermine-gallery.net/en/upgrading.htm#upgrade_any
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

HazelFlagg

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Fatal Error/Debug won't work
« Reply #4 on: September 11, 2010, 02:54:31 am »

That's what I tried to do. But when I get to this part---> http://yoursite.tld/your_coppermine_folder/update.php it acts like it already upgraded.
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Fatal Error/Debug won't work
« Reply #5 on: September 11, 2010, 05:46:29 am »

sending pm for admin.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

HazelFlagg

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Fatal Error/Debug won't work
« Reply #6 on: September 11, 2010, 06:04:07 am »

Well I finally got the upgrade to work. Docs now say 1.5. But I still have this fatal error and the debug still won't work.  :-[
Logged

HazelFlagg

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Fatal Error/Debug won't work
« Reply #7 on: September 11, 2010, 06:14:33 am »

I got your pm but the site says I am not allowed to send personal messages. ??
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Fatal Error/Debug won't work
« Reply #8 on: September 11, 2010, 06:20:20 am »

thats why my email is in it.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

HazelFlagg

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Fatal Error/Debug won't work
« Reply #9 on: September 11, 2010, 04:35:48 pm »

Oops. Sorry. I see that now.
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Fatal Error/Debug won't work
« Reply #10 on: September 13, 2010, 03:47:13 am »

You had not turned debug mode on.

The real error is
Code: [Select]
While executing query 'DELETE FROM `dmg`.gallery_sessions WHERE time < 1284338618 AND remember = 0' in bridge/coppermine.inc.php on line 248
mySQL error: Can't open file: 'gallery_sessions.MYI' (errno: 145)
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Fatal Error/Debug won't work
« Reply #11 on: September 13, 2010, 03:54:13 am »

Performed SQL
Code: [Select]
REPAIR TABLE gallery_sessionsYour gallery works now.

Your antique theme didn't work so I changed it to Curve. It probably needs to be upgraded for 1.5.x, please open a new thread if you would like help with that.

please resolve your thread as outlined here => http://forum.coppermine-gallery.net/index.php/topic,55415.msg270631.html#msg270631
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

HazelFlagg

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Fatal Error/Debug won't work
« Reply #12 on: September 13, 2010, 05:08:14 am »

THANK YOU so much!! That was way over my head.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 19 queries.