Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Resend activation link doesn't work - Selected user does not exist!  (Read 5249 times)

0 Members and 1 Guest are viewing this topic.

ArnieW

  • Coppermine newbie
  • Offline Offline
  • Posts: 14

I recognized, that the Resend activation link doesn't work on my page.
I tried a few email addresses of registered / active users and it always returns with the error message: Selected user does not exist!
To check this error I created a user: Coppermine with the password: test and email address: a@b.com. The webpage is: www.cudgenschool.com
Thanks for your help
Arnie
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

ArnieW

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #2 on: September 09, 2010, 06:28:09 am »

I finished the update, but the problem still occurs, the Resend activation link still doesn't work.
Any more ideas?
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #3 on: September 09, 2010, 06:42:12 am »

Did you remember to run update.php and check your file versions?
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #4 on: September 09, 2010, 06:51:53 am »

Hmm nevermind. I'm seeing this on my test gallery as well maybe its a bug. Let me do some more research.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #5 on: September 09, 2010, 08:27:46 am »

Try it with the username of a user with a real email address. It looks like the language string is wrong or the code is wrong. I'm gonna wait for a dev to confirm this but I'll look through the code and post what I find.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

ArnieW

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #6 on: September 09, 2010, 08:44:13 am »

Hi Jeff
I tried it with a real user with real email address. It still don't work!
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #7 on: September 09, 2010, 08:45:56 am »

you tried the username ... instead of typing the email?
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #8 on: September 09, 2010, 08:52:27 am »

It looks like the language string is wrong or the code is wrong
I cannot see any problem here:
Code: [Select]
    $emailaddress = $superCage->post->testEmail('email');

    $sql = "SELECT user_id, user_group, user_active, user_name, user_email, user_actkey FROM {$CONFIG['TABLE_USERS']} WHERE user_email = '$emailaddress' AND user_active = 'NO'";
It doesn't work if the user is already activated.
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #9 on: September 09, 2010, 08:55:31 am »

It doesn't work if the user is already activated.
:-[  well that makes perfect sense. I feel like an idiot now.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #10 on: September 09, 2010, 08:55:58 am »

Maybe the string
Quote
Selected user does not exist!
should be changed to something like
Quote
Selected user does not exist or is already activated!
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #11 on: September 09, 2010, 09:10:57 am »

@André
Works for me when the user is not activated, like you said.
Also I would agree the string needs to be changed or a note added to the docs.

@Arnie
please confirm that the user is not currently activated by looking at the lightbulbs in the user manager.

Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

ArnieW

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #12 on: September 09, 2010, 09:37:24 am »

Hi Andre
Something is going totally wrong here!
First, yes when a user is still "not active" the link works.

But look at this scenery:
-visitor fills in the register form and submit -> this visitor is now a "not active" user
-In config settings/User registration requires email verification this is hooked, means I want to make the decide if this user becomes activ.
-But why waiting for administrator if he ("not active" user) can just click the  Resend activation link than enter his email and that way active his account himself.

I just gave it a go: registered a new user -> clicked resend activation link -> entered email address of new user -> email has send by Coppermine Gallery to new user email account -> click on the activation link in this email -> account of new user is now active without any doing of the administrator.

?????????
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #13 on: September 09, 2010, 10:02:31 am »

Please enable Admin activation of registrations and disable User registration requires email verification.
Logged

ArnieW

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #14 on: September 09, 2010, 10:22:35 am »

Thank you Andre, thank you Jeff
It is all working the way it mend to!
Now that I know what the settings have to be, I actually understand what the "description" to the setting mean.
I thought It would be good to add the information, that User registration requires email verification is a email address misuse protection, and it doesn't need Administrator permission.
BUt reading it again is says email verification.
Seems to be the problem me beeing a german living in a english speaking country and still not able to understand this language ::)
Thanks for you help +++++++++
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #15 on: September 09, 2010, 10:30:36 am »

'email verification' is used in every software where users need to click an activation link which is sent by email. No need for further description imo.
Logged

ArnieW

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Resend activation link doesn't work - Selected user does not exist!
« Reply #16 on: September 09, 2010, 11:01:38 am »

I absolutely agree!!
But I like to recommend, to change the order in config/registration:

-Admin activation of registrations
- if "Admin activation of registrations" is not selected:  User registration requires email verification

When using Admin activation of registrations, User registration requires email verification is not necessary as the confirmation email beeing send to the provided email address.

Just an idea

Thanks again
Arnie
Logged
Pages: [1]   Go Up
 

Page created in 0.118 seconds with 19 queries.