Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Performance issues after upgrade 1.4x to 1.5x  (Read 2436 times)

0 Members and 1 Guest are viewing this topic.

Jokke_K

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Performance issues after upgrade 1.4x to 1.5x
« on: December 01, 2010, 12:19:41 am »

Hello,

We upgraded our gallery from 1.4.x to 1.5x (now 1.5.10) and after that we faced huge increase in server load. Our gallery has ~7K usr, 43K pics, 188K comments, server is dedicated 2,33 Ghz Quadcore Xeon with 8 GB RAM and 5x146GB 15K SAS hard drives. URL: http://www.fireimages.net

I have disabled almost everything (and now we don't have Private messages for example), but still server load was 10x higher in this evening compared to situation two weeks ago.

We have created database indexes and tried to optimize the situation, but load is still too heavy and database queries are very slow. I'm not able to remove lastcom and lastup meta albums due to user demand, but every other hint or suggestion how to optimize or limit database queries would be very helpful.
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1510
  • aka 'i-imagine'
    • Home Page
Re: Performance issues after upgrade 1.4x to 1.5x
« Reply #1 on: December 01, 2010, 05:35:25 am »

URL: http://www.fireimages.net
Does not help much if a login is required to navigate the gallery.

I have disabled almost everything
No, you have a few plugins running. One of which is: Who is online? (onlinestats).
I vaguely remember reading somewhere that it creates a lot of queries when there are many users. (I very well could be wrong)
It runs on every category page so I would suggest for that plugin and any others you have running.
1) Look at what the output of your debug tells you. (please don't post it)
2) Show onlinestats only on the home page,try this plugin   

Without any more to go on that is all.
Post a user and password and maybe someone can help.

Jokke_K

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Performance issues after upgrade 1.4x to 1.5x
« Reply #2 on: December 01, 2010, 07:26:27 am »

Does not help much if a login is required to navigate the gallery.
No, you have a few plugins running. One of which is: Who is online? (onlinestats).
Post a user and password and maybe someone can help.

Sorry, late night and...

user: testi
pwd: coppermine

TL
Logged

Nibbler

  • Guest
Re: Performance issues after upgrade 1.4x to 1.5x
« Reply #3 on: December 01, 2010, 10:02:01 am »

See http://documentation.coppermine-gallery.net/en/performance.htm#perf_tips

If the issue is slow queries you need to enable slow query logging in MySQL and check the mysqldumpslow output.
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.