Advanced search  


CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Cannot upload image via URI/URL Upload  (Read 8325 times)

0 Members and 1 Guest are viewing this topic.


  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Cannot upload image via URI/URL Upload
« on: August 23, 2010, 11:57:59 pm »


I recently switched servers, and now I'm not able to upload an image from another site such as imageshack via the URI/URL Uploads option. I've tried working with my new server company about this, and they said that it wasn't an issue on their end and to contact Coppermine. I've set up a test account for my gallery so that you can take a look and see what the error is. The log in info is as follows:

admin: test
password: test1

The test account is allowed to upload images to the User Galleries section at the top of the gallery once you've logged in. The gallery can be found here:

Here's an example of what I've been trying to upload:

When I click Upload File and then enter the above imageshack URL into the URI/URL Upload field, I get an error message that says: 0 Uploads were successful.

I have enabled debug mode, too, so that you can see more of the error messages. I hope this helps. Thanks in advance for any assistance you can give me. It is greatly appreciated!

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1545
  • aka 'i-imagine'
    • Home Page
Re: Cannot upload image via URI/URL Upload
« Reply #1 on: August 24, 2010, 01:20:42 am »

Please do not hot-link images, attach them to your posting.

You need to follow the instructions in your document package:
Upload Troubleshooting
Asking for Support on Upload issues.

Please return only after you have followed all of the steps.


  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4886
Re: Cannot upload image via URI/URL Upload
« Reply #2 on: August 24, 2010, 01:27:06 am »

There are many reasons why the URL upload may not work and most of these are server issues. Do a search on the forums and you will find many posts detailing why and some workarounds.
It is a mistake to think you can solve any major problems just with potatoes.


  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Cannot upload image via URI/URL Upload
« Reply #3 on: August 24, 2010, 06:47:31 am »


Thank you for getting back to me. I would like to apologize for hot-linking to the image. I actually had been reading the forums here at Coppermine in the hopes of finding a solution to this problem without having to start a new thread, but to no avail. I took another look at the links that Joe mentioned in his reply, and even after trying a few other things I am still unable to upload via URI/URL Upload. Every workaround I've tried just doesn't seem to be working, and everything in the php.ini and files on my server is exactly as it should be. I just don't know what could be causing this problem, so I went back to my server company and gave them an update on what I had done to try and resolve this matter, and here is what they said:

Thank you for getting back to us. I am sorry that you are having problems with Coppermine. Unfortunately I was not able to resolve your issue. I have checked and double checked the server site to make sure the settings are correct for what Coppermine requires per there error page. The information listed at the Coppermine error page on how to resolve this issue has been all set correctly. Look in the section: No file was uploaded ! If you have really selected a file to upload, check that the server allows file uploads...

There you will see what it requires to resolve this issue. You can check yourself to see that the settings are all set to the correct config by going to this link:

If you go to that link and search for the settings that was listed in Coppermine error page:

You will see they are all configured with the correct information. For the upload_max_filesize it says that you need only 2m but you have a limit of 256m which is well above the 2m limit.

I am sorry we can not provide any further assistance with this issue. I would make sure you have the most updated version of Coppermine and then try again. Also when I tried to upload it never really gave any errors. It just stated there was a problem with the image. I tried several image urls with no luck. If you contact Coppermine again I would point them to and have them look that the settings are correct on our end.

I would greatly appreciate any assistance that you can give me in resolving this matter.

Thank you so much.
Pages: [1]   Go Up

Page created in 0.045 seconds with 20 queries.