Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: cut from sample theme.php method for custom menu gives blank page  (Read 3694 times)

0 Members and 1 Guest are viewing this topic.

kenw

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 2
    • In the Frame Photography

I am building a website, listed on my profile. It's written using frames, with Coppermine as a sub-frame. I want to change that so Coppermine is the main page, and migrate two main menu items (about_us and location) into the Coppermine menu. I have already created a custom theme in the recommended way, by copying from themes/sample and modifying style.css and theme.php. I did a few searches on the subject of custom menus, and concluded that I should cut and paste Section <<<$template_sys_menu>>> and Section <<<$template_sub_menu>>> into my theme.php file for modifications. When I do this and upload the file, my gallery page shows a blank screen. I didn't yet make any mods to the sections. I also tried copying the addbutton procedure and Section <<<THEME_HAS_NO_SUB_MENU_BUTTONS>>> , but that didn't change anything. I always pasted them before my other changes. Everything is normal when I remove all the menu sections. What have I missed? I enclose my theme.php file...
Logged

kenw

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 2
    • In the Frame Photography
Re: cut from sample theme.php method for custom menu gives blank page
« Reply #1 on: August 09, 2010, 04:55:25 pm »

It works now. Seems like I didn't include Section <<<assemble_template_buttons>>> . I thought I tried that before, but sometimes something that works Monday morning, couldn't possibly work on Sunday night. Maybe it's the coffee.
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 20 queries.