Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Unable to use Flash Upload  (Read 8999 times)

0 Members and 1 Guest are viewing this topic.

djcascao

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Unable to use Flash Upload
« on: August 01, 2010, 01:43:43 am »

Hi there, i'm from Brazil and I have a new instalation of coppermine on www.odeiotic.com.br
I'm facing some trouble if I try to use Flash upload.
bellow are the "debug info"...

I'm facing the same problem.
I already take a look onto my /album folder and there is no problem there.
this is the message that appears to me:

SWF DEBUG: SWFUpload Init Complete
SWF DEBUG:
SWF DEBUG: ----- SWF DEBUG OUTPUT ----
SWF DEBUG: Build Number:           SWFUPLOAD 2.2.0
SWF DEBUG: movieName:              SWFUpload_0
SWF DEBUG: Upload URL:             /upload.php
SWF DEBUG: File Types String:      *.*
SWF DEBUG: Parsed File Types:     
SWF DEBUG: HTTP Success:           0
SWF DEBUG: File Types Description: All Files (*.*)
SWF DEBUG: File Size Limit:        5120000 bytes
SWF DEBUG: File Upload Limit:      0
SWF DEBUG: File Queue Limit:       0
SWF DEBUG: Post Params:
SWF DEBUG:                         process=1
SWF DEBUG:                         user=YToyOntzOjc6InVzZXJfaWQiO3M6MToiMSI7czo5OiJwYXNzX2hhc2giO3M6MzI6IjY2OTY4MzFhMmEzNWI0YmI0ZTk0MWZlYzQ5YjNhMWZlIjt9
SWF DEBUG: ----- END SWF DEBUG OUTPUT ----
SWF DEBUG:
SWF DEBUG: Event: fileDialogStart : Browsing files. Multi Select. Allowed file types: *.*
SWF DEBUG: Select Handler: Received the files selected from the dialog. Processing the file list...
SWF DEBUG: Event: fileQueued : File ID: SWFUpload_0_0
SWF DEBUG: Event: fileDialogComplete : Finished processing selected files. Files selected: 1. Files Queued: 1
SWF DEBUG: StartUpload: First file in queue
SWF DEBUG: Event: uploadStart : File ID: SWFUpload_0_0
SWF DEBUG: Global Post Item: process=1
SWF DEBUG: Global Post Item: album=2
SWF DEBUG: Global Post Item: user=YToyOntzOjc6InVzZXJfaWQiO3M6MToiMSI7czo5OiJwYXNzX2hhc2giO3M6MzI6IjY2OTY4MzFhMmEzNWI0YmI0ZTk0MWZlYzQ5YjNhMWZlIjt9
SWF DEBUG: ReturnUploadStart(): File accepted by startUpload event and readied for upload.  Starting upload to /upload.php for File ID: SWFUpload_0_0
SWF DEBUG: Event: uploadProgress (OPEN): File ID: SWFUpload_0_0
SWF DEBUG: Event: uploadProgress: File ID: SWFUpload_0_0. Bytes: 44620. Total: 44620
SWF DEBUG: Event: uploadError: HTTP ERROR : File ID: SWFUpload_0_0. HTTP Status: 406.
SWF DEBUG: Event: uploadComplete : Upload cycle complete.
Error Code: HTTP Error, File name: 03-12-06_1345.jpg, Message: 406


anyone can assist me?!
Best Regards
Cassiano
Logged

villas

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 11
Re: Unable to use Flash Upload
« Reply #1 on: August 01, 2010, 04:40:50 pm »

I have the same problem but with 403 wen update from 1.4 to 1.5.6

SWF DEBUG: Event: uploadProgress (OPEN): File ID: SWFUpload_0_2
SWF DEBUG: Event: uploadProgress: File ID: SWFUpload_0_2. Bytes: 276216. Total: 276216
SWF DEBUG: Event: uploadError: HTTP ERROR : File ID: SWFUpload_0_2. HTTP Status: 403.
SWF DEBUG: Event: uploadComplete : Upload cycle complete.
Error Code: HTTP Error, File name: Autumn Leaves.jpg, Message: 403

Im serching a lot and nothing.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4826
    • Windsurf.me
Re: Unable to use Flash Upload
« Reply #2 on: August 01, 2010, 05:53:57 pm »

Villas, your problem is different so please start your own thread.

I answer to the first users problem, please follow all the guidelines here - http://documentation.coppermine-gallery.net/en/upload_troubleshooting.htm#upload_trouble

Additionally, read this - http://www.checkupdown.com/status/E406.html
Logged
It is a mistake to think you can solve any major problems just with potatoes.

djcascao

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Unable to use Flash Upload
« Reply #3 on: August 01, 2010, 10:59:01 pm »

Phill thanks 4 the feedback.
I've already tried everithing that is asked on uploading troubleshooting, but, on that it appears to use "non flash upload" on the tutorial, and if I try that the problem doesn't occurs.
I'm facing problem just with the flash upload.

Br,
Cassiano
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4826
    • Windsurf.me
Re: Unable to use Flash Upload
« Reply #4 on: August 01, 2010, 11:02:45 pm »

We are aware of that but we need the suggested settings in place and a test account, debug enabled etc for our test purposes.

Also, look at your phpinfo and see if mod_security is enabled. If it is that could be the culprit on your web server. You might have to speak to your host if that is the case or you could try adding a .htaccess file along the lines of

Code: [Select]
<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

However, I could be barking up the wrong tree here.
« Last Edit: August 01, 2010, 11:09:01 pm by Phill Luckhurst »
Logged
It is a mistake to think you can solve any major problems just with potatoes.

djcascao

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Unable to use Flash Upload
« Reply #5 on: August 02, 2010, 02:14:16 pm »

Hi Phill
www.odeiotic.com.br
test user account:
Username
Test
PassWord
Test
Debug on

Cheers,
cassiano
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4826
    • Windsurf.me
Re: Unable to use Flash Upload
« Reply #6 on: August 02, 2010, 03:14:17 pm »

Have you checked that php mod_security?
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Snowcamper

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Unable to use Flash Upload
« Reply #7 on: August 09, 2010, 02:24:10 pm »

@Phill Luckhurst

Thanks for the .htaccess tip!!!  :)

I had the same error message (403) when I was trying to use flash upload (the normal upload worked fine). I added your code into my .htaccess file and now the flash upload is working perfect!

I've installed coppermine just yesterday and I'm absolutely happy with it so far! Great work!  :)
Logged

villas

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 11
Re: Unable to use Flash Upload
« Reply #8 on: August 09, 2010, 02:34:48 pm »

Where (folder) do you put de .htaccess ?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Unable to use Flash Upload
« Reply #9 on: August 16, 2010, 03:19:44 pm »

Where (folder) do you put de .htaccess ?
Upload it to your gallery root directory.
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.