Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Empty gallery after upgrading  (Read 2900 times)

0 Members and 1 Guest are viewing this topic.

gustaf

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Empty gallery after upgrading
« on: July 31, 2010, 02:49:46 pm »

I just updated from 1.4.27 to 1.5.6. I used the FTP in Windows Vista Explorer.

http://www.scrabbleforbundet.se/album/index.php

Now all albums are gone. What did I do wrong?
I didn't replace the albums directory while upgrading. I ran the update.php file.

I did a version check, and it said I was missing two files: albums/edit/index.php and albums/userpics/index.php
So I uploaded those files from the installation package, but it didnīt solve the problem.

The version checker also said my anycontent.php whas old. Wasnīt I supposed to keep the old version of that file when updating?
Anyway, I replaced the old anycontent.php with the new one, and now the version checker is happy. But still no albums.
Logged

gustaf

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Empty gallery after upgrading
« Reply #1 on: July 31, 2010, 08:31:36 pm »

I installed the old forum again so now I am back where I started.
I still don't know what I did wrong, but I will try it again.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4822
    • Windsurf.me
Re: Empty gallery after upgrading
« Reply #2 on: July 31, 2010, 09:11:03 pm »

Firstly, don't use vista explorer. Use filezilla as your ftp app.

You obviously backed up so well done with that. Disable your bridge before you start then delet everything in your coppermine folder except your include/config.inc.php , your albums folder and your anycontent.php

Upload all the cpg 1.5.6 files.

browse to update.php and let the script run.

That should be it. If that works then go through your settings and check everything works as expected before restoring your bridge. Finally after testing again install any new plugins and your custom theme (upgraded to 1.5.x)
Logged
It is a mistake to think you can solve any major problems just with potatoes.
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 20 queries.