Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: {} Variables aren't working.  (Read 2574 times)

0 Members and 1 Guest are viewing this topic.

Sw0rDz

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 5
{} Variables aren't working.
« on: July 24, 2010, 05:25:37 am »

I'm not sure if this the right board and feel free to move it.  I can't get any of the {}'s variables to work!  So I decide to hard-code all the links for my navigation, and I'm having trouble with some of the links, especially logut.

So I see that in my theme.php I have $template_sys_menu defined and define('THEME_HAS_NO_SYS_MENU_BUTTONS', 1); near the <?, ignoring comments.  It won't show any of the links or the code!

However, I do use pageheader(); and that's being used.  I'm thinking conflicting with this.

Code: [Select]
function pageheader($section, $meta = '')
{

global $CONFIG;
include('config.php');

$title = $CONFIG['gallery_name'];
$description = $CONFIG['gallery_description'];
$keywords = "zelda, legend, dungeon, artwork, pictures, photographs";

if(isset($CURRENT_PIC_DATA) )
{
$keywords .= ", " . $CURRENT_PIC_DATA['keywords'] . ", " . $CURRENT_PIC_DATA['title'];
$title .= " - " . $CURRENT_PIC_DATA['title'];
}

$extraheader[] = "<link rel=\"stylesheet\" href=\"css/coppermine.css\" type=\"text/css\" />";
$extraheader[] = "<link rel=\"stylesheet\" href=\"themes/19Dungeon/style.css\" type=\"text/css\" />";
$extraheader[] = theme_javascript_head();
include('header.php');


}

The header, config are files that I need to be included because they're being used other files to keep site consistency.

Thanks!
Logged

papukaija

  • Contributor
  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 333
Re: {} Variables aren't working.
« Reply #1 on: August 26, 2010, 10:23:33 pm »

Please post a link to your gallery as requested by board rules.
Logged

Sw0rDz

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Posts: 5
Re: {} Variables aren't working.
« Reply #2 on: August 27, 2010, 05:40:54 am »

I've got it to work now.  It was when I was overwriting the function that handle the header.  I did a custom header, which it included a .php file that I used to handle my header.  Thanks for the reply though!
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 21 queries.