Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: 1.5.6 - Ban IP gives error  (Read 4188 times)

0 Members and 1 Guest are viewing this topic.

TeknoSounds

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 83
    • TeknoSounds
1.5.6 - Ban IP gives error
« on: July 21, 2010, 09:00:55 am »

Attempting to ban via IP gives me an error stating "Enter a valid IP address (x.x.x.x)" despite it being properly formatted as x.x.x.x. 

http://teknosounds.com/tspics/

TeknoSounds

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 83
    • TeknoSounds
Re: 1.5.6 - Ban IP gives error
« Reply #1 on: July 21, 2010, 09:29:39 am »

just upgraded to latest SVN and retried, still gives an error when attempting to enter an IP address.

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: 1.5.6 - Ban IP gives error
« Reply #2 on: July 21, 2010, 10:51:29 am »

Works for me as expected. Maybe your IP address is invalid? Which address do you try to ban?
Logged

TeknoSounds

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 83
    • TeknoSounds
Re: 1.5.6 - Ban IP gives error
« Reply #3 on: July 21, 2010, 01:58:03 pm »

It hasn't actually been working since I upgraded to 1.5.4.

I remember trying a spammer's IP and it didn't work.  For testing purposes I was trying an IP that was already in the DB but I modified it slightly.
In this case it was 76.176.120.170

I'm attempting to enter it in the 3'd text box at the bottom where it says Add New Ban

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: 1.5.6 - Ban IP gives error
« Reply #4 on: July 21, 2010, 02:19:04 pm »

I wonder why the error appears at your ban record #84. It seems that Coppermine has a problem with that record for some reason. I've also banned that IP address in my testbed: everything works as expected.

Can you send me a database dump of your ban table? Maybe I find something odd.

Are you able to add some other IP addresses?
Logged

TeknoSounds

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 83
    • TeknoSounds
Re: 1.5.6 - Ban IP gives error
« Reply #5 on: July 22, 2010, 05:13:52 am »

Okay did a bit of further testing.  I went to another page of my listed IPs and the error didn't appear...I guess it doesn't like that one record?

attaching the db dump for the banned list.

TeknoSounds

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 83
    • TeknoSounds
Re: 1.5.6 - Ban IP gives error
« Reply #6 on: July 22, 2010, 05:17:00 am »

deleted that one IP from the database (wouldn't let me from the list, kept erroring) and now not seeing any errors when attempting to ban a user.  Here's the IP it was having a problem with:

69.93.234.205

TeknoSounds

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 83
    • TeknoSounds
Re: 1.5.6 - Ban IP gives error
« Reply #7 on: July 22, 2010, 05:18:34 am »

sorry for the multiple replies...keep responding then finding something to test.


I readded the offending IP to the list and no problem with it.  Something was wrong with the record entry I guess?

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: 1.5.6 - Ban IP gives error
« Reply #8 on: July 22, 2010, 08:55:31 am »

I haven't tested your dump, as it works for you now.

Something was wrong with the record entry I guess?
I suggest not to think about that further ;)
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.