Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Re: "Fatal Error" upgrade 1.4.27 to 1.5.6 - how I fixed it.  (Read 3082 times)

0 Members and 1 Guest are viewing this topic.

TCWORLD

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21

I am upgrading from 1.4.22 to 1.5.6. As per the upgrade documentations, I save all the 1.4.22 by downloading them to my HDD using FileZilla. I then copied the new files except for the /album/ folder (which i kept on my server from 1.4.22), and the anycontent.php.

I have tried then running the update.php script, but nothing happens. I get the following:

"""
Template error
Failed to find block 'exif_manager' (#<!-- BEGIN exif_manager -->(.*?)<!-- END exif_manager -->#s) in :

                <div align="center">
                <table cellpadding="0" cellspacing="1">
                        <tr>

                                <td class="admin_menu"><a href="admin.php" title="{ADMIN_TITLE}">{ADMIN_LNK}</a></td>
                                <td class="admin_menu"><a href="catmgr.php" title="{CATEGORIES_TITLE}">{CATEGORIES_LNK}</a></td>
                                <td class="admin_menu"><a href="albmgr.php{CATL}" title="{ALBUMS_TITLE}">{ALBUMS_LNK}</a></td>
                                <td class="admin_menu"><a href="groupmgr.php" title="{GROUPS_TITLE}">{GROUPS_LNK}</a></td>
                                <td class="admin_menu"><a href="usermgr.php" title="{USERS_TITLE}">{USERS_LNK}</a></td>
                                <td class="admin_menu"><a href="banning.php" title="{BAN_TITLE}">{BAN_LNK}</a></td>
                                <td class="admin_menu"><a href="reviewcom.php" title="{COMMENTS_TITLE}">{COMMENTS_LNK}</a></td>
                                </tr><tr>
<!-- BEGIN log_ecards -->
                                <td class="admin_menu"><a href="db_ecard.php" title="{DB_ECARD_TITLE}">{DB_ECARD_LNK}</a></td>
<!-- END log_ecards -->
                                <td class="admin_menu"><a href="picmgr.php" title="{PICTURES_TITLE}">{PICTURES_LNK}</a></td>
                                <td class="admin_menu"><a href="searchnew.php" title="{SEARCHNEW_TITLE}">{SEARCHNEW_LNK}</a></td>
                                <td class="admin_menu"><a href="util.php" title="{UTIL_TITLE}">{UTIL_LNK}</a></td>
                                <td class="admin_menu"><a href="profile.php?op=edit_profile" title="{MY_PROF_TITLE}">{MY_PROF_LNK}</a></td>
<!-- BEGIN documentation -->
                                <td class="admin_menu"><a href="{DOCUMENTATION_HREF}" title="{DOCUMENTATION_TITLE}" target="cpg_documentation">{DOCUMENTATION_LNK}</a></td>
<!-- END documentation -->
                        </tr>
                </table>
                </div>
"""


If anyone else gets this, there is a simple solution. If is 1.4.xx you had a custom theme, go into the themes folder, backup the custom theme, then copy the files of the 1.4.xx classic theme into that folder. The script should then run - though all the fomatting is messed up - don't worry theough, once the script has completed, select one of the new themes. I am not sure if you can use your old theme with 1.5. Can you??
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: "Fatal Error" upgrade 1.4.27 to 1.5.6 - how I fixed it.
« Reply #1 on: July 16, 2010, 06:52:56 pm »

If anyone else gets this, there is a simple solution.
That's a generic erro that can be caused by several things, that's why you suggestion doesn't necessarilly have to apply for others.

If is 1.4.xx you had a custom theme, go into the themes folder, backup the custom theme, then copy the files of the 1.4.xx classic theme into that folder. The script should then run - though all the fomatting is messed up - don't worry theough, once the script has completed, select one of the new themes.
Nonsense. Do as suggested in the docs we provide. We provide them for a reason. In your particular case, read the upgrade section of the docs carefully, particularly http://documentation.coppermine-gallery.net/en/upgrading.htm#upgrade_14_custom_theme

I am not sure if you can use your old theme with 1.5. Can you??
RTFM - especially the section I refered to above. It explains how to upgrade your custom theme.

You shouldn't have hijacked an unrelated thread that dealt with something completely else - I have split your posting from it into a thread of it's own. You should have read board rules and do as suggested there instead.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 20 queries.