Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Invalid]: Upgrade from 1.4 failed  (Read 5297 times)

0 Members and 1 Guest are viewing this topic.

anewday

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
[Invalid]: Upgrade from 1.4 failed
« on: July 05, 2010, 04:53:37 am »

Hello, I'm trying to upgrade my coppermine gallery from version 1.4.18 to 1.5.6. I uploaded all the files except the albums folder from the cpg1.5.6.zip file then ran update.php in the web browser. After the first step of inputting the database name, user, password, etc. The following error is shown.

Code: [Select]
mySQL Error: Table 'cpg11d_albums' already exists on query ' CREATE TABLE cpg11d_albums ( aid int(11) NOT NULL auto_increment, title varchar(255) NOT NULL default '', description text NOT NULL, visibility int(11) NOT NULL default '0', uploads enum('YES','NO') NOT NULL default 'NO', comments enum('YES','NO') NOT NULL default 'YES', votes enum('YES','NO') NOT NULL default 'YES', pos int(11) NOT NULL default '0', category int(11) NOT NULL default '0', owner int(11) NOT NULL DEFAULT '1', thumb int(11) NOT NULL default '0', keyword VARCHAR( 50 ), alb_password VARCHAR( 32 ), alb_password_hint TEXT, moderator_group INT NOT NULL default 0, alb_hits INT( 10 ) NOT NULL default 0, PRIMARY KEY (aid), KEY alb_category (category), KEY `moderator_group` (`moderator_group`), KEY `visibility` (`visibility`) ) TYPE=MyISAM COMMENT='Used to store albums''

http://www.celinedionforum.com/gallery/

I copied the database info from the existing config.inc.php file to the first step. Is it fine to use the same table prefix? Any help is appreciated.
« Last Edit: July 05, 2010, 09:50:32 am by Joachim Müller »
Logged

anewday

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: Upgrade from 1.4 failed
« Reply #1 on: July 05, 2010, 04:59:48 am »

Also, there is no config.inc.php file present in the include folder, anycontent.php is present in the gallery rooter folder.
Logged

onthepike

  • Guest
Re: Upgrade from 1.4 failed
« Reply #2 on: July 05, 2010, 05:19:20 am »

Use your existing 1.4.18 config.inc.php file. It should remain on your server during the upgrade process, along with your anycontent.php file and your /albums/ directory.

http://documentation.coppermine-gallery.net/en/upgrading.htm#upgrade_any
Logged

anewday

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: Upgrade from 1.4 failed
« Reply #3 on: July 05, 2010, 05:43:15 am »

So, I used the config.inc.php and anycontent.php files from 1.4.18. This error shows up immediately after I ran update.php from the browser.

Coppermine critical error:
The group table does not contain the Anonymous group !

The gallery is using the invision 2.3 bridge. Could this be the cause?
Logged

onthepike

  • Guest
Re: Upgrade from 1.4 failed
« Reply #4 on: July 05, 2010, 06:01:47 am »

Disable bridging before upgrading, then check the documentation for details on re-enabling bridging after upgrading from 1.4.x to 1.5.6.
Logged

anewday

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: Upgrade from 1.4 failed
« Reply #5 on: July 05, 2010, 06:22:36 am »

I can't seem to login to the bridge manager with the admin account even after running adminpass.php to reset it. :(
Logged

onthepike

  • Guest
Re: Upgrade from 1.4 failed
« Reply #6 on: July 05, 2010, 07:04:11 am »

First, I would suggest you spend some time reading through the 1.5 documentation, and read it thoroughly. So far, all your questions (and answers, thereof) are explained, in very minute detail. This is not to say that you don't actually have a problem -- but the very basics of upgrading and fail/recover bridging are completely explained within the documentation that came as part of your download package.

To recover from failed bridging, please see: Recover From Failed Bridging. Should these steps fail, and you have a functioning gallery, but have bridging issues, please see the Bridging Support forum posting template (again, within your documentation).

Please advise as to whether or not this is a failed upgrade or a bridging issue. If bridging, I will move this thread to the appropriate sub forum.

Lastly, if you are indeed upgrading the gallery you provided above, please do leave the 1.5.6 installation available, as the 1.4.18 version is (a) susceptible to immediate harm, and (b) serves no useful purpose to us in attempting to assist you with these issues.
Logged

anewday

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: Upgrade from 1.4 failed
« Reply #7 on: July 05, 2010, 07:17:52 am »

Yes, I have already read the documentation on upgrading before performing the upgrade. I just didn't reuse the anycontent.php from the 1.4.18 install. The gallery is functioning with the bridging so this thread should remain here. I don't want to leave the installation files as the gallery will be broken. Do you have any other ideas? Thanks for your help.
Logged

onthepike

  • Guest
Re: Upgrade from 1.4 failed
« Reply #8 on: July 05, 2010, 07:27:19 am »

You are asking for support on the 1.5.x board regarding a gallery you maintain at version 1.4.18. At minimum, I would suggest updating to the latest 1.4.x version; currently 1.4.27, as you are extremely vulnerable to infection, etc. This version is woefully outdated and will not be supported.

If you require updating assistance, you must provide the gallery within the state of issue. Otherwise, it's all guesswork. We need to actually see the non-working gallery in order to determine the cause and remedy. Well, I do, anyway; perhaps someone else can resolve your issue without seeing the faulty 1.5.6 version.

I'm sorry I couldn't have been of help here.
Logged

anewday

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: Upgrade from 1.4 failed
« Reply #9 on: July 05, 2010, 07:52:21 am »

I though this was the correct forum for upgrading to 1.5. The gallery is upgraded to 1.4.27, thanks for the heads up! :)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upgrade from 1.4 failed
« Reply #10 on: July 05, 2010, 07:58:19 am »

Well, then upgrade as we suggest in our documentation to cpg1.5.x if you think you're on the right board. Currently, you're on the wrong board, as you have upgraded your gallery from 1.4.18 to cpg1.4.27!
Logged

anewday

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: Upgrade from 1.4 failed
« Reply #11 on: July 05, 2010, 08:52:22 am »

Well, then upgrade as we suggest in our documentation to cpg1.5.x if you think you're on the right board. Currently, you're on the wrong board, as you have upgraded your gallery from 1.4.18 to cpg1.4.27!
Why the rude remark? This forum description clearly states: "Troubles upgrading from previous versions (i.e. cpg1.4.x) to cpg1.5.x? Go here! Issues related to upgrading from cpg1.5.x to cpg1.5.y go here as well." I was initially upgrading from 1.4.x to 1.5.x and I did follow the documentation. The issue at hand is not upgrading from 1.4.18 to 1.4.27 so that is irrelevant.
Logged

anewday

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: Upgrade from 1.4 failed
« Reply #12 on: July 05, 2010, 09:47:06 am »

Anyway, the same error exists even after upgrading from 1.4.27 to 1.5.6. :(
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upgrade from 1.4 failed
« Reply #13 on: July 05, 2010, 09:50:22 am »

Stop posting nonsense - the gallery that you refered to in your initial posting is still running cpg1.4.27, that's why this entire thread is nonsensical. Locking.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.