Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: uploading files  (Read 4930 times)

0 Members and 1 Guest are viewing this topic.

joost

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
uploading files
« on: June 24, 2010, 12:42:01 am »

I have read through the docs, the board and tried everything I can think of. I have been using coppermine for more than five years, but now things seem to not work any longer....

After some issues with some photo's that seemed not to upload well, I had done an upgrade on my existing album (from 1.4.xx to 1.5.6). Theme didn't work anymore so I used a standard theme. Album seems to show everything just fine, but uploading is still giving some problems.

I have installed two brand new coppermine albums, 1.4.27 and 1.5.6. Both work fine (although not with IE 8, can't creete a new album). However, uploading is halting or not continuing or ...... - in both these new albums. Although I normally only do batch loading, I tried in the 1.5.6 to upload the standard way, but only got a few pictures to upload. Same with batch loading. I tried to batch load with 1.4.27 and couldn't get that to work either. I have used different browsers (Firefox, Chrome, IE8), different computers (XP and Win 7), all without succes. I have got some 20+ hours into this, but I cannot figure out what I am overlooking. To my knowledge, nothing changed on the server setup: running PHP 5.x and MySQL 5.x.

There are 2 demo setups, please take a look: http://www.skygliders.nl/album (1.5.6) and www.skygliders.nl/album1427. Both have their own database and some pictures sitting ready to go in an albums subdirectory.

login: admin and ww: copper

Your taking a look is greatly appreciated - thanks in advance.

Logged

onthepike

  • Guest
Re: uploading files
« Reply #1 on: June 24, 2010, 03:23:03 am »

I haven't (yet) read your issue fully. I did however log into your gallery and change your password.

Please do NOT EVER post an admin password on a public forum!! I will PM you your new password.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: uploading files
« Reply #2 on: June 24, 2010, 07:30:42 am »

To add to what onthepike said: I don't understand what you're trying to say in your posting. Decide for one gallery, then do as suggested in http://documentation.coppermine-gallery.net/en/upload_troubleshooting.htm#upload_trouble
If your issues persist, do as suggested in http://documentation.coppermine-gallery.net/en/upload_troubleshooting.htm#upload_support
Logged

joost

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: uploading files
« Reply #3 on: June 24, 2010, 10:07:36 am »

@ onthepie: thank you. I didn't think it would be an issue for a test setup, but I guess someone could change the settings in such a way to allow for some really bad uploads.

@ joachim: I thought I head read through all the docs, but there are soooo many. Anyway, this is the message, with different values for 2592, that keeps on coming up:
'Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2592 bytes) in /home/httpd/vhosts/skygliders.nl/httpdocs/album/include/picmgmt.inc.php  on line 439'
After trying many different uploads, it turns out that small pictures (with the largest size somewhere under 2400 pixels) are doing OK, bigger ones don't. The filesize seems to not be a problem (as the docs state, pixels rule over file size), as a 400KB picture failed where a 600 KB pictures succeeded.

Since I have full faith in Coppermine (and all of its loyal developers) and since I have uploaded 10's of thousands of pictures of all sizes in many different albums, I just tried and tried and stumbled onto one last thing: I put the setting of 'Automatically adjust pictures bigger than max width or height' to NO (this is translated by me to English - I don't know what it says in your settings, because I can't get my version to go back to English...).

And now, uploading seems to work as expected! Maybe it is just my server or my setup, but I can live without this one particular option.

Thank you both for your input and help. The debug mode got me to look in the right direction.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: uploading files
« Reply #4 on: June 25, 2010, 07:42:10 am »

'Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2592 bytes) in /home/httpd/vhosts/skygliders.nl/httpdocs/album/include/picmgmt.inc.php  on line 439'
That's why we even mention that error message and have provided a large article that explains it in every detail. You probably won't find a more detailed explanation of that error message on the internet. The explanation is on the very documentation page that I already have refered to twice in this thread. But I like to repeat, as I'm a trained parrot instead of a human being ::), so here you go: http://documentation.coppermine-gallery.net/en/upload_troubleshooting.htm#ErrorAllowedMemorySize and of course http://documentation.coppermine-gallery.net/en/upload_troubleshooting.htm#upload_trouble_server-sided_restrictions and http://documentation.coppermine-gallery.net/en/upload_troubleshooting.htm#upload_trouble_memory_usage - in fact I want you to read the entire page. Don't complain that it's a lot to read - reading will no doubt be easier than actually writing it.
Logged
Pages: [1]   Go Up
 

Page created in 0.026 seconds with 21 queries.