Advanced search  


CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Add Chinese Simplified Language into Database  (Read 8122 times)

0 Members and 1 Guest are viewing this topic.


  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Add Chinese Simplified Language into Database
« on: June 20, 2010, 04:03:39 pm »


I've just upgraded to 1.5.6 from 1.4.25 and I'm running into one problem. I'm trying to enable the Chinese Simplified language and eventually make it the default language on my gallery. When I go to the language manager, I find the language "chinese_gb" and I pick the China flag for it, then place the checkbox to enable it, and click OK at the bottom.

There's no errors or anything, but the changes are not saved.

I read the documentation and it says that when a + symbol is next to a language file, it means the file is there, but not in the database and to "Submit the form to create a record in the database as well." (I'm assuming clicking OK is the form submission step.)

Basically, after choosing Chinese Simplified, and submitting the form by click OK, no changes are saved. The language is listed as an option again, but it's still not enabled.

I turned off my theme and switched to a new theme that comes with 1.5 just in case the issue is with my theme, but the issue still exists. My gallery is at . PHP version is 5.3.1

Can anyone help?


  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Add Chinese Simplified Language into Database
« Reply #1 on: June 20, 2010, 04:33:35 pm »

I ended up making it work by manually entering a record for the chinese language into the MySQL database for the Coppermine Gallery and it is working now for visitors. I'm not sure if there will be any possible side effects to it, but it looks like it is working now.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
Re: Add Chinese Simplified Language into Database
« Reply #2 on: June 21, 2010, 12:44:35 pm »

Your language preferences probably where overriding the default - after all, the default only applies if all other mechanisms fail - the default means save fallback in this aspect. To force the usage of chinese, you could have added the parameter to the URL like this:

Please read up the details in the docs before asking questions, i.e.
Pages: [1]   Go Up

Page created in 0.019 seconds with 19 queries.