Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: error on upgrading from 1.5.4 to 1.5.6  (Read 3887 times)

0 Members and 1 Guest are viewing this topic.

andy_cul

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 63
  • Incigida
error on upgrading from 1.5.4 to 1.5.6
« on: June 10, 2010, 05:01:21 pm »

Got this error on upgrading from 1.5.4 to 1.5.6 http://jorpetz.com/photogallery/update.php warning adult content if it worked.
Code: [Select]
Template error
Failed to find block 'faq' (#<!-- BEGIN faq -->(.*?)<!-- END faq -->#s) in :

            <!-- BEGIN home -->
        <a href="{HOME_TGT}" title="{HOME_TITLE}" >{HOME_LNK}</a> ::
  <!-- END home -->  <!-- BEGIN contact -->
        <a href="{CONTACT_TGT}" title="{CONTACT_TITLE}" >{CONTACT_LNK}</a> ::
  <!-- END contact -->  <!-- BEGIN my_gallery -->
        <a href="{MY_GAL_TGT}" title="{MY_GAL_TITLE}" >{MY_GAL_LNK}</a> ::
  <!-- END my_gallery -->  <!-- BEGIN allow_memberlist -->
        <a href="{MEMBERLIST_TGT}" title="{MEMBERLIST_TITLE}" >{MEMBERLIST_LNK}</a> ::
  <!-- END allow_memberlist -->  <!-- BEGIN my_profile -->
        <a href="{MY_PROF_TGT}" title="{MY_PROF_TITLE}" >{MY_PROF_LNK}</a> ::
  <!-- END my_profile -->  <!-- BEGIN enter_admin_mode -->
        <a href="{ADM_MODE_TGT}" title="{ADM_MODE_TITLE}" >{ADM_MODE_LNK}</a> ::
  <!-- END enter_admin_mode -->  <!-- BEGIN leave_admin_mode -->
        <a href="{USR_MODE_TGT}" title="{USR_MODE_TITLE}" >{USR_MODE_LNK}</a> ::
  <!-- END leave_admin_mode -->  <!-- BEGIN sidebar -->
        <a href="{SIDEBAR_TGT}" title="{SIDEBAR_TITLE}" >{SIDEBAR_LNK}</a> ::
  <!-- END sidebar -->  <!-- BEGIN upload_pic -->
        <a href="{UPL_PIC_TGT}" title="{UPL_PIC_TITLE}" >{UPL_PIC_LNK}</a> ::
  <!-- END upload_pic -->  <!-- BEGIN register -->
        <a href="{REGISTER_TGT}" title="{REGISTER_TITLE}" >{REGISTER_LNK}</a> ::
  <!-- END register -->  <!-- BEGIN login -->
        <a href="{LOGIN_TGT}" title="{LOGIN_TITLE}" >{LOGIN_LNK}</a>
  <!-- END login -->  <!-- BEGIN logout -->
        <a href="{LOGOUT_TGT}" title="{LOGOUT_TITLE}" >{LOGOUT_LNK}</a>
  <!-- END logout -->
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1504
  • aka 'i-imagine'
    • Home Page
Re: error on upgrading from 1.5.4 to 1.5.6
« Reply #1 on: June 10, 2010, 05:14:00 pm »

You might still have your custom theme that has not been updated to cpg 1.5.x standards.

Make a backup of that theme, remove it from your server and make certain that you have at least one of the newer cpg 1.5.x themes in your theme directory before you run update again.

Read your docs about updating cpg 1.4.x themes to cpg 1.5.x.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: error on upgrading from 1.5.4 to 1.5.6
« Reply #2 on: June 10, 2010, 05:14:15 pm »

There no longer is a placeholder "faq" in the themes - the feature was dropped. If you still have an error message that complains about that element missing, you haven't done as suggested and replaced all files from cpg1.4.x with the ones from cpg1.5.x.
On your index (http://jorpetz.com/photogallery/)  one can see a fatal error, which backs up this suggestion as well. Enable debug_output for details if you want to see a more detailed error message, but I guess it is related to not replacing all files. Re-read the upgrading instructions and re-apply all steps.
Logged
Pages: [1]   Go Up
 

Page created in 0.032 seconds with 20 queries.