Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 [2]   Go Down

Author Topic: Search url changed?  (Read 7627 times)

0 Members and 1 Guest are viewing this topic.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Search url changed?
« Reply #20 on: June 28, 2010, 04:20:26 pm »

Logged

nickelas

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 114
Re: Search url changed?
« Reply #21 on: January 04, 2011, 11:12:35 am »

Just checking - I still have problems with links to my gallery in version 1.5.12 (now using .htaccess to solve it). Is this on the todo-list?
Cheers
http://uppsalafoto.se/galleri/
Logged
Human

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Search url changed?
« Reply #22 on: January 04, 2011, 11:34:59 am »

Maybe if I (or someone else) has a lot of spare time we can have a look at this issue again. I've added it to my to-do list, but only with a very low priority, sorry. I don't want to move it to the bugs board, as it's no bug, but the way how it works since the fix of a more dramatic issue. Of course we could add it to the 'Known issues' list, but that won't solve your issue ;)

Maybe you want to share your htaccess redirection rule with the community, so others may implement it the same way?
Logged

nickelas

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 114
Re: Search url changed?
« Reply #23 on: January 04, 2011, 11:58:59 am »

Sure, this is what I use
Code: [Select]
RewriteEngine On
RewriteCond %{QUERY_STRING} search\&search(.*)$
RewriteRule ^(.*)$ gallery-root/thumbnails.php?album=search&keywords=on&search%1 [R=302,L]
Replace "gallery-root" in the last row with the url to the cpg-root and place the .htacess there aswell.
This was a quick-fix and I can't swear it doesn't mess up any other search-options. But it fixes my issue
Logged
Human
Pages: 1 [2]   Go Up
 

Page created in 0.016 seconds with 19 queries.