Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Upgrade Failed  (Read 7637 times)

0 Members and 1 Guest are viewing this topic.

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Upgrade Failed
« on: June 07, 2010, 07:50:37 pm »

My link to my gallery is: http://www.fluffhouse.org.uk/jakie/robingirl/gallery

I was told to upgrade my gallery from 1.4 (something) to the recent (I was apparently 16 versions behind) edition of this program. I downloaded the latest stable package and unzipped it then uploaded it to my server not replacing, albums folder or config.php like the documents said.

I went to upgrade.html and it says the tables were all installed correctly and then at the bottom I got a bunch of code and it said something along the lines of authorization incomplete. I entered my Username and Password and it wouldn't let me log in. I got a bunch of code on that page that just appeared, so I'm guessing the code exploded some where. I can post the garbled mess if you'd like, it's A LOT. Like at least a page or more.

I then did "version checker" (to make sure some of my old files weren't causing the problem) and got this error (again, this was the original problem to begin with)


Deprecated: Assigning the return value of new by reference is deprecated in /var/www/jakie/robingirl/gallery/include/debugger.inc.php on line 129

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /var/www/jakie/robingirl/gallery/include/debugger.inc.php on line 131


Then I searched through all the files, admin.php, config.php (which is now unusable in the new package I found out :) ), and whatever else I thought may contain the "log in" info for my account, so if I needed to add in my user name and password I could.

I couldn't find it anywhere.


Please help.
Thanks
RG


(I posted this here after realizing I posted in the wrong spot AGAIN. So as not to make mod's mad, I tried again. You can delete my topic in the 1.4 support if you want.)
Logged

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Upgrade Failed
« Reply #1 on: June 07, 2010, 07:52:58 pm »

OH! Forgot to add this, part of garbled code explosion is the debug, but I haven't turned on Debug mode since 2006 or so ....so I don't know why it's on or how to even turn it off since I can't log in.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4850
    • Windsurf.me
Re: Upgrade Failed
« Reply #2 on: June 07, 2010, 08:22:40 pm »

You have not uploaded all the files properly (for instance - http://www.fluffhouse.org.uk/jakie/robingirl/gallery/docs/ is still showing the old version). Restore from your backup then try again using a good ftp app such as filezilla.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Upgrade Failed
« Reply #3 on: June 07, 2010, 09:11:59 pm »

I re-uploaded all the files and tried to update and all I got was a blank page (literally).

My gallery URL still says the same thing:


Deprecated: Assigning the return value of new by reference is deprecated in /var/www/jakie/robingirl/gallery/include/debugger.inc.php on line 129

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /var/www/jakie/robingirl/gallery/include/debugger.inc.php on line 131
Logged

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Upgrade Failed
« Reply #4 on: June 07, 2010, 09:20:31 pm »

Um...there is no other word but HOLY CRAP for this one. I went back and re-checked all of my files and saw that the darn debug php file in /includes hadn't been replaced. So I did that and well, once again the code exploded. LOL. For once I have no IDEA what happened or what it's trying to say.

You get the same crap when you go to my gallery URL: http://www.fluffhouse.org.uk/jakie/robingirl/gallery

Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1510
  • aka 'i-imagine'
    • Home Page
Re: Upgrade Failed
« Reply #5 on: June 07, 2010, 09:58:10 pm »

What are you using to transfer/upload?

You should be using something reliable like Filezilla. Set it to transfer in binary mode.

Make sure that you do a fresh, complete and clean (no errors) download and unzip of cpg 1.5.6 before uploading. I highly recommend Peazip (along with Filezilla).

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Upgrade Failed
« Reply #6 on: June 07, 2010, 10:44:40 pm »

Cyberduck is the program I use to transfer files because my webhost uses SFTP. I downloaded it from Coppermine's download page and downloaded the most stable.

I will download Filezilla right now and PeaZip as well.

Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4850
    • Windsurf.me
Re: Upgrade Failed
« Reply #7 on: June 07, 2010, 10:53:37 pm »

I've had issues with Cyberduck in the past.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Upgrade Failed
« Reply #8 on: June 07, 2010, 11:08:27 pm »

I'm still learning what programs work with Mac and which don't (I'm a very new Mac user ..i.e less than 6 months) work. Is Linux and Mac the same thing? If not then I don't think I can use PeaZip. Any other good unzipping programs? I am currently using "The Unarchiver" is this one good? It's been working ok so far, no issues.

Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4850
    • Windsurf.me
Re: Upgrade Failed
« Reply #9 on: June 07, 2010, 11:16:19 pm »

That is fine.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Upgrade Failed
« Reply #10 on: June 08, 2010, 01:14:23 am »

Alright, so the code finally stopped showing up and I think I got it "working" I upgraded and now I'm going to try and upload a photo before closing this help ticket, alright?

Thanks for all your help.

Now cross your fingers!

Logged

robingirl

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Upgrade Failed
« Reply #11 on: June 08, 2010, 01:25:24 am »

Everything seems to be in order.

So here for future people having this problem what I did:

1. Download Filezilla (just go ahead and do it, I feel it would have saved a lot of headaches if I'd just done it instead of waited)
2. With the newest stable edition of Coppermine unzipped, follow the instructions completely (as complete as you can) in the Upgrade.html located in the doc/eng folder.
3. When you copy files onto your server make sure to REPLACE them, the new ones are needed for the program to work!!

REMINDER: I upgraded. I didn't do a full new install.

Thanks for all the help.
<3
Robin Gurl

P.S - Mods you can close this out. (How do I edit the title of the first post to "solved" ?)
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4850
    • Windsurf.me
Re: Upgrade Failed
« Reply #12 on: June 08, 2010, 05:20:52 am »

Glad you got it sorted. To mark as solve simply click the little tick in your posts - http://forum.coppermine-gallery.net/index.php/topic,55415.msg270631.html#msg270631
Logged
It is a mistake to think you can solve any major problems just with potatoes.

flinsy

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 13
    • Arte Histriónico y Lúdico
Re: Upgrade Failed
« Reply #13 on: June 24, 2010, 12:11:43 am »

Hello!
After updating my gallery to the latest version I have trouble login it.
I'm sure what my login information and does not, indeed, tried to change it from phpMyAdmin and does not accept any changes, when I enter show Welcome Guess.
My Gallery is http://www.artehistrionico.com/Curriculums/
What I did was copy all the files to my webhost through the FireFTP plugin for Firefox, I always use, I run http://www.artehistrionico.com/Curriculums/update.php asked me to authenticate, accept the login data, however I can not enter an administrator or user mode!!
It shows good, but I can not manage it.
That is what should I do?
If you want to try, I have a test user and password:
Username: test and password: platense
I would appreciate any help.
Greetings.

Excuse my bad English, I used the Google translator.
Logged

flinsy

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 13
    • Arte Histriónico y Lúdico
Re: Upgrade Failed
« Reply #14 on: June 24, 2010, 12:26:51 am »

I can not log in any way or even as a normal user!!
What should I do? but I must return to the previous version ...
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4850
    • Windsurf.me
Re: Upgrade Failed
« Reply #15 on: June 24, 2010, 12:51:34 am »

Please start a thread of your own - http://forum.coppermine-gallery.net/index.php/topic,55415.msg270632.html#msg270632. If you struggle with the language please get someone to help or use one of the language specific boards - http://forum.coppermine-gallery.net/index.php/board,37.0.html

Locking
Logged
It is a mistake to think you can solve any major problems just with potatoes.
Pages: [1]   Go Up
 

Page created in 0.04 seconds with 19 queries.