Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Strange Database-Log-entry  (Read 7757 times)

0 Members and 1 Guest are viewing this topic.

taucher_0815

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 134
Strange Database-Log-entry
« on: June 06, 2010, 06:22:25 pm »

Hi @ all!

Link to gallery: http://Http://www.sk-foto.info

After uploading several files via FTP to a subfolder within the albums folder and batch adding these files into an empty gallery folder I get the following entry in the Database-Log:

Quote
06. Juni 2010 um 18:13 - While executing query 'INSERT INTO cpg15x_exif (pid, exifData) VALUES (13093, 'a:10:{s:13:\"VerboseOutput\";i:0;s:6:\"Errors\";i:0;s:9:\"ValidJpeg\";i:1;s:13:\"ValidIPTCData\";i:0;s:13:\"ValidJFIFData\";i:1;s:13:\"ValidEXIFData\";i:0;s:13:\"ValidAPP2Data\";i:0;s:12:\"ValidCOMData\";i:1;s:4:\"JFIF\";a:4:{s:4:\"Size\";i:16;s:4:\"Data\";s:14:\"JFIF\0\0\0\0\0\0\";s:10:\"Identifier\";s:5:\"JFIF\0\";s:13:\"ExtensionCode\";s:2:\"01\";}s:3:\"COM\";a:2:{s:4:\"Size\";i:59;s:4:\"Data\";s:57:\"CREATOR: gd-jpeg v1.0 (using IJG JPEG v62), quality = 60
\";}}')' in include/exif_php.inc.php on line 56 the following error was encountered:
Doppelter Eintrag '13093' für Schlüssel 'PRIMARY'

Last sentece translated to English: "Duplicate entry '13093' for key 'PRIMARY'"

Any Ideas?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Strange Database-Log-entry
« Reply #1 on: June 07, 2010, 08:02:42 am »

Is the database-column set to auto-increment?
Logged

taucher_0815

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 134
Re: Strange Database-Log-entry
« Reply #2 on: June 07, 2010, 08:19:00 am »

Good question...

Thats the first time this appeared with 7500+ pictures...

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Strange Database-Log-entry
« Reply #3 on: June 07, 2010, 08:28:55 am »

Please review using a third-party tool like phpMyAdmin wether that column is set to auto-increment
Logged

taucher_0815

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 134
Re: Strange Database-Log-entry
« Reply #4 on: June 07, 2010, 08:46:55 am »

I don't thin an autoincrement is needed as there is only the storage of exif-data...

But as far as i can see there are very strange entries in this table...

Quote
a:10:{s:13:"VerboseOutput";i:0;s:6:"Errors";i:0;s:9:"ValidJpeg";i:1;s:13:"ValidIPTCData";i:0;s:13:"ValidJFIFData";i:1;s:13:"ValidEXIFData";i:0;s:13:"ValidAPP2Data";i:0;s:12:"ValidCOMData";i:1;s:4:"JFIF";a:4:{s:4:"Size";i:16;s:4:"Data";s:14:"JFIF������";s:10:"Identifier";s:5:"JFIF�";s:13:"ExtensionCode";s:2:"01";}s:3:"COM";a:2:{s:4:"Size";i:59;s:4:"Data";s:57:"CREATOR: gd-jpeg v1.0 (using IJG JPEG v62), quality = 80
";}}

This occurs for only 638 entries but I have more than 7500 images in the gallery and all of them are with complete exif-datas
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Strange Database-Log-entry
« Reply #5 on: June 07, 2010, 09:28:35 am »

Looks like an encoding issue to me (non-utf-8).
Logged

taucher_0815

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 134
Re: Strange Database-Log-entry
« Reply #6 on: June 07, 2010, 09:37:10 am »

Data-field ist set to "latin1_german1_ci".

Should I change that to utf8_unicode or utf8_general?

Is there a way to re-read the exifs out of all the images?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Strange Database-Log-entry
« Reply #7 on: June 07, 2010, 09:39:29 am »

I doubt that the error will go away if you change the collation of the database alone, as it's only teh default collation. Existing records won't change when changing the collation of the database table. Please zip the image that acts up as it came out of the camera and attach the zip to your posting here.
Logged

taucher_0815

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 134
Re: Strange Database-Log-entry
« Reply #8 on: June 07, 2010, 09:49:06 am »

Would like to attache the original image but there is a limit of 2000KB... The zipped image is 5.105.791 Byte...

find it here: http://ebay.sk-foto.info/testimage.zip

Please give me a note if you have DL the image, so i can delete it from there
Logged

taucher_0815

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 134
Re: Strange Database-Log-entry
« Reply #9 on: June 07, 2010, 09:50:22 am »

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Strange Database-Log-entry
« Reply #10 on: June 07, 2010, 10:00:43 am »

Using Ubuntu Linux 10.04 with Gnome and Gvenview I get "strange" chars in some places of your meta data (see attached screenshot). Please leave the file available, I'd like to check from a Windows-driven machine later.
Logged

taucher_0815

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 134
Re: Strange Database-Log-entry
« Reply #11 on: June 07, 2010, 10:04:48 am »

I am using PhotoMechanic on a MAC to ingest the IPTC-Data during DL of all images.
The language will be: MAC Romas as Unicode (see screenshot)
Logged

taucher_0815

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 134
Re: Strange Database-Log-entry
« Reply #12 on: June 07, 2010, 10:06:24 am »

and here the exifs:
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Strange Database-Log-entry
« Reply #13 on: June 07, 2010, 12:18:39 pm »

Off-topic:

I doubt that the error will go away if you change the collation of the database alone, as it's only teh default collation. Existing records won't change when changing the collation of the database table.
The collation only affects the sort ordering (read), not how the database stores (write) the data! More information here (German only).
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Strange Database-Log-entry
« Reply #14 on: June 07, 2010, 03:53:10 pm »

The language will be: MAC Romas as Unicode (see screenshot)
This is probably where the issue lies in (just guessing here though).
Logged

taucher_0815

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 134
Re: Strange Database-Log-entry
« Reply #15 on: June 07, 2010, 03:56:37 pm »

Strange is also that all the IPTC-Data is read OK as you can see on all images in the gallery.

EXIF-Data is not touched at all...

The exif-Table consists only of 600+x entries and not of 7.500+.

Is there a way to re-read all exifs out of the images that exist in the gallery?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Strange Database-Log-entry
« Reply #16 on: June 07, 2010, 04:20:32 pm »

Afaik the exif data is only read if there is no database record. If you need to refresh exif infos, just delete the appropriate entries in the exif table.
Logged

taucher_0815

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 134
Re: Strange Database-Log-entry
« Reply #17 on: June 07, 2010, 04:32:22 pm »

OK, deleted all the stuff from the table, started viewing the first images and they showed up the exif-data OK.

http://www.sk-foto.info/displayimage-2-6334-_American_Football_Munich_Cowboys_vs_Stutt.html#top_display_media

When viewing the latest images, they will not be displayed :(

http://www.sk-foto.info/displayimage-104-13093-_Beachvolleyball_U19_in_Germering_am_06_06.html#top_display_media

Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Logged

taucher_0815

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 134
Re: Strange Database-Log-entry
« Reply #19 on: June 07, 2010, 04:38:17 pm »

strange, but from where does the description come? I did not enter that for several 100 images ;)
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 20 queries.