Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: User name not visible in Image View (displayimage.php) SMF  (Read 5398 times)

0 Members and 1 Guest are viewing this topic.

Sebastyne

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26

I have the following issue when trying to bridge Coppermine 1.4.26 and SMF 1.1.11:
I am guessing this is a bridging problem, but I might be wrong. When viewing a singular image (image view) the user name of the owner of the photo is not displayed. I am sure that before I upgraded the Coppermine installation, it was viewable on the page, but it isn't anymore.

I'm guessing this part of the code in displayimage.php...

Code: [Select]
if ($CURRENT_PIC_DATA['owner_id'] && $CURRENT_PIC_DATA['owner_name']) {
        $owner_link = '<a href ="profile.php?uid=' . $CURRENT_PIC_DATA['owner_id'] . '">' . $CURRENT_PIC_DATA['owner_name'] . '</a> ';

...might have to be changed to point to the smf -user database somehow, but I'm not sure (how) so I'm asking.

I tried searching for an answer to this with every search term I could think of with no luck, I'm sorry if I a asking something obvious.


Coppermine install: http://www.thebdoll.com/gallery
(Example of the Image view: http://www.thebdoll.com/gallery/displayimage.php?pos=-21350 )
Forum install: http://www.thebdoll.com/forum/
Coppermine version: cpg1.4.26
Forum version: SMF 1.1.11
Test user account: Testihenkilo / hoplallaa (Login on the front page, everything is goes through Joomla.)

BridgeManager settings:
Forum URL:  http://www.thebdoll.com/forum
Relative path to your BBS's config file:  ../forum/
Use post-based groups?:  1
Cookie name/preifx (if applicable)

Hope you can help, and thank you. :)
Logged

Sebastyne

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: User name not visible in Image View (displayimage.php) SMF
« Reply #1 on: May 30, 2010, 02:42:40 pm »

It was a template issue after all.  :p
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 20 queries.