Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Moving Day  (Read 3822 times)

0 Members and 1 Guest are viewing this topic.

annekmadison

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Moving Day
« on: May 20, 2010, 04:52:57 pm »

I have a Coppermine 1.4x installation that I am migrating from one host server to another. The documentation on this seems pretty straightforward. The new host is Rackspace Cloud. I have a couple of questions:

1) Since I have to have the gallery down to move/install/test, would this be a good opportunity to upgrade to the new version? Should I consider this, or should I just stay with my current version, which is the latest 4?
2) If upgrading is possible and a good idea, aside from saving my albums folder and config.inc, is there anything I should watch out for? Potential "gotchas" I can prevent?
3) Is there a methodology or set of steps for this "move and upgrade" that will make it most efficient?
4) Is anybody else running on Rackspace Cloud? Anything I should know about them that would be helpful?

This gallery is accessible to the public only for viewing. The only person who can upload is Admin, and comments/ratings, etc. are all disabled.

Thanks in advance. I am looking foward to working with the new version if this is the right time to do so.

Anne
 
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4886
    • Windsurf.me
Re: Moving Day
« Reply #1 on: May 20, 2010, 05:04:48 pm »

Please post a link to your site as per the board rules - http://forum.coppermine-gallery.net/index.php/topic,55415.msg270616.html#msg270616

We also have a one question per thread policy so I'll just answere the should I upgrade question (all the rest have been asked and answered anyway and a quick search of the forums will answer those).

Upgrading to 1.5.x RC is a choice only you can make. While we are happy to support it you may encounter bugs or incomplete code. There are changes being made daily. Most of these are minor fixes or additions to language files but overall there is still a lot of development going on. The same goes for the many plugins that are appearing for 1.5.x. So if you are happy to keep up to date using the SVN and are happy to put up with a few quirks then go ahead. If not then stick with your current version if it is up to date.

Once again, please post a link to your site or we cannot really help.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Moving Day
« Reply #2 on: May 20, 2010, 05:14:49 pm »

Phill beat me to it, so part of my posting is a repetition of what Phill said.

Board rules / Forum policies: Post Links

I have a Coppermine 1.4x installation that I am migrating from one host server to another.
Board rules / Forum policies: Choose the proper board for your posting

I have a couple of questions
Board rules / Forum policies: One Question per Thread

1) Since I have to have the gallery down to move/install/test, would this be a good opportunity to upgrade to the new version?
Yes

2) If upgrading is possible and a good idea, aside from saving my albums folder and config.inc, is there anything I should watch out for? Potential "gotchas" I can prevent?

3) Is there a methodology or set of steps for this "move and upgrade" that will make it most efficient?
It doesn't matter if you move first and then upgrade or if you upgrade and then move.

Joachim
Logged

annekmadison

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Moving Day
« Reply #3 on: May 20, 2010, 06:23:43 pm »

Thanks to both for the info, and my apologies for the "bundled" question.

In the interest of saving time, I went ahead and installed the existing version, which is unfortunately not working. I will close this thread off and post the new question in the appropriate thread.

The new/existing installation of 4.x is at http://zippersportfishing.com/photographs. The reason I didn't add it to my initial query was that I hadn't yet set it up. It's now set up/not working. I'll close this and re-post the new problem in the appropriate thread.

Anne
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.