Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: App issue inserting into temp_messages table  (Read 3714 times)

0 Members and 1 Guest are viewing this topic.

Darwin

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
App issue inserting into temp_messages table
« on: April 07, 2010, 02:55:07 pm »

I have a fresh install of 1.5.3 and the installation seemed to go well.

I am in the midst of testing the gallery.  The only user is my administrative account.  When logging in or out I get critical database errors:

Apr 07, 2010 at 05:01 AM - While executing query 'INSERT INTO cpg15x_temp_messages  SET  message_id = 'd41d8cd98f00b204e9800998ecf8427e',  user_id = '0',  time   = '1270641672',  message = 'Welcome+dgadmin+...'' in include/functions.inc.php on line 4807 the following error was encountered: ^M
Duplicate entry 'd41d8cd98f00b204e9800998ecf8427e' for key 1^M

I am using MySQL 5 and sharing the table with a PHPBB 3 instance.  I checked the table using phpMyAdmin and the table appears to be defined properly, and is empty.  I am not sure of what versions of web server I am using.

When I click a menu item (such as Home) I seem to do OK.  I haven't even gotten to the point of testing uploads etc, as I want to get each piece resolved as I encounter it.

Any ideas?
Logged

Nibbler

  • Guest
Re: App issue inserting into temp_messages table
« Reply #1 on: April 07, 2010, 03:44:45 pm »

Logged

Darwin

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: App issue inserting into temp_messages table
« Reply #2 on: April 07, 2010, 08:18:53 pm »

Thanks.

I'll see if that fix works tonight.

I need to learn to search a little more effectively.
Logged

Darwin

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: App issue inserting into temp_messages table
« Reply #3 on: April 08, 2010, 01:26:39 am »

The fix worked for me...
Just replaced

$message_id = md5(uniqid());

with

$message_id = md5(uniqid(''));
Logged
Pages: [1]   Go Up
 

Page created in 0.055 seconds with 20 queries.