Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Closed]: My mySQL from the previous version 1.4x doesn't want to update to 1.5x  (Read 8663 times)

0 Members and 1 Guest are viewing this topic.

vxfjeff

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 3

I've not been able to get my MySQL database to be recognized in the 1.53 upgrade from 1.4.26. I see that the table prefix has changed from cpg1410_ to cpg15x_, but getting my data from the old tables to the new ones has not worked.

I tried changing the table prefix in the config.php from cpg1410_ to cpg15x_, but that corrupted the site with an unspecified fatal error. In the php editor, I tried copying the data out of the old tables into the empty new ones. Same fatal error with Coppermine. I also tried copying the old table data *as* the new tables with the correct cpg15x_ prefix (thinking that the substitution would work). I even tried creating an entirely new MySQL database, but it just didn't grab anything of my stuff from the old one... I had hoped the installer would possibly do that automatically.

To the best of my ability, I don't know how to upgrade/update to 1.53 while keeping my old database intact. Is 1.5x upwardly compatible with 1.4x versions? If it is, it may be helpful if there is documentation to describe what's happening. The database structure must have changed, right? I'm sure many other people may encounter this issue as well. How do we migrate our work to the new version?
« Last Edit: April 04, 2010, 07:17:37 pm by Joachim Müller »
Logged

vwad

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 3
  • God & Sun are the only divine things in universe.

There is whole section in the docs specifically for upgrading and according to me, its the best possible and easiest way to upgrade if you read it to the core and completely.

http://documentation.coppermine-gallery.net/en/upgrading.htm
Logged
God is Greatest !!

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9096
  • aka Frantz
    • Ma galerie

do what vwad suggests: read the docs and particulary the upgrade section.
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

vxfjeff

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 3

According to the documentation, I have created a fresh install (in order to avoid damaging my current online presence). Coppermine 1.5.3 is working fine, but collecting my work from the old database 1.4.x is problematic. In my profession, we explain the unknown (the question) by describing what we have discovered... I discovered that changing the table prefix in the include/config.inc.php is not a solution. I discovered that exporting the old database and importing that data into the new database doesn't fix the problem either... even if the new data is contained in correctly named tables with the prefix cpg15x_. In short, I am personally not capable of correcting this issue with the documentation available.

I can't imagine when nor why the documentation (that I have read many times) became more important than a living breathing person like myself. As many of us start upgrading our Coppermine software, respect and understanding of the various skill levels of the users is going to be extremely important. It seems like appropriate responses to questions on the board would include information not actually in the documentation or that includes a clarification on the documentation as it pertains to the stated question. I understand that I may not worthy of your time specifically, which is unfortunate and disappointing, but please allow others that may wish to offer actual assistance to me to respond without putting unhelpful redirects between me and possible solutions. Regardless of support intentions, Coppermine can only benefit by getting clarity on questions that the writers of the documentation may never have expected to need clarification.

Does anyone have helpful suggestions on how to upgrade my MySQL database tables correctly from 1.4x_ to 1.5x_ so I can use my current data?

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de

According to the documentation, I have created a fresh install
That's not what the documentation is suggesting. In fact it says quite the opposite.

I can't imagine when nor why the documentation (that I have read many times) became more important than a living breathing person like myself.
We're human beings as well, and we give support freely without getting paid or getting any other way of compensation. We can expect that you do read the documentation instead of anticipating that we're going to explain the same issue over and over again to each lazy person like you.


Does anyone have helpful suggestions on how to upgrade my MySQL database tables correctly from 1.4x_ to 1.5x_ so I can use my current data?
Yes, I have a suggestion: you re-read the upgrading section and do exactly as suggested there: replacing the existing cpg1.4.x-files with fresh cpg1.5.x files and then running the update script will perform the needed database changes easily. Stop dragging your feet and whining about your missing skill level: it's not hard to read that little upgrading section and respect the simple description there what you need to do instead of coming up with wrong assumptions.
I discovered that changing the table prefix in the include/config.inc.php is not a solution.
Nobody said that you should do that.
I discovered that exporting the old database and importing that data into the new database doesn't fix the problem either...
Of course not. Nobody said so neither.

even if the new data is contained in correctly named tables with the prefix cpg15x_. In short, I am personally not capable of correcting this issue with the documentation available.
Instead of blaming the documentation you should learn to read it properly. Don't blame others for your inability to read the docs properly. A very big effort has been put into the documentation, and you're welcome to help us improve it even more by posting your additional information. However, just saying that the documentation is bad is not helpfull. You can hardly expect help with an attitude as confrontational as yours.

Additionally, you have failed to do as suggested per board rules, so what do you expect? If you came here just to troll, then you succeeded. But I won't tolerate this any more.
Logged

vxfjeff

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 3

Here is my site:

http://www.retromatic.tv/cpg1410/index.php?cat=0

As you can see, my site is highly customized. I'm trying to start from scratch, but also import my data in order to avoid destroying my current site. My issue is with MySQL as it relates to Coppermine. I apologize for not being able to communicate better with you. I did donate when I started with the group many years ago, and I am willing to do so again. I do think that my question is valid. I'm sorry that we can't agree on its validity.

 
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de

I'm trying to start from scratch, but also import my data in order to avoid destroying my current site.
That's nonsense. Create a copy of your live gallery and perform the upgrade on the copy if you don't trust the instructions to succeed.
I did donate when I started with the group many years ago
Really? You should have posted details to whom you did donate and how. The number of donators is "small"...

Here is my site:

http://www.retromatic.tv/cpg1410/index.php?cat=0
You're deliberately hiding the "Powered by Coppermine" footer that is mandatory to perserve in terms of license as well as from an ethical point of view. It fits into the image that you're doing that. You're banned. Go away.
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.