Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: In welcher Spalte steht das Erstellungsdatum des hocheladenen Bildes ?  (Read 4121 times)

0 Members and 1 Guest are viewing this topic.

M4rkus

  • Contributor
  • Coppermine regular visitor
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 97

Hallo,

meine CPG: https://www.naturfoto-galerie.net

Folgende Frage, in welcher Spalte steht das Erstellungsdatum eines hochgeladenen Bildes ?
In der Tabelle cpg14x_pictures in der Spalte mtime steht immer das Datum wann das Bild zum letzten
Male einen Kommentar erhalten hat...glaube ich zumindest.
Wahrscheinlich steht in der Spalte ctime das Erstellungsdatum ?

Wenn das so ist, wie kann ich daraus das Datum ablesen, da stehen bei mir solche Sachen drin: 1258057375

Vielen Dank für die Hilfe....Markus.
« Last Edit: April 05, 2010, 09:25:13 am by Joachim Müller »
Logged
Best all, Markus

sylvia.r

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 98

Tag Markus,
das Datum findest du in der Spalte "ctime". Tabelle _pictures ist richtig.
Dafür brauchst du Unix-Umrechner wie hier z.B.
http://www.werbegraphix.de/webmaster_tools/php-timestamp-berechnen.php

hth Marek
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de

in welcher Spalte steht das Erstellungsdatum eines hochgeladenen Bildes ?
Das Erstellungsdatum eines Bildes kennt Coppermine nicht, es sei denn Du hast das Auslesen von Exif-Daten aktiviert - dann steht diese Information in der entsprechenden Exif-Tabelle in Coppermine.
mtime ist der Zeitstempel, wann das Bild zuletzt angesehen wurde. Der Zeitstempel ctime gibt an, wann das Bild in Coppermine hochgeladen wurde, vgl. http://documentation.coppermine-gallery.net/de/dev_database.htm#db_pictures

Wenn das so ist, wie kann ich daraus das Datum ablesen, da stehen bei mir solche Sachen drin: 1258057375
Das ist ein Unix-Zeitstempel (also die Anzahl der Sekunden seit dem ersten Januar 1970), den man in vielerlei Art in ein menschen-lesbares Format umwandeln kann, vgl. http://www.php.net/manual/de/function.date.php

Deine Seite ist nach wie vor zwei Versionen hinterher: Du hast cpg1.4.24, obwohl die derzeit aktuellste stabile Version cpg1.4.26 ist. Du erhälst ab sofort keinen Support mehr, wenn Du nicht aktualisierst.

Logged

M4rkus

  • Contributor
  • Coppermine regular visitor
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 97

Hallo,

@All: Danke für die schnellen Antworten, ich werde mir mal die Geschichte mit dem Zeitstempel ansehen.
Exif's sind bei mir auch aktiviert, alternativ könnte ich dort die entsprechende Spalte abfragen.

@Joachim: Ich habe Dir bereits in diesem Posting: http://forum.coppermine-gallery.net/index.php/topic,64227.0.html
sofort auf Deinen Hinweis zur Version geantwortet, wenn Du es nicht liest kann ich es nicht ändern.
Aber ich schreibe es gern nochmal hier: Ich habe bereits bei der Installation die Version 1.4.25 verwendet.
Danach Stramms Modpack installiert, was eigenständig die Versionsnummern wieder auf 1.4.24 zurückdreht !
Den Patch auf 1.4.26 habe ich von Hand eingespeilt so wie es hier: http://forum.coppermine-gallery.net/index.php/topic,63510.0.html beschrieben ist. Die aktuelle Version verwende ich schon seit langem.
Logged
Best all, Markus

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de

Ich habe
@Joachim: Nein...ich verwende Version 1.4.26
Ich hatte von Anfang an 1.4.25 drauf, nach Stramms Modpack hat er die Versionsnummer wieder auf 1.4.24 gedreht.
Und das Update auf 1.4.26 hab ich von Hand geändert.
schon in Deinem anderen Thread gelesen, halte es aber für Mumpitz. Um sicher zu gehen habe ich eben https://sourceforge.net/projects/coppermine/files/Modifications%20and%20AddOns/1.4.x/cpg1.4.26_modpack_stramm_1_bridge.zip/download herunter geladen, um zu überprüfen, ob Deine Aussage plausibel ist. Sie ist es nicht; die in diesem Archiv vorkommenden Versionsnummern sind korrekt - bei korrektem Upgrade-Vorgang wird definitiv die richtig Versionsnummer im Output angezeigt. Daher hier nochmals meine Aussage: Upgrade. Du hast den Upgrade-Vorgang unvollständig oder falsch vorgenommen, was durch die Ausgabe auf Deiner Seite eindeutig belegt wird.
Wenn Du das nicht tust wirst Du keinerlei Support mehr erhalten. Wenn Du zu dem Upgrade Hilfe brauchst, dann starte einen entsprechenden Thread.

@Joachim: Ich habe Dir bereits in diesem Posting: http://forum.coppermine-gallery.net/index.php/topic,64227.0.html
sofort auf Deinen Hinweis zur Version geantwortet, wenn Du es nicht liest kann ich es nicht ändern.
Aber ich schreibe es gern nochmal hier: Ich habe bereits bei der Installation die Version 1.4.25 verwendet.
Ein bißchen Mäßigung in Deinem selbstzufriedenen Posting würde Dir nicht so schlecht zu Gesicht stehen, denn Du magst vielleicht allerhand über Fotografie wissen, aber vielleicht doch nicht alles über Coppermine - da weiss ich ein bißchen mehr. Meine Aussage steht.
Logged

M4rkus

  • Contributor
  • Coppermine regular visitor
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 97

Das Modpack habe ich Ende November...Anfang Dezember 2009 installiert.
Da existierte noch kein 1.4.26-Modpack.
Da gab es nur das 1.4.24-Modpack.
Ich bin damals auf eine Thread hier im Forum gestossen, in dem die Aussage steht,
dass das 1.4.24-Modpack in eine 1.4.25-CPG installiert werden kann, das wäre OK so.
Wenn nach der Installation dann 1.4.24er Versionsnummern in meiner 1.4.25-CPG drin stehen,
bin ich es also Schuld und bekomme keinen Support mehr....ist das richtig so ?
Logged
Best all, Markus

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de

Ich bin damals auf eine Thread hier im Forum gestossen, in dem die Aussage steht,
dass das 1.4.24-Modpack in eine 1.4.25-CPG installiert werden kann, das wäre OK so.
Exakt, über cpg1.4.25 durfte man damals cpg1.4.24_modpack installieren. Inzwischen sind wir aber bei cpg1.4.26 angekommen und bei cpg1.4.26_modpack. Daher ist alles Gerede über alte Pakete Schnee von gestern.
Wenn nach der Installation dann 1.4.24er Versionsnummern in meiner 1.4.25-CPG drin stehen,
bin ich es also Schuld und bekomme keinen Support mehr....ist das richtig so ?
Richtig, da weder cpg1.4.24 noch cpg1.4.25 die neuesten Versionen sind, sondern cpg1.4.26. Ende der Debatte: ich hatte Dir doch gesagt, dass Du einen separaten Thread starten sollst, wenn Du ein Problem mit dem Upgrade hast. Auch hatte ich Dir gesagt, dass Du Deine selbstzufriedene Art etwas überdenken solltest. Ebenfalls hast Du es versäumt, diesen Thread als gelöst zu markieren, obwohl Deine ursprüngliche Frage schon lange geklärt ist. Du bist einen Millimeter vor einer Verbannung. Ich sperre diesen Thread und markiere ihn entsprechend.
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 19 queries.