Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Prosilver with 1.5  (Read 8399 times)

0 Members and 1 Guest are viewing this topic.

Bill Hildyard

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Prosilver with 1.5
« on: March 30, 2010, 08:53:08 pm »

Hi I am trying to install amidly customised version of Prosilver to 1.5 however despite follow all the upgrade themes instructions I am getting the following error:

Quote
Template error
Failed to find block 'view_log_files' (#<!-- BEGIN view_log_files -->(.*?)<!-- END view_log_files -->#s) in :

Full text of error page attached, any thoughts.

Cheers

Bill
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Prosilver with 1.5
« Reply #1 on: March 30, 2010, 09:01:13 pm »

Almost
Then create a new one with your themes theme.php and template.html attached and a link to your site.
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

Bill Hildyard

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Prosilver with 1.5
« Reply #2 on: March 30, 2010, 09:15:45 pm »

Sorry.

Files attached. http://www.gasteria.org.uk/Gallery/

Cheers

Bill

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Prosilver with 1.5
« Reply #3 on: March 31, 2010, 07:23:41 am »

Actually I suggest zipping your custom theme folder and attaching the zip to your posting.
You appear to be using an editor that is not up to the task, with double line-breaks showing through for me. You have copied nonsensical code from somewhere you shouldn't have copied from: your theme.php file end in mid-air with
Code: [Select]
if (!function_exists('theme_display_image')) {  //{THEMES}

function theme_display_image($nav_menu, $picture, $votes, $pic_info, $comments, $film_strip)

{

    global $HTTP_COOKIE_VARS, $CONFIG;



    starttable();

    echo $nav_menu;

    endtable();

    starttable();

    if ($CONFIG['display_film_strip'] == 1) {

echo "<tr><td width='200' class='tableb'
, which is of course incomplete and will cause errors.
Try the files I have attached instead for a start.

Joachim

P.S. In the short time span you have been around on this forum you have an impressive record of not respecting board rules and misbehaviour. You have been told about board rules often enough now, so the tolerance is zero as far as you breaking the rules is concerned.
Logged

Bill Hildyard

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Prosilver with 1.5
« Reply #4 on: March 31, 2010, 07:48:09 pm »

Sorry :-[ I am appreciative of the help.

I tried those two files but still getting the same error and it is defiantly to do with the theme as if I remove the Prosilver folder Coppermine opens with the default theme, zipped theme folder attached.

Regards

Bill
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Prosilver with 1.5
« Reply #5 on: April 01, 2010, 07:53:51 am »

So you picked a theme that is one of the hardest to port from cpg1.4.x to cpg1.5.x, as nearly every item that can be changed was changed, and you try to use it without even having looked at
Converting cpg1.4.x themes to cpg1.5.x
[...]
Edit theme.php
Many notable things have happened that will influence your modifications to your theme.php.
If you can, empty your copy of theme.php (of course you should keep a backup somewhere safe as a precaution) and then re-add the changes you need as if you were creating your custom theme from scratch, copying the relevant bits you want to see changed from the sample theme (as suggested in "The sample theme - a template to copy from") and then modifying your edits as you see fit.

The reason for the template error is the fact that vital items in the definition for $template_gallery_admin_menu in theme.php are missing. To make the theme sort-of work as expected, just get rid of that definition and the definition for the user admin menu as well. However, I can't see the point in using that very theme unless you run a forum with that theme as well.
Logged

Bill Hildyard

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Prosilver with 1.5
« Reply #6 on: April 01, 2010, 08:13:21 am »

Yes I will have a forum running the same theme and a website the looks similar too, unfortunately, not my idea.

Bangs head against the wall, don't know how I missed that I did all the other changes above it, less haste more speed methinks. Will give it a go.

Thanks

Bill
Logged

Bill Hildyard

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Prosilver with 1.5
« Reply #7 on: April 02, 2010, 12:42:42 am »

Decided to start a fresh with modifying Curve instead.

Thanks Bill
Logged

Bill Hildyard

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Prosilver with 1.5
« Reply #8 on: April 02, 2010, 12:49:08 am »

I hope I have done right marking it resolved?

Bill
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Prosilver with 1.5
« Reply #9 on: April 02, 2010, 09:20:29 am »

That was correct, thank you.
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 19 queries.