Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: batch add working only once  (Read 8091 times)

0 Members and 1 Guest are viewing this topic.

xheartrockx

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
batch add working only once
« on: March 16, 2010, 12:05:00 pm »

Hi everybody,

sorry to bother you with yet another one of those topics. I have checked the board for solutions.
I've followed the instructions but it doesn't seem to work. That is, it worked once with the first folder of pictures and now it doesn't. Single uploads work just fine without giving me error messages but the batch upload always leads back to the 'select a folder' page.

I checked the phpinfo and as far as I can tell, the values are correct according to the aforementioned instruction.

If anybody can subtly point to what I'm missing, I'd highly appreciated it.

website: http://seamusdeverfan.innocent-obsession.de/cpg14x/index.php

user: test

pass: test

Again, sorry if this is redundant and I'm just stupid but I have no clue wherelse to look.

Thanks :)
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1545
  • aka 'i-imagine'
    • Home Page
Re: batch add working only once
« Reply #1 on: March 16, 2010, 12:47:01 pm »

Post a deep link to one of the files your are trying to batch upload.
Example: h t t p ://seamusdeverfan.innocent-obsession.de/cpg14x/albums/album_name/picture_name.jpg

xheartrockx

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1545
  • aka 'i-imagine'
    • Home Page
Re: batch add working only once
« Reply #3 on: March 16, 2010, 03:21:46 pm »

Recheck the permissions for the folders - try 777 if you are at 755.

Use folders without any uppercase (capital) lettering.

xheartrockx

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: batch add working only once
« Reply #4 on: March 16, 2010, 03:32:49 pm »

Still the same.

Folders are set to 777 and I changed the folder names.

It's only working for the first folder, when I try to upload from the second, it bumps back to the 'pick a folder'-page
Logged

xheartrockx

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: batch add working only once
« Reply #5 on: March 16, 2010, 03:34:12 pm »

Plus, now there are pics missing, and I can't edit the albums as it tells me their are not "writeable"
Logged

onthepike

  • Guest
Re: batch add working only once
« Reply #6 on: March 16, 2010, 05:25:09 pm »

Your /uploads folder is set to 711. CHMOD that folder to 755 and copy the index.php file from the /albums directory into the /uploads directory to prevent directory listing if that was the purpose of denying access via the 711 permission setting in /uploads. See if that helps.

Also, the above deep link returns a 404.
Logged

xheartrockx

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: batch add working only once
« Reply #7 on: March 16, 2010, 05:33:13 pm »

here's the deep link again:

http://seamusdeverfan.innocent-obsession.de/cpg14x/albums/uploads/armywives205/armywives2x05_0100.jpg

Still doesn't work, though. I checked the uploads folder and it was set to 777 in my ftp...
Logged

onthepike

  • Guest
Re: batch add working only once
« Reply #8 on: March 16, 2010, 06:32:45 pm »

Viewing header response from http://seamusdeverfan.innocent-obsession.de/cpg14x/albums/uploads/armywives205/:

Code: [Select]
URL = http://seamusdeverfan.innocent-obsession.de/cpg14x/albums/uploads/armywives205/
UAG = Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
REF = http://www.rexswain.com/httpview.html
AEN =
REQ = GET ; VER = 1.1 ; FMT = AUTO
Sending request:

GET /cpg14x/albums/uploads/armywives205/ HTTP/1.1
Host: seamusdeverfan.innocent-obsession.de
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Referer: http://www.rexswain.com/httpview.html
Connection: close

• Finding host IP address...
• Host IP address = 78.138.89.34
• Finding TCP protocol...
• Binding to local socket...
• Connecting to host...
• Sending request...
• Waiting for response...
Receiving Header:
[b]HTTP/1.1·403·Forbidden(CR)(LF)[/b]
Date:·Tue,·16·Mar·2010·17:30:12·GMT(CR)(LF)
Server:·Apache(CR)(LF)
Content-Length:·237(CR)(LF)
Connection:·close(CR)(LF)
Content-Type:·text/html;·charset=iso-8859-1(CR)(LF)
(CR)(LF)


Some web hosts using UNIX based servers will not allow you to CHMOD any files or folders to 777, regardless of what the setting says to you. I have seen 777 return a 403 based on below-root host setting, and this seems to be the case for you.

Try changing whatever folders you have set to 777 back to 755 recursive and see if that helps.
Logged

xheartrockx

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: batch add working only once
« Reply #9 on: March 16, 2010, 07:43:22 pm »

No, still not working :(

What confuses te me the most is that it worked with the first folder but not with the second...


I'm so so so sorry to bother you with this :(
Logged

onthepike

  • Guest
Re: batch add working only once
« Reply #10 on: March 16, 2010, 08:32:23 pm »

I'm still getting a denial of access in /armywives205/ where I should be getting an index page, a directory listing prohibitation notice or other static redirect, as in your /albums/ directory (which incidentally has a misconfigured redirect). That means you haven't set RECURSIVE premissions from /albums, only permissions ON albums.

Set /armywives205/ to 755 and (first copy, download locally, then) delete any .htaccess file you might have in that folder and try again.
Logged

xheartrockx

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: batch add working only once
« Reply #11 on: March 16, 2010, 09:05:13 pm »

Aha.. so I had to a more advanced version of my ftp uploaded to set the recurvice permissions. At least I think that's what I did, if I understand correctly.
I'm still getting a denial of access from any of these folders (this is not the only pages hosted there where I don'T get access, no matter what I try).

I didn't find any .htaccess files, though...

Ah well... I think I'll just look for another script... don't mean to bother you any further
Logged

onthepike

  • Guest
Re: batch add working only once
« Reply #12 on: March 16, 2010, 09:24:57 pm »

Nonsense. I'm no authority here. Stick around for someone else with more knowledge to assist getting things back to normal. I gave you a few suggestions; they didn't work out for you. Someone else will solve the issue.
Logged

xheartrockx

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: batch add working only once
« Reply #13 on: March 16, 2010, 09:36:58 pm »

and I'm SO gratefuly for any suggestions :) Thanks again for trying.

Part of me thinks it's the server as that other script isn't working as well no matter whan permission settings I have...
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4886
    • Windsurf.me
Re: batch add working only once
« Reply #14 on: March 16, 2010, 10:47:02 pm »

I think in your case you will need to speak to your host. It does appear that you have set chmod but it is not always as simple at that. In this case it looks like you have ownership issues. For the script to be able to write to those files it requires the correct permissions to do so. While your ftp app might have the right permissions whatever group your server is in might not. You will probably find that you have the same trouble with any script you install so it is something you really need to speak to your host about.

Look up chown and chmod with Google for a full explanation of what is going on here and remember that your host may also have its own permissions set so while it may appear you have set 777 (again, Google it to see exactly what 777 or 755 means) but your hosts settings may override those.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

xheartrockx

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: batch add working only once
« Reply #15 on: March 17, 2010, 10:58:37 am »

Thanks Phill,

I think it might the case, yeah. I've had that experience with a few hosts who set the permissions like this for security reasons. I might contact them, find out for sure. I mean, I can add individual pictures but for screencaps it is a bit annoying.

Anyways... thanks for the help, guys. I appreaciate it.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4886
    • Windsurf.me
Re: batch add working only once
« Reply #16 on: March 17, 2010, 06:06:24 pm »

If your host really cannot help due to their restrictions then try the Jupload plugin for bulk uploading. I've often used that to get around certain host restrictions.

http://forum.coppermine-gallery.net/index.php/board,100.0.html
Logged
It is a mistake to think you can solve any major problems just with potatoes.

xheartrockx

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: batch add working only once
« Reply #17 on: March 17, 2010, 06:16:54 pm »

According to them it's not the restriction. I'm in negotiations with them now about a few settings.

I'll keep that in mind, though :D Thank you.
Logged

xheartrockx

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: batch add working only once
« Reply #18 on: March 17, 2010, 09:36:45 pm »

After some back and forth and value adjustments, it's not working.

Don't ask me what it was, though. The support-person upped some value or another (my guess would be the max_upload thingie) and now it's working.

Thanks everyone for the support.
Logged
Pages: [1]   Go Up
 

Page created in 0.025 seconds with 20 queries.