Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: Need help with this: Notice: Undefined offset: 8192 in /customers/mastingallery.  (Read 27714 times)

0 Members and 1 Guest are viewing this topic.

sally

  • Coppermine newbie
  • Offline Offline
  • Gender: Female
  • Posts: 14
    • Mastin Espaņol International

Hi all of you,

I have a problem with my Coppermine gallery that I cannot solve myself :(

I cannot login as admin - and members cannot login either -

I have this message at the main page of my gallery: Notice: Undefined offset: 8192 in /customers/mastingallery.net/mastingallery.net/httpd.www/cpg145/include/debugger.inc.php on line 112

Please, can anyone help me???

Best regards from
Sally
« Last Edit: March 14, 2010, 10:40:00 pm by Joachim Müller »
Logged
Testing the cpg 1.4.8. at
www.MastinGallery.net/cpg145

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de

I guess http://www.mastingallery.net/cpg145/ is the link to your gallery. That gallery needs updating baaaadly: it is running cpg1.4.8, while the most recent stable release currently is cpg1.4.26, so you're running 18 versions behind. This means that you have failed to upgrade for three and a half years. Subsequently, your gallery is extremely vulnerable to get hacked (or maybe even was hacked). You need to upgrade at once.
This piece of advice has been posted free of charge (although you started your thread in the paid support section without paying attention to the rules for this particular sub-board). Since I can't see the point in asking this on the paid support board I'm moving your thread to the regular (free) support board. If you want to pay something, go ahead and donate to the project ;).
Logged

sally

  • Coppermine newbie
  • Offline Offline
  • Gender: Female
  • Posts: 14
    • Mastin Espaņol International

Hi Joachim,
Thanks for answering...
I am sorry if I posted in the 'wrong' place..
Yes, I know my gallery should have been updated a long time ago, but I was unsecure how to do it... and please, have patience with me, I am an old girl at 60 - and please do not tell me that I should leave this to the young generation... :)
I have loved using Coppermine galleries for many years - and the one I have problems with now (mastin espanol) - is the largest gallery of spanish mastiffs in the whole world, and I would hate to let go of it...
Well, what do I do now?
I need help! I want to 'keep' my gallery with my 17.000 photos.
I cannot solve the problems I have at the moments. Of course I would pay anyone who could help me...

Best regards,
Sally   

I guess http://www.mastingallery.net/cpg145/ is the link to your gallery. That gallery needs updating baaaadly: it is running cpg1.4.8, while the most recent stable release currently is cpg1.4.26, so you're running 18 versions behind. This means that you have failed to upgrade for three and a half years. Subsequently, your gallery is extremely vulnerable to get hacked (or maybe even was hacked). You need to upgrade at once.
This piece of advice has been posted free of charge (although you started your thread in the paid support section without paying attention to the rules for this particular sub-board). Since I can't see the point in asking this on the paid support board I'm moving your thread to the regular (free) support board. If you want to pay something, go ahead and donate to the project .
 

 
Logged
Testing the cpg 1.4.8. at
www.MastinGallery.net/cpg145

onthepike

  • Guest

That issue should resolve itself with an update to your gallery. Here are the instructions:

http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upgrade

Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4685
    • Windsurf.me

We certainly would never suggest that you are past it at 60 ;D. Age is no barrier to to anyone who wants to put the effort in.

Upgrading really is a simple task and is something you should try. Once you have done it once you will wonder what all the fuss is about.

It also looks like you have no custom modifications to your gallery so upgrading should be nice and simple.

Here are the skills you nead.

1. To be able to read - Well you obviously have that one nailed ;)
2. Be willing to learn and put the effort in - Maybe that sounded a little patronising.
3. To be able to download, unzip and upload files using filezilla or another ftp app - This is actualy really simple but for some reason a few struggle.
4. To be able to backup your database probably using a tool such as phpmyadmin or whatever your host provides.

Start by reading the docs - http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#14

If there is anything you need verification on then please ask and I will do my best to help.

The ability to upgrade is quite important as you need to keep up or risk getting hacked. This goes for any website not just coppermine based ones. You really don't want to have to pay every time a new release comes. You certainly don't want the sometimes huge expense when some git hacks your website and you have to pay to get it fixed.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

sally

  • Coppermine newbie
  • Offline Offline
  • Gender: Female
  • Posts: 14
    • Mastin Espaņol International

Thank you very much for your replies.
Finally I 'took the step' to update the gallery - and everything went well. I solved my problem :)

However, a few new 'smaller' problems have arrived...
In users' profiles, their avatars and the link to their web sites are not available anymore. How can I solve that?

Best regards,
Sally

www.mastingallery.net


Logged
Testing the cpg 1.4.8. at
www.MastinGallery.net/cpg145

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4685
    • Windsurf.me

Did you have the Stramm modpack installed or something similar? For avatars you probably had a mod installed that will need re-applying.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

sally

  • Coppermine newbie
  • Offline Offline
  • Gender: Female
  • Posts: 14
    • Mastin Espaņol International

Did you have the Stramm modpack installed or something similar? For avatars you probably had a mod installed that will need re-applying.

I only had the coppermine gallery...
Members just used links like this (avatar at my mastin web):
(https://forum.coppermine-gallery.net/proxy.php?request=http%3A%2F%2Fwww.mastininfo.com%2Fmodules%2FForums%2Fimages%2Favatars%2Fgallery%2Ferny.jpg&hash=4743af6a148a56d6d4e6ff5bcfc0ade0)
and this for web site: WEB

- Sally
Logged
Testing the cpg 1.4.8. at
www.MastinGallery.net/cpg145

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1503
  • aka 'i-imagine'
    • Home Page

You were most likely using bbcode tags. Those were disabled back sometime around revision 1.4.19 for security reasons, it is noted in the Documentation package as well as here on the Support Forum.

Coppermine 1.5.x will have some of the bbcode features - see the Coppermine home page for more info..

adibar

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

I have 1.4 version, but I have the same problem in my gallery www.bartniccy.pl
Notice is:  Undefined offset: 8192 in /include/debugger.inc.php on line 112
Could you help me?
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4685
    • Windsurf.me

What you need to do is update to the 1.5.x version. Sadly we can no longer support 1.4.x based coppermine installs. Upgrading is not too hard, is all outlined in the docs and will probably fix your problems and a lot more besides.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

adibar

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

I am afraid that after the update will not fit the style, individually created by me. Should I be afraid?
Logged

adibar

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

1. Which version 1.5 is stable? Is version 5.1.18 is stable?
2. Could you give me a link to the description of how to do the upgrade from 4.1.16 to 5.1.18? In the "Documentation" is just a description of "Upgrading to version cpg1.4.27". Do you upgrade to version 5.1.18 does the same?
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4685
    • Windsurf.me

1.5.20 is the current release as stated at the top of this page.

The documentation is well organised with a large section detailed to upgrading. Please make sure you read it fully before starting.

http://documentation.coppermine-gallery.net/en/upgrading.htm
Logged
It is a mistake to think you can solve any major problems just with potatoes.

adibar

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

But there is a problem with style. It is a style modified by me, "Reynolds", which has been in use without any problem in my version 4.1.16. I have uploaded it to the newly launched (separately) of galleries and displays this error:

Code: [Select]
Template error
Failed to find block 'view_log_files' (#<!-- BEGIN view_log_files -->(.*?)<!-- END view_log_files -->#s) in :
                    <ul>

                            <li><a href="admin.php" title="{ADMIN_TITLE}" class="navmenu">{ADMIN_LNK}</a></li>
                            <li><a href="catmgr.php" title="{CATEGORIES_TITLE}" class="navmenu">{CATEGORIES_LNK}</a></li>
                            <li><a href="albmgr.php{CATL}" title="{ALBUMS_TITLE}" class="navmenu">{ALBUMS_LNK}</a></li>
                            <li><a href="groupmgr.php" title="{GROUPS_TITLE}" class="navmenu">{GROUPS_LNK}</a></li>
                            <li><a href="usermgr.php" title="{USERS_TITLE}" class="navmenu">{USERS_LNK}</a></li>
                            <li><a href="banning.php" title="{BAN_TITLE}" class="navmenu">{BAN_LNK}</a></li>
                            <li><a href="reviewcom.php" title="{COMMENTS_TITLE}" class="navmenu">{COMMENTS_LNK}</a></li>

                            <li><a href="picmgr.php" title="{PICTURES_TITLE}" class="navmenu">{PICTURES_LNK}</a></li>
                            <li><a href="searchnew.php" title="{SEARCHNEW_TITLE}" class="navmenu">{SEARCHNEW_LNK}</a></li>
                            <li><a href="util.php" title="{UTIL_TITLE}" class="navmenu">{UTIL_LNK}</a></li>
                           
<!-- BEGIN documentation -->
                            <li><a href="{DOCUMENTATION_HREF}" title="{DOCUMENTATION_TITLE}" target="cpg_documentation" class="navmenu">{DOCUMENTATION_LNK}</a></li>
<!-- END documentation -->
                    </ul>

Given the above, we could use the new version of the script, if only an easy way to improve the above-mentioned problem, and some of you can help me with this.

If not then I would just find out what causes the error listed below and remove it with your help. Can you help me with its liquidation without updating the script?

Code: [Select]
Notice: Undefined offset: 8192 in /include/debugger.inc.php on line 112
Thanks in advance for your help.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4685
    • Windsurf.me

Sorry, but we no longer support versions other than 1.5 so you will need to update.

Locking
Logged
It is a mistake to think you can solve any major problems just with potatoes.
Pages: [1]   Go Up
 

Page created in 0.127 seconds with 20 queries.