Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Closed]: CF error at installation  (Read 8356 times)

0 Members and 1 Guest are viewing this topic.

explora57

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
[Closed]: CF error at installation
« on: February 20, 2010, 06:14:12 pm »

Here is a link to my gallery

http://edinpics.homeserver.com/images/cpg14x/index.php

which appears to be working fine.  I have read and re-read the board tried every which way I can to solve my problem I already have a web site at www.flylow-flyfast.co.uk using Coppermine and cpmfetch up and working which I did some months ago which given I am maybe a bit more than a novice but defo not an expert I am quite pleased with.

The problem I have here though is quite perplexing following all of the instructions unfortunatel when I run cpmfetch install.php it produces CF error narrative and what appears to be a broken link (with the blue border) the strange thing is when I click on the link it takes me to the Coppermine gallery image no problem.

When I run the following test

Code: [Select]
<html>
<head>
</head>
<body>
<div>
<p>
<table width="950">
<tr>
<td>
<?php error_reporting(E_ALL); ini_set('display_errors',1); ?>
<?php
  
include_once "./cpg14x/cpmfetch/cpmfetch.php";
  
$objCpm = new cpm("./cpg14x/cpmfetch/cpmfetch_config.php");
  
$options = array("subtitle" => "File name : {{pFilename}}");
  
$objCpm->cpm_viewLastAddedMedia(14$options);
  
$objCpm->cpm_viewRandomMediaFrom("cat=1",14$options);
  
$objCpm->cpm_close(); 
?>

</td>
</tr>
</table>
</p>
</body>
</html>

it reports

Quote
Warning: include_once(./cpg14x/cpmfetch/cpmfetch.php) [function.include-once]: failed to open stream: No such file or directory in D:\shares\Websites\images\phptest2.php on line 12

Warning: include_once() [function.include]: Failed opening './cpg14x/cpmfetch/cpmfetch.php' for inclusion (include_path='.;c:\php5\includes;c:\inetpub') in D:\shares\Websites\images\phptest2.php on line 12

Fatal error: Class 'cpm' not found in D:\shares\Websites\images\phptest2.php on line 13


I hope I have provided enough information just tried everything that I am able need some help for sure.

Rgds
Bill
« Last Edit: February 22, 2010, 12:08:36 pm by Joachim Müller »
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4853
    • Windsurf.me
Re: CF error at installation
« Reply #1 on: February 20, 2010, 06:31:26 pm »

Please upgrade your gallery. You are running CPG 1.4.19 while the current release is 1.4.26.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

explora57

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: CF error at installation
« Reply #2 on: February 20, 2010, 08:35:49 pm »

Sorry with respect Phil I am already running 1.4.26 on my new installation I am aware that I am running 1.4.19 on the previous web site but that is on a completely different server and not connected in any way.

Thnaks anyway.

Bill
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4853
    • Windsurf.me
Re: CF error at installation
« Reply #3 on: February 20, 2010, 08:46:15 pm »

Unfortunately the first link does not work for me so I cannot comment on it.

You should still upgrade the second one.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

explora57

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: CF error at installation
« Reply #4 on: February 20, 2010, 09:16:58 pm »

OK the link works fine for me.

I have gone back deleted and reloaded and double checked both the cpg and cpmfetch versions at

http://edinpics.homeserver.com/images/cpg14x/index.php

reinstalled both cpg with new images and cpmfetch and I still get the same error.

Must be something simple going to sleep on it and have another go tomorrow.

Thanks btw will upgrade my first site.

Cheers
bill
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: CF error at installation
« Reply #5 on: February 21, 2010, 08:24:16 am »

Post a deep link to the page where the cpmFetch code is on and where you get the error message. Please use the bbcode tag [ c o d e ] in the future - I have edited your posting accordingly. Both links work for me. Probably was down for Phill because you appear to be self-hosting, which is not recommended nor supported.
Logged

explora57

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: CF error at installation
« Reply #6 on: February 21, 2010, 08:46:42 am »

Thanks for that apologies for not using the BB code it was remiss of me here is a link to the installation page

http://edinpics.homeserver.com/images/cpg14x/cpmfetch/install.php

hitting install will replicate the error.

Bill
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1510
  • aka 'i-imagine'
    • Home Page
Re: CF error at installation
« Reply #7 on: February 21, 2010, 01:44:31 pm »

Make sure that you have correctly set Config >> General Settings >> URL of your Coppermine. That seems to be a common error.

I strongly suggest >> Enable help-icons (?) for Admins << while you are in that menu - they are very instructive.

[off topic]
This is where you should really be concentrating your efforts......
....I am aware that I am running 1.4.19 on the previous web site but that is on a completely different server......

A version that much out of date is at risk for not running for long on any sever - Upgrade it!

explora57

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: CF error at installation
« Reply #8 on: February 21, 2010, 03:43:33 pm »

Thanks for the input Joe but unfortunately it doesn't address or solve the problem Coppermine is working fine its the installation of cpmfetch where the problem arises.


Bill
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: CF error at installation
« Reply #9 on: February 22, 2010, 07:58:01 am »

We do not support people who are reluctant to upgrade - it's silly to put effort into the customization of your site if the core is prone to break. You have a problem: your gallery is outdated. The version you are running is vulnerable against various exploits. Various exploits exist in the wild and are actively used by malevolent people. Once you have solved that problem (it's dead easy), you can take care of the cpmFetch issue you have.
You're rolling several issues into one with your reluctance to upgrade, the fact that you're self-hosting although you don't appear to have the skills and that you're immune to advice. That's fine, go ahead - you have been warned.

Joachim

P.S. One of the reasons why self-hosting sucks: your server currently is down again for me - here's the result of my attempt to ping it.
Code: [Select]
gaugau@gurkenhobel:~$ ping edinpics.homeserver.com
PING edinpics.homeserver.com (86.145.216.237) 56(84) bytes of data.
^C
--- edinpics.homeserver.com ping statistics ---
633 packets transmitted, 0 received, 100% packet loss, time 633497ms
Logged

explora57

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: CF error at installation
« Reply #10 on: February 22, 2010, 09:45:20 am »

I am not at all reluctant to upgrade this is not the issue I can do that and know how to do that, that particular usage of Coppermine and cpmfetch is on a Linux server which has been running problem free for some time now. I have two sites working there no problem at all and I accept what you say and will upgrade ASAP no problem.

Cpmfetch is obviously problematic on home servers I can see that quite clearly from the evidence I have and searching the net for a solution I am obviously pushing some boundaries here but hey its good stuff when it works. Coppermine is working fine and it is the latest version and that will do what I want but I thought I would set up a front page with some random stuff etc well I can see it is a problem for which I am not expert enough to immediately resolve.

We had more snow here last night and some problems with the broad band connection this morning unfortunately sorry if you wasted time as I do value any advice you give.

I am a photographer not a computer expert.

Cheers
Bill
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: CF error at installation
« Reply #11 on: February 22, 2010, 10:00:31 am »

I am not at all reluctant to upgrade this is not the issue I can do that and know how to do that
Then go ahead and stop arguing - it will take less than 5 minutes. Instead of typing your anwer you could just have performed the upgrade.

that particular usage of Coppermine and cpmfetch is on a Linux server which has been running problem free for some time now.
The operating system doesn't matter at all.


Cpmfetch is obviously problematic on home servers
No, that's not the case. cpmFetch runs both on my Linux-driven as well as on my Windows-driven testbeds just fine. The difference between you and me is just that I'm not making my testbeds public on the internet - I run them locally for testing, development and evaluation purposes. To put pics on the internet (i.e. make them publicly available) I trust in paid webhosting.
You're drawing the wrong conclusions: just because it doesn't work for you doesn't mean that it doesn't work at all.

I am a photographer not a computer expert.
That doesn't matter at all imo. It just means that you really should review the idea to host a server on your own if you're not an expert.
Logged

explora57

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: CF error at installation
« Reply #12 on: February 22, 2010, 10:43:27 am »

So there is an answer but your not prepared it seems to share it well OK no problem.

Have a nice day.

Bill
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: CF error at installation
« Reply #13 on: February 22, 2010, 12:08:22 pm »

There's certainly an answer, but I don't know it yet. I might have been able to figure it out together with you if you wouldn't behave like a jerk:
  • first of all, your site is still down for me, so what should I look at?
  • Neither I nor anyone else is ready to waste time looking into issues that might be caused by the fact that you're running an outdated app. There's a reason why new maintenance releases come out: they fix things that didn't work as expected in previous versions.
  • You haven't proven that you have filled in the field that Joe mentioned by attaching a screenshot of that section to your posting or at least saying what that record is for you.

I wish you a nice day as well. Stop bitching and treat supporters with respect and you'll get support. This is not only the case here, but on any other forum on the www. Marking thread as closed, as you decided to walk away.
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.