Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: thumbnail.php generating 404s  (Read 2287 times)

0 Members and 1 Guest are viewing this topic.

AntonLargiader

  • Coppermine novice
  • *
  • Country: 00
  • Offline Offline
  • Posts: 31
    • My Coppermine Album
thumbnail.php generating 404s
« on: February 16, 2010, 02:20:32 pm »

Looking through my server logs I found some 404s from CPG

The album shown has just those four pictures, cyl1.jpg through cyl4.jpg. The following appears in the log:

URL                 hits     referrer
/album/cyl2.jpg   6   http://www.largiader.com/album/thumbnails.php
/album/cyl3.jpg   6   http://www.largiader.com/album/thumbnails.php
/album/cyl4.jpg   6   http://www.largiader.com/album/thumbnails.php
/album/cyl1.jpg   6   http://www.largiader.com/album/thumbnails.php
/images/h_powered-php.gif   2   http://www.largiader.com/album/thumbnails.php
/images/h_powered-mysql.gif   2   http://www.largiader.com/album/thumbnails.php
/images/button_bg_anim.gif   2   http://www.largiader.com/album/thumbnails.php
/images/h_valid-css.gif   2   http://www.largiader.com/album/thumbnails.php
/images/valid-xhtml10.gif   2   http://www.largiader.com/album/thumbnails.php
/images/powered-php.gif   2   http://www.largiader.com/album/thumbnails.php
/images/button_bg.gif   2   http://www.largiader.com/album/thumbnails.php
/images/powered-mysql.gif   2   http://www.largiader.com/album/thumbnails.php
/images/h_valid-xhtml10.gif   2   http://www.largiader.com/album/thumbnails.php
/images/valid-css.gif   2   http://www.largiader.com/album/thumbnails.php

Is this just a server hiccup? It looks like CPG generated calls to the wrong URL. BTW this represents about 24 hours. It's not happening every time.

CPG is installed in /album/ on my server, and those files were uploaded to the /album/albums/uploads/bike/ directory.

http://www.largiader.com/album/ is the installation
http://www.largiader.com/album/thumbnails.php?album=12 is the album where those four pictures are.
Logged
My album:  www dot largiader dot com slash album

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1510
  • aka 'i-imagine'
    • Home Page
Re: thumbnail.php generating 404s
« Reply #1 on: February 16, 2010, 02:48:29 pm »

A good "rule of thumb" is if the 404 - 500 etc. errors are not repeatable then it is a server/hosting issue.

Try testing those pages repeatedly with a browser that you can easily clear the cache. If the errors are not repeatable, then ask your host for assistance.

AntonLargiader

  • Coppermine novice
  • *
  • Country: 00
  • Offline Offline
  • Posts: 31
    • My Coppermine Album
Re: thumbnail.php generating 404s
« Reply #2 on: February 16, 2010, 03:03:38 pm »

It's not really a problem in that the album seems to work fine, but searching for 404 gave a few threads indicating that under certain conditions a path variable was not available, or something similar. That seems like a logical cause for me, since /album[some upload path]/cyl2.jpg and [some theme path]/images/button_bg.gif are valid paths.

BTW I am running 1.4.26. I upgraded from 1.4.25 ten days ago.
Logged
My album:  www dot largiader dot com slash album

AntonLargiader

  • Coppermine novice
  • *
  • Country: 00
  • Offline Offline
  • Posts: 31
    • My Coppermine Album
Re: thumbnail.php generating 404s
« Reply #3 on: February 18, 2010, 02:02:07 pm »

No additional entries were found so for the moment I conclude that it's not a problem within CPG. If I can duplicate the problem in the future I'll open a new thread.
Logged
My album:  www dot largiader dot com slash album

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: thumbnail.php generating 404s
« Reply #4 on: February 19, 2010, 08:07:45 am »

It's beyond the scope of this board to help you with issues related to webserver setup. Examining a server's error log and figuring out why particular errors happen clearly falls into that category. Please ask your webhost for support if you have questions concerning the server's log.
Logged
Pages: [1]   Go Up
 

Page created in 0.044 seconds with 19 queries.