Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Critical Error when re-installing the Iscroll plugin  (Read 6438 times)

0 Members and 1 Guest are viewing this topic.

mfjones

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Critical Error when re-installing the Iscroll plugin
« on: February 04, 2010, 06:57:10 am »

I recently removed the beautifully working iscroll plug-in from my cpm gallery using the config/general settings/manage plug-ins, delete button. Now I am trying to reinstall it but I get this message. “Critical Error – There was an error while processing a database query.” It is followed by this code and a file path to /functions.inc.php – Line 250.

Code: [Select]
While executing query "INSERT INTO config VALUES('iscroll_cfg_meta', '1'), ('iscroll_cfg_count', '24'),('iscroll_cfg_width', '800'), ('iscroll_cfg_height', '250') " on 0

mySQL error: Duplicate entry 'iscroll_cfg_meta' for key 1

It appears the manage plugins delete function has left these files somewhere in my gallery. I have followed the path to /functions.inc.php Line – 250, but have found nothing there that resembles the information above. Even if it did I’m a php novice and would not know what to do with the information anyway. Can someone please help.


http://www.michaelfjones.com
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Critical Error when re-installing the Iscroll plugin
« Reply #1 on: February 04, 2010, 07:33:31 am »

I guess you're refering to the plugin "Image Scroller - Based on iTunes - Slideshow for Main and Album List Pages v1.1".
Looks like the uninstall routine of that plugin didn't work as expected and left the settings behind. Now the install routine complains about the settings already being present. In an ideal world, both the uninstall as well as the install routines would be better of that plugin (imo they suck, as suggested in another plugin by that author). To fix that issue for you, either manually delete the leftover database records (if you know your way around) or modify codebase.php with a plain text editor, find
Code: [Select]
$sql = "INSERT INTO {$CONFIG['TABLE_CONFIG']} VALUES('iscroll_cfg_meta', '1'), ('iscroll_cfg_count', '24'),('iscroll_cfg_width', '800'), ('iscroll_cfg_height', '250') ";and replace with
Code: [Select]
$sql = "INSERT IGNORE INTO {$CONFIG['TABLE_CONFIG']} VALUES('iscroll_cfg_meta', '1'), ('iscroll_cfg_count', '24'),('iscroll_cfg_width', '800'), ('iscroll_cfg_height', '250') ";
http://www.michaelfjones.com
That page doesn't contain a coppermine-driven gallery. When posting on this forum it's mandatory to post a link to your coppermine-driven gallery and not just to your home page.
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1511
  • aka 'i-imagine'
    • Home Page
Re: Critical Error when re-installing the Iscroll plugin
« Reply #2 on: February 04, 2010, 12:12:40 pm »

New release to address issue

mfjones

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Critical Error when re-installing the Iscroll plugin
« Reply #3 on: February 05, 2010, 06:56:27 am »

Thank you Gau Gau for your fast response. As suggested I removed the suspected code and added the replacement code to the codebase.php page. Now when i install iscroll the plugin manager shows install was successful as well as iscroll's configuration. However, when I return to my home page or album page I can see a space where iscroll should load but nothing happens iscroll does not show up?

 Also, my link should work now. Sorry, I forgot to set up the redirect.

http://michaelfjones.com
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1511
  • aka 'i-imagine'
    • Home Page
Re: Critical Error when re-installing the Iscroll plugin
« Reply #4 on: February 05, 2010, 11:29:51 am »

You need to read the thread + instructions for the plugin. iScroll for Coppermine

Security updates implemented in version 1.1 prevent the script from being run by any/all domains. (the short story)

Because you have a redirect, you will need to confirm your settings for "URL of Coppermine" in Config. You might also need to setup/add a file "crossdomain.xml".

It's all in the original thread - so is a newer version with these same instruction.

mfjones

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Critical Error when re-installing the Iscroll plugin
« Reply #5 on: February 06, 2010, 07:29:55 am »

Thanks Joe for your response. I assumed the problem with not being able to see  the plugin working on my cpm site was related to the initial problem of re-installing it. I went back and reread the threads and tried the “crossdomian.xml” and now it works beautifully.

Thank you for the plugin and thanks to you and GauGau for the help. :)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.