Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Fatal Error After Hosting Move  (Read 3830 times)

0 Members and 1 Guest are viewing this topic.

glennk

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 43
Fatal Error After Hosting Move
« on: January 27, 2010, 05:12:26 pm »

Hi There.

I recently moved hosts. I transferred the database across and was met by a screen saying mysql could not connect. After searching around this forum I realised I had the databse username and password wrong in the inc/config file.

I set the configuration right and am not met by a screen saying fatal erorr.

My site url is :

http://www.whitbyseaanglers.co.uk/members-gallery/index.php

Your help would be appreciated.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Fatal Error After Hosting Move
« Reply #1 on: January 27, 2010, 05:15:35 pm »

Enable debug mode in coppermine's config, then post the actual error message (the query that fails - not the debug_output). If you can't go to the config screen to enable debug mode, read up Tutorial: Manually enabling debug_mode
Logged

glennk

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 43
Re: Fatal Error After Hosting Move
« Reply #2 on: January 27, 2010, 05:59:21 pm »

Thankyou for that. The resulting error message says

Quote
While executing query "select * from cpg_plugins order by priority asc;" on 0

mySQL error: Table 'copp1.cpg_plugins' doesn't exist
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: Fatal Error After Hosting Move
« Reply #3 on: January 27, 2010, 06:20:17 pm »

Have you correctly set the database name in include.config.inc.php ?

The database name will have changed too which is likely to be your problem.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

glennk

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 43
Re: Fatal Error After Hosting Move
« Reply #4 on: January 27, 2010, 06:36:53 pm »

Hi Phil,

Wouldnt the error be different if that was the case ? would it not just say unable to connect ?
Logged

glennk

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 43
Re: Fatal Error After Hosting Move
« Reply #5 on: January 27, 2010, 06:39:03 pm »

This is whats in the file. I think its right but then again I could be wrong :

Quote
<?php

    define ( 'SILLY_SAFE_MODE' , 1 ) ;

    $CONFIG['dbserver'] = 'localhost' ;
    $CONFIG['dbuser'  ] = 'copp1user' ;
    $CONFIG['dbpass'  ] = ' [Edit] ' ;
    $CONFIG['dbname'  ] = 'copp1'   ;

    $CONFIG['TABLE_PREFIX'] = 'cpg_';

?>
« Last Edit: January 27, 2010, 06:51:51 pm by Jeff Bailey »
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: Fatal Error After Hosting Move
« Reply #6 on: January 27, 2010, 07:15:07 pm »

Not if the table prefix was incorrect. However, in that case you would probably get a config table missing error at that is processed before the plugins.

Check using phpmyadmin that the copp1.cpg_plugins does exist. If not restore it from your backup
Logged
It is a mistake to think you can solve any major problems just with potatoes.

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: Fatal Error After Hosting Move
« Reply #7 on: January 27, 2010, 07:19:39 pm »

Now after running update.php for you there is a different error.

'copp1.cpg_users'

It certainly looks like you haven't restored your database correctly.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

glennk

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 43
Re: Fatal Error After Hosting Move
« Reply #8 on: January 27, 2010, 07:35:53 pm »

Cheers Phil.  :)

I was wondering what was happening there as I noticed the error message changed. I have spoken to support and the hosts are going to try install the database again from the original dump.

I will post back to let you know how it goes.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: Fatal Error After Hosting Move
« Reply #9 on: January 27, 2010, 08:59:26 pm »

Always take regular dumps yourself, being regular is good for you ;)

Seriously though, taking regular backups is essential. Had you done that yourself you would not have to await your host.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

glennk

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 43
Re: Fatal Error After Hosting Move
« Reply #10 on: January 28, 2010, 09:43:54 pm »

Cheers Phil,

I will have to get into the habbit of weekly dumps.

Indeed you were right, the database had not imported properly. I started from scratchg and with the help of the hosts, all appears to be working now.

Many thanks for your help yet again guys, and ofcourse, thanks to joachim for not shouting at me.  ;D :D :D
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 19 queries.