Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Closed]: New administrator - no list of useers  (Read 3362 times)

0 Members and 1 Guest are viewing this topic.

doliver

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
[Closed]: New administrator - no list of useers
« on: January 05, 2010, 09:15:43 pm »

http://pdqflyers.com/

I have taken over as administrator of the gallery, and have no access to the previous administrator.
I have searched the docs and the forum, without finding any clues.

There are 10 albums of user's pictures, so there should be 10 users, plus administrator listed.
These 10 users have passwords to access their own albums.

As administrator, I seem to be able to do everything, except find out who the users are.
I created a new user, in the Registered group, and he shows up in the list.

In phpMyAdmin, I get exactly the same result.

Thanks for your attention,
Don Oliver
« Last Edit: January 06, 2010, 11:36:01 am by Joachim Müller »
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: New administrator - no list of useers
« Reply #1 on: January 05, 2010, 09:33:04 pm »

link is http://pdqflyers.com/gallery/index.php

<!--Coppermine Photo Gallery 1.4.23 (stable)-->
Please upgrade

If there were users, is it possible the users were deleted?
your user_id does suggest there were other users.

The user albums all appear to have been created by PDQAdmin
http://pdqflyers.com/gallery/displayimage.php?album=17&pos=1
http://pdqflyers.com/gallery/displayimage.php?album=09&pos=1
Are some examples... look in the file information.

Check this search for the other admins password.
« Last Edit: January 05, 2010, 10:28:52 pm by Jeff Bailey »
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

doliver

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: New administrator - no list of useers
« Reply #2 on: January 06, 2010, 02:03:31 am »

Jeff, thanks for your reply.

I updated to 1.4.25.

I also checked the links that you provided, and found nothing that would help.

Attached is a screenshot of the User Manager, showing only the administrator and the one user that I added to the Registered group.

Any other ideas welcome.

Don
Logged

doliver

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: New administrator - no list of useers
« Reply #3 on: January 06, 2010, 04:11:53 am »

I believe I know what has happened.

When I took over, the gallery was not working - nothing showed.

I found the album files, and put them into the gallery.
Obviously, since only the administrator shows, it is because I put them all there.
At that time I did not find, nor know to look for, a user list.

So, Jeff, you were correct to say that they were all created by admin.

I will have to poll the members, to see who owned the albums, and start over.
Thanks for your help.

I will now close this thread.
Don
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: New administrator - no list of useers
« Reply #4 on: January 06, 2010, 11:35:48 am »

I will now close this thread.
@doliver: marking it as solved as suggested per board rules would have done the trick. You failed to do so, so I'm marking it accordingly for you. Thanks for doing as suggested in the future.

@others with similar issues: although doliver reported his issue to be solved, I don't understand a word of the explanation he has given: I don't understand the question nor the solution). Permission issues or authentification issues won't go by copying files around like doliver suggested. Take our word on that: users and authentification are database driven processes. Moving files around doesnÄt have an impact on that.
Logged

doliver

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: New administrator - no list of useers
« Reply #5 on: January 06, 2010, 06:28:03 pm »

@doliver: marking it as solved as suggested per board rules would have done the trick. You failed to do so, so I'm marking it accordingly for you. Thanks for doing as suggested in the future.

@others with similar issues: although doliver reported his issue to be solved, I don't understand a word of the explanation he has given: I don't understand the question nor the solution). Permission issues or authentification issues won't go by copying files around like doliver suggested. Take our word on that: users and authentification are database driven processes. Moving files around doesnÄt have an impact on that.

Sorry I missed the little check mark. I did look in the board rules for how to mark it, but could not find it. Since you brought it up, I searched again, enlarged the fuzzy little picture, and there it was!
I will definitely mark any future posts this way. Thanks for marking it for me this time.

The question was very simple: there were no users except the administrator. I sent a screen shot to show this.

The solution was also very simple, once I realized what had happened. I will try to make it easier to understand:
I was not suggesting that, as you implied, that one should move the files around. On the contrary, that was the problem, not the solution.
The problem had nothing to do with permissions or authentication issues.

The gallery was totally messed up - nothing showed when I took over.
I found the album folders, and made them into albums. That was easy. but not the right way to do it.

After getting the clue from Jeff, I realized that there was no easy fix, and have now started doing it right.
I created a user for each album, and am now in the process of adding the pictures, by uploading from the mirror of the gallery on my computer, as is the correct procedure.
This is a tedious process, as there are many pictures but, when completed, everything will be correct and working properly.

So, even though my question may have not been understood, I did get the help I needed as a result of the posting, and for that I am grateful.

Don
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 19 queries.