Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Can I add a link to user uploads in sysmenu?  (Read 4174 times)

0 Members and 1 Guest are viewing this topic.

Solberg

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Can I add a link to user uploads in sysmenu?
« on: December 31, 2009, 09:37:45 pm »

Hi
I have looked for an answer for hours, but cant find an exact answer, hope you can help me.

My danish gallery - http://myshot.dk/index.php
Using Stramms modpack and a modded version of I-feel-dirty.

I would like a link in sysmenu that allows registered (and logged in) users to go directly to their own images.
"User Galleries" is disabled.

I think johnnystorm describes it well in this thread: http://forum.coppermine-gallery.net/index.php/topic,61617.msg306587.html#msg306587

The link should only be visible for logged in users.

Atmorell has a similar question in this thread: http://forum.coppermine-gallery.net/index.php/topic,46443.0.html, but Im not sure how to use this code.

Could somebody tell me exactely what code to put in my theme?

Right now the code in sysmenu looks like this
Code: [Select]
$template_sys_menu = <<<EOT

<!-- BEGIN register -->
                                                <li><a href="{REGISTER_TGT}" title="{REGISTER_TITLE}">{REGISTER_LNK}</a></li>
<!-- END register -->
<!-- BEGIN login -->
                                                <li><a href="{LOGIN_TGT}" title="{LOGIN_LNK}">{LOGIN_LNK}</a></li>
<!-- END login -->
<!-- BEGIN home -->
                                                <li><a href="{HOME_TGT}" title="{HOME_TITLE}">{HOME_LNK}</a></li>
<!-- END home -->
<!-- BEGIN upload_pic -->
                                                <li><a href="{UPL_PIC_TGT}" title="{UPL_PIC_TITLE}">{UPL_PIC_LNK}</a></li>
<!-- END upload_pic -->
<!-- BEGIN my_gallery -->
                                                <li><a href="{MY_GAL_TGT}" title="{MY_GAL_TITLE}">{MY_GAL_LNK}</a></li>
<!-- END my_gallery -->
<!-- BEGIN allow_memberlist -->
                                                <li><a href="{MEMBERLIST_TGT}" title="{MEMBERLIST_TITLE}">{MEMBERLIST_LNK}</a></li>
<!-- END allow_memberlist -->
<!-- BEGIN my_profile -->
                                                <li><a href="{MY_PROF_TGT}" title="{MY_PROF_LNK}">{MY_PROF_LNK}</a></li>
<!-- END my_profile -->
<!-- BEGIN faq -->
                                                <li><a href="{FAQ_TGT}" title="{FAQ_TITLE}">{FAQ_LNK}</a></li>
<!-- END faq -->
<!-- BEGIN custom_link -->
                                                <li><a href="http://myshot.dk/index.php?file=recaptcha/echo" title="Kontakt Webmaster">Kontakt Webmaster</a></li>
<!-- END custom_link -->
<!-- BEGIN logout -->
                                                <li><a href="{LOGOUT_TGT}" title="{LOGOUT_LNK}">{LOGOUT_LNK}</a></li>
<!-- END logout -->
<!-- BEGIN enter_admin_mode -->
                                                <li><a href="{ADM_MODE_TGT}" title="{ADM_MODE_TITLE}">{ADM_MODE_LNK}</a></li>
<!-- END enter_admin_mode -->
<!-- BEGIN leave_admin_mode -->
                                                <li><a href="{USR_MODE_TGT}" title="{USR_MODE_TITLE}">{USR_MODE_LNK}</a></li>
<!-- END leave_admin_mode -->

EOT;

Thanks in advance

Kasper Solberg
Logged

Solberg

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Can I add a link to user uploads in sysmenu?
« Reply #1 on: January 09, 2010, 07:49:01 pm »

Anyone?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Can I add a link to user uploads in sysmenu?
« Reply #2 on: January 10, 2010, 09:19:28 am »

Right now the code in sysmenu looks like this
Code: [Select]
$template_sys_menu = <<<EOT

<!-- BEGIN register -->
                                                <li><a href="{REGISTER_TGT}" title="{REGISTER_TITLE}">{REGISTER_LNK}</a></li>
<!-- END register -->
<!-- BEGIN login -->
                                                <li><a href="{LOGIN_TGT}" title="{LOGIN_LNK}">{LOGIN_LNK}</a></li>
<!-- END login -->
<!-- BEGIN home -->
                                                <li><a href="{HOME_TGT}" title="{HOME_TITLE}">{HOME_LNK}</a></li>
<!-- END home -->
<!-- BEGIN upload_pic -->
                                                <li><a href="{UPL_PIC_TGT}" title="{UPL_PIC_TITLE}">{UPL_PIC_LNK}</a></li>
<!-- END upload_pic -->
<!-- BEGIN my_gallery -->
                                                <li><a href="{MY_GAL_TGT}" title="{MY_GAL_TITLE}">{MY_GAL_LNK}</a></li>
<!-- END my_gallery -->
<!-- BEGIN allow_memberlist -->
                                                <li><a href="{MEMBERLIST_TGT}" title="{MEMBERLIST_TITLE}">{MEMBERLIST_LNK}</a></li>
<!-- END allow_memberlist -->
<!-- BEGIN my_profile -->
                                                <li><a href="{MY_PROF_TGT}" title="{MY_PROF_LNK}">{MY_PROF_LNK}</a></li>
<!-- END my_profile -->
<!-- BEGIN faq -->
                                                <li><a href="{FAQ_TGT}" title="{FAQ_TITLE}">{FAQ_LNK}</a></li>
<!-- END faq -->
<!-- BEGIN custom_link -->
                                                <li><a href="http://myshot.dk/index.php?file=recaptcha/echo" title="Kontakt Webmaster">Kontakt Webmaster</a></li>
<!-- END custom_link -->
<!-- BEGIN logout -->
                                                <li><a href="{LOGOUT_TGT}" title="{LOGOUT_LNK}">{LOGOUT_LNK}</a></li>
<!-- END logout -->
<!-- BEGIN enter_admin_mode -->
                                                <li><a href="{ADM_MODE_TGT}" title="{ADM_MODE_TITLE}">{ADM_MODE_LNK}</a></li>
<!-- END enter_admin_mode -->
<!-- BEGIN leave_admin_mode -->
                                                <li><a href="{USR_MODE_TGT}" title="{USR_MODE_TITLE}">{USR_MODE_LNK}</a></li>
<!-- END leave_admin_mode -->

EOT;
That's not enough; zip your custom theme's folder and attach the zip to your posting. The link target thumbnails.php?album=lastupby&uid=USER_ID_HERE needs to be composed in the function and not just the variable definition.
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 19 queries.