Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: error message when using the ATSIV BLUE THEME  (Read 11884 times)

0 Members and 1 Guest are viewing this topic.

maosee

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
error message when using the ATSIV BLUE THEME
« on: December 23, 2009, 02:16:16 pm »

Dear Sir:

I have installed the ATSIV BLUE theme,
when I click onto the album, below error comes out:


Template error
Failed to find block 'c_spacer'(#(<!-- BEGIN c_spacer -->)(.*?)(<!-- END c_spacer -->)#s) in :


<!-- BEGIN c_header -->
        <tr class="tableb_compact">
<!-- END c_header -->


<!-- BEGIN c_row_separator -->
        </tr>
        <tr class="tableb_compact">
<!-- END c_row_separator -->
<!-- BEGIN c_footer -->
        </tr>
<!-- END c_footer -->

<!-- BEGIN spacer -->
<!-- END spacer -->

my link: http://www.photoyellall.com, can someone help to sort out the problem? thanks
« Last Edit: December 23, 2009, 08:26:09 pm by Phill Luckhurst »
Logged

Gene-2008

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 188
Re: error message when using the ATSIV BLUE THEME
« Reply #1 on: December 23, 2009, 03:12:50 pm »

Did you edit the theme.php?

This is looking for tokens in the $template_album_list_cat.

This template should be in that file.

Let me know,
Gene
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: error message when using the ATSIV BLUE THEME
« Reply #2 on: December 23, 2009, 05:24:41 pm »

You're running cpg1.5.x, which goes unsupported (as in "no support at all"). That's why that gallery displays for you (in big bold letters)
Quote
Unsupported version!
You are running Coppermine 1.5.1 (alpha) which is only meant for very experienced users - this version comes without support nor any warranties. Use it at your own risk or downgrade to the latest stable version if you need support!
Does this mean anything to you? No support means exactzly what it says. Of course, a theme designed for cpg1.4.x doesn't work with cpg1.5.x out of the box. The documentation that comes with cpg1.5.x clearly says so and even explains what you need to do to make that theme work with cpg1.5.x, but you're on your own with that.
Moving this thread to the support board for cpg1.5.x (although that board has not opened publicly). Stop behaving like a jerk.
Logged

Gene-2008

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 188
Re: [Invalid]: error message when using the ATSIV BLUE THEME
« Reply #3 on: December 23, 2009, 05:54:20 pm »

Why did you say he is running 1.5.x?  Isn't he running 1.4.25?

And the theme is released as 1.4.25 capable.
http://forum.coppermine-gallery.net/index.php/topic,62294.0.html

Am I missing something?

Gene
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: [Invalid]: error message when using the ATSIV BLUE THEME
« Reply #4 on: December 23, 2009, 06:01:32 pm »

Quote
Coppermine version: 1.5.1
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1543
  • aka 'i-imagine'
    • Home Page
Re: [Invalid]: error message when using the ATSIV BLUE THEME
« Reply #5 on: December 23, 2009, 06:22:13 pm »

User's Head:

Foot outputs:
Quote
<!--Coppermine Photo Gallery 1.4.25 (stable)-->

Is probably a case of using 1.5.x theme on 1.4.25.

maosee make sure you pay attention when you download!

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: [Invalid]: error message when using the ATSIV BLUE THEME
« Reply #6 on: December 23, 2009, 06:57:38 pm »

I think you are right Joe. The docs are from 1.4.25, too.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: [Invalid]: error message when using the ATSIV BLUE THEME
« Reply #7 on: December 23, 2009, 08:24:23 pm »

Opening /sql/update.sql as a text file clearly shows what version is being run.


##  Coppermine version: 1.4.25
##  $HeadURL: https://coppermine.svn.sourceforge.net/svnroot/coppermine/trunk/cpg1.4.x/sql/update.sql $
##  $Revision: 5997 $
##  $Author: gaugau $
##  $Date: 2009-05-26 08:43:24 +0200 (Di, 26 Mai 2009) $
##  ********************************************

Afaik there isn't a version of astiv_blue for 1.5x yet?

Moving to the 1.4.x section as this shouldn't be in the 1.5.x section. Not sure if the OP has changed his version or something. I'm sure Joachim would have checked. As a guess, the OP was running 1.5.x with the 1.4.x astiv_blue theme but read Joachim's post and changed to 1.4.25. Now his theme does not work there either but classic does.

maosee,

Could you tell use what you are up to as currently we have no idea. If you are now happy please mark your thread as closed.
« Last Edit: December 23, 2009, 09:36:12 pm by Phill Luckhurst »
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Gene-2008

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 188
Re: [Invalid]: error message when using the ATSIV BLUE THEME
« Reply #8 on: December 23, 2009, 08:48:06 pm »

User's Head:

Foot outputs:
Is probably a case of using 1.5.x theme on 1.4.25.

maosee make sure you pay attention when you download!


That SVN info should have been stripped.  That is my fault.  I believe the footer is correct.  The coppermine may have been 1.5.x...but it is now 1.4.25.
The only released atsiv blue theme is for 1.4.25. 

I have versions for 1.5.x but have not released them yet.

Gene
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: error message when using the ATSIV BLUE THEME
« Reply #9 on: December 23, 2009, 09:37:11 pm »

OK, so we can blame Gene - lol.

I'll move the posters other post back to the 1.4.x board.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

maosee

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: error message when using the ATSIV BLUE THEME
« Reply #10 on: December 24, 2009, 10:26:51 am »

Yes, it is right that my version is 1.5, since my friend install it for me, I didn't know the version, I will downgrade back to 1.4, thanks for help!
Logged

maosee

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: error message when using the ATSIV BLUE THEME
« Reply #11 on: December 29, 2009, 06:17:01 am »

I have re-install the coppermine with 1.424 version, still have below message, I haven't change anything of the theme or either the coppermine, I only add a chinese langugae only, please help to check how I can solve this problem:

My link is http://www.photoyellall.com


Template error
Failed to find block 'c_spacer'(#(<!-- BEGIN c_spacer -->)(.*?)(<!-- END c_spacer -->)#s) in :


<!-- BEGIN c_header -->
        <tr class="tableb_compact">
<!-- END c_header -->


<!-- BEGIN c_row_separator -->
        </tr>
        <tr class="tableb_compact">
<!-- END c_row_separator -->
<!-- BEGIN c_footer -->
        </tr>
<!-- END c_footer -->

<!-- BEGIN spacer -->
<!-- END spacer -->

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: error message when using the ATSIV BLUE THEME
« Reply #12 on: December 29, 2009, 09:48:07 am »

My link is http://www.photoyellall.com
That site is now using the classic theme and requires a login, so you need to provide a non-admin test user account if you want us to look into this for you. Stop behaving difficult!

I have re-install the coppermine with 1.424 version
Why? Most recent stable release is cpg1.4.25, so why do you install an outdated version?

I only add a chinese langugae only
Erm, you did what? Coppermine comes with two chinese language files out of the box, so you better explain what you actually did.
Logged

maosee

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: error message when using the ATSIV BLUE THEME
« Reply #13 on: December 29, 2009, 10:53:53 am »

I have created a user call test, same as the password, can you have a look, please!

Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: error message when using the ATSIV BLUE THEME
« Reply #14 on: December 29, 2009, 01:54:59 pm »

I've tried logging in with username - test and password -test and no joy. I tried with no password and with a password of password.

Why do I feel like I am wasting my time?
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: error message when using the ATSIV BLUE THEME
« Reply #15 on: December 29, 2009, 09:59:29 pm »

maosee, your next posting better make 100% sense and contain all needed details or you'll be gone! ::)
Logged

maosee

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: error message when using the ATSIV BLUE THEME
« Reply #16 on: December 30, 2009, 01:38:11 am »

I have created a user call test, same as the password, can you have a look, please!

Means the username is test, the password is the same, so the password is test, honestly, if we have the know how, or can solve the problem, who will post for help? you can expect everyone as smart as you, right! that is why we ask help from you! anyway, thanks for help!
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: error message when using the ATSIV BLUE THEME
« Reply #17 on: December 30, 2009, 05:58:54 pm »

I can replicate your report when going to http://www.photoyellall.com/index.php?cat=4&theme=atsiv_blue and logging in with the test user account you created. Obviously the theme is broken. The same thing does not happen on our demo though - http://coppermine-gallery.net/demo/cpg14x/index.php?cat=4&theme=atsiv_blue doesn't show that error message, so you better make sure to have grabbed the most recent version of the atsiv_blue theme from the announcement thread for that theme.
Logged

Nibbler

  • Guest
Re: error message when using the ATSIV BLUE THEME
« Reply #18 on: December 30, 2009, 06:09:25 pm »

Does simply changing

Code: [Select]
<!-- BEGIN spacer -->
<!-- END spacer -->

to

Code: [Select]
<!-- BEGIN c_spacer -->
<!-- END c_spacer -->

in theme.php fix it?
Logged

maosee

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: error message when using the ATSIV BLUE THEME(CLOSED)
« Reply #19 on: December 31, 2009, 03:07:09 am »

Tks for hlep
Logged
Pages: [1] 2   Go Up
 

Page created in 0.029 seconds with 20 queries.