Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: batch sreen over and over again  (Read 10672 times)

0 Members and 1 Guest are viewing this topic.

ferreiraactiva

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
[Solved]: batch sreen over and over again
« on: April 09, 2009, 01:06:26 am »

Hello users:
I have a problem that I cant understand. Let me explain as good as I can.
I have sended the pics into the server by ftp. Then I go to the batch sreen and select the directory where the pics are and assigne the correct album, but when I press insert selected pictures, instead of seeing the ok sreen it goes to the bach sreen again over and over. I have tried to found a solution as my one and on the forum and didnt get an solution, because i had batched other pics to the same album and it worked but now i cannot batch another pics.
Can anyone help me?
Thanks...
Zd

user:tester
pass:tester
url: http://ferreiraactiva.org/galerias
« Last Edit: April 21, 2009, 11:14:46 pm by Joachim Müller »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: batch sreen over and over again
« Reply #1 on: April 09, 2009, 07:24:42 am »

Being caught in an endless loop usually happens if you have named your folders in an inappropriate way. Make sure that your folder names are web-safe (no spaces, no special chars). Post a deep link to one of the files you're trying to batch-add.
Additionally, you need to upgrade instantly: you're running cpg1.4.19, while the most recent stable release currently is cpg1.4.21
Logged

ferreiraactiva

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: batch sreen over and over again
« Reply #2 on: April 09, 2009, 04:31:06 pm »

Hello:

Thanks for your help, but I have checked and I am not using any special caracthers. I haved batched other files to the album inquestion, but now I cant do it anymore. And this is not the only album with problems, but if I can resolve this I will then resolve the others.
I have updated to the latest version, but still didnt work.
What do you mean by posting a deep link to one of the files?Sorry for the question but I am not a expert and may not be interpreting you suggestion well , once I am Portuguese.
Thanks...

Zd
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: batch sreen over and over again
« Reply #3 on: April 10, 2009, 09:50:50 am »

What do you mean by posting a deep link to one of the files?Sorry for the question but I am not a expert and may not be interpreting you suggestion well , once I am Portuguese.
Try http://en.wikipedia.org/wiki/Deep_link

Something like http://coppermine-gallery.net/demo/cpg14x/albums/userpics/19980/040818-COURGE.jpg would be a deep link to one of the files that reside on our demo's webspace. What I've asked you for is a deep link to one of the files you're having issues with. Something like http://ferreiraactiva.org/galerias/albums/img/acampamentos/2004/acampamento_de_8_de_abril_%2812%29.jpg (although that's a deep link to a file that already has been added to your database).

Thanks for your help, but I have checked and I am not using any special caracthers.
Sure thing. That's why the very first file I tried (the deep link example from your site above that points to a file that already exists in your database) that I have picked randomly contains special characters (as you can see in the representation of the URL using the funny %28 combination to represent the opening bracket and %29 for the closing bracket. The brackets are special characters that should not be used in web-safe file or folder names. OK, so you said that you're not using any special characters, which was a false assumption. Any other false assumptions you have made? I tried using the test user account that you have posted in your initial posting to test http uploads, but that doesn't work because you failed to set your gallery up as suggested in the docs, section "asking for support on upload issues": the tester doesn't have the privileges to create an album of his own, nor is he allowed to upload to a public album. Hence I got the error message
Quote
Sorry there is no album where you are allowed to upload files
, so I'm stuck as well.


I have updated to the latest version, but still didnt work.
Really? That's amazing. To me it seems as if you're using cpg1.4.20, while the most recent stable release currently is cpg1.4.21. I'm not ready to play games with you.

Please do your homework first.
Logged

ferreiraactiva

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: batch sreen over and over again
« Reply #4 on: April 16, 2009, 02:15:29 am »

Hello:

Back again after making some homework.
Updated to 1.4.21
When I assume that I am not using special carachteres I was referring to the album in question
Now it´s possible users to upload images even in the tester account
Still not able to batch ad files when inserting the files into the album, so the same problem continue
Deep link: http://ferreiraactiva.org/galerias/albums/img/canoagem/subidamira/p1080382.jpg

Dont know what to do anymore and can´t find a reason to this problem because in past I could batch add files as you can see in the album in question. But now not anymore.
I´ll be waitting for your special comments.
thanks for all.

Zd
Logged

jeepguy_1980

  • Contributor
  • Coppermine regular visitor
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 94
    • Loop Family Forum & Gallery
Re: batch sreen over and over again
« Reply #5 on: April 16, 2009, 02:47:36 am »

He telling you to access your album folders via ftp and change the folder and file names to exclude special characters.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: batch sreen over and over again
« Reply #6 on: April 16, 2009, 08:18:58 am »

But do not change the folder names for images that already reside in your database, or the reference to those pics will be broken. I suggested renaming only the folders that contain files that don't already exist in the database. You appear to have a mixture of both.

You have browsing turned on (not a good idea, generally speaking), so I was able to take a look around: you already have some files residing within that folder that appear to have been added to the database previously. Move the new pics into a new sub-folder of their own and then try batch-adding them.
There's something fishy with your webserver setup: http://ferreiraactiva.org/galerias/albums/ returns an internal server error. Review that error. Are you by chance self-hosted? Post details about your server OS and webserver service.
« Last Edit: April 17, 2009, 12:10:44 pm by Joachim Müller »
Logged

ferreiraactiva

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: batch sreen over and over again
« Reply #7 on: April 17, 2009, 01:19:29 am »

Hello:

Thanks for all your help, it has been very helpfull.
Regarding to the recomendations I did moved the new pics to another subfolder and it worked on the album in question. Then I tried to do the same thing to another albuns with the same problem and only worked on another one. So after the second batch add files on other albuns with the same problem it returned the problem and the constant batch add screen.It seems that when I choose the files to be inserted sometimes I cannot choose all of them but have to mark a few and then insert them alternated.It happen today when i tried the subfolder solution as recommended and once it didnt work I tried other ways and on some albuns the only way to batch add files was selecting a few in different times and inserting them.
I am not self-hosted so I pay a annual ammount for the hosting and domain.
The OS is Linux and the webserver service is http://www.webhostingbuzz.com/website-hosting.shtml?host_shared-hosting
So now the problem is resolved for the album in question but it persist on another albuns like:
Category: Canoagem
Subcategory:Kayak-polo
Sub-sub-category:KP2008
Album:3 Fase CNKP
Deeplink:http://ferreiraactiva.org/galerias/albums/img/kayakpolo/2008/3Fase/mafa/dsc0606.jpg

Sorry if I can´t explain the problem better but it´s difficult for someone that is not a expert in this matter to give the correct info what I have encountered in our gallerie. Meanwhile I have turned off the browsing of the site as you can see.

Best regards and a happy weekend.

Zd
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: batch sreen over and over again
« Reply #8 on: April 17, 2009, 12:13:00 pm »

Review your phpinfo output: look for suhosin. If you have suhosin enabled, post the suhosin settings here.
Logged

ferreiraactiva

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: batch sreen over and over again
« Reply #9 on: April 17, 2009, 01:32:22 pm »

This server is protected with the Suhosin Extension 0.9.27

Copyright (c) 2006-2007 Hardened-PHP Project
Copyright (c) 2007-2008 SektionEins GmbH

Directive   Local Value   Master Value
suhosin.apc_bug_workaround   Off   Off
suhosin.cookie.checkraddr   0   0
suhosin.cookie.cryptdocroot   On   On
suhosin.cookie.cryptkey   [ protected ]   [ protected ]
suhosin.cookie.cryptlist   no value   no value
suhosin.cookie.cryptraddr   0   0
suhosin.cookie.cryptua   On   On
suhosin.cookie.disallow_nul   1   1
suhosin.cookie.disallow_ws   1   1
suhosin.cookie.encrypt   Off   Off
suhosin.cookie.max_array_depth   50   50
suhosin.cookie.max_array_index_length   64   64
suhosin.cookie.max_name_length   64   64
suhosin.cookie.max_totalname_length   256   256
suhosin.cookie.max_value_length   10000   10000
suhosin.cookie.max_vars   100   100
suhosin.cookie.plainlist   no value   no value
suhosin.coredump   Off   Off
suhosin.disable.display_errors   Off   Off
suhosin.executor.allow_symlink   Off   Off
suhosin.executor.disable_emodifier   Off   Off
suhosin.executor.disable_eval   Off   Off
suhosin.executor.eval.blacklist   no value   no value
suhosin.executor.eval.whitelist   no value   no value
suhosin.executor.func.blacklist   no value   no value
suhosin.executor.func.whitelist   no value   no value
suhosin.executor.include.blacklist   no value   no value
suhosin.executor.include.max_traversal   0   0
suhosin.executor.include.whitelist   no value   no value
suhosin.executor.max_depth   0   0
suhosin.filter.action   no value   no value
suhosin.get.disallow_nul   1   1
suhosin.get.disallow_ws   0   0
suhosin.get.max_array_depth   50   50
suhosin.get.max_array_index_length   64   64
suhosin.get.max_name_length   64   64
suhosin.get.max_totalname_length   256   256
suhosin.get.max_value_length   512   512
suhosin.get.max_vars   100   100
suhosin.log.file   0   0
suhosin.log.file.name   no value   no value
suhosin.log.phpscript   0   0
suhosin.log.phpscript.is_safe   Off   Off
suhosin.log.phpscript.name   no value   no value
suhosin.log.sapi   0   0
suhosin.log.script   0   0
suhosin.log.script.name   no value   no value
suhosin.log.syslog   no value   no value
suhosin.log.syslog.facility   no value   no value
suhosin.log.syslog.priority   no value   no value
suhosin.log.use-x-forwarded-for   Off   Off
suhosin.mail.protect   0   0
suhosin.memory_limit   0   0
suhosin.mt_srand.ignore   On   On
suhosin.multiheader   Off   Off
suhosin.perdir   0   0
suhosin.post.disallow_nul   1   1
suhosin.post.disallow_ws   0   0
suhosin.post.max_array_depth   50   50
suhosin.post.max_array_index_length   64   64
suhosin.post.max_name_length   64   64
suhosin.post.max_totalname_length   256   256
suhosin.post.max_value_length   65000   65000
suhosin.post.max_vars   200   200
suhosin.protectkey   On   On
suhosin.request.disallow_nul   1   1
suhosin.request.disallow_ws   0   0
suhosin.request.max_array_depth   50   50
suhosin.request.max_array_index_length   64   64
suhosin.request.max_totalname_length   256   256
suhosin.request.max_value_length   65000   65000
suhosin.request.max_varname_length   64   64
suhosin.request.max_vars   200   200
suhosin.server.encode   On   On
suhosin.server.strip   On   On
suhosin.session.checkraddr   0   0
suhosin.session.cryptdocroot   On   On
suhosin.session.cryptkey   [ protected ]   [ protected ]
suhosin.session.cryptraddr   0   0
suhosin.session.cryptua   On   On
suhosin.session.encrypt   On   On
suhosin.session.max_id_length   128   128
suhosin.simulation   Off   Off
suhosin.sql.bailout_on_error   Off   Off
suhosin.sql.comment   0   0
suhosin.sql.multiselect   0   0
suhosin.sql.opencomment   0   0
suhosin.sql.union   0   0
suhosin.sql.user_postfix   no value   no value
suhosin.sql.user_prefix   no value   no value
suhosin.srand.ignore   On   On
suhosin.stealth   On   On
suhosin.upload.disallow_binary   0   0
suhosin.upload.disallow_elf   1   1
suhosin.upload.max_uploads   25   25
suhosin.upload.remove_binary   0   0
suhosin.upload.verification_script   no value   no value
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: batch sreen over and over again
« Reply #10 on: April 17, 2009, 07:57:45 pm »

I'm not actually an expert on suhosin setup, but suhosin.get.max_vars  appears to be low imo. Ask your webhost if they could improve this for you.
Logged

ferreiraactiva

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: batch sreen over and over again
« Reply #11 on: April 21, 2009, 02:16:57 pm »

Hello Joaquim:

Problem solved. You where correct, so I increased  the suhosin.get.max_vars and the files could be inserted.I hope that this will not happen again.
Thanks a lot for all your patient and time wasted with this issue.
Best regards from Portugal...

Zd
Logged

validom

  • Guest
Re: [Solved]: batch sreen over and over again
« Reply #12 on: April 29, 2009, 05:12:11 pm »

hi,

I also had this issue ... and fixed it by disabling suhosin on the server.

As increasing suhosin.get.max_vars to 20000 does not help on my server... does anyone has an idea which setting to change? I'm using debian lenny (stable), except of the one value I did not do any changes to the suhosin-config.

If it helps, in coppermine I get loads of such notices when I'm on the page to select the pictures for batch-input:
Code: [Select]
# Notice line 101: Undefined variable: sel_album
# Notice line 169: Undefined variable: fullimagesize

Code: [Select]
[suhosin]
; Logging Configuration
;suhosin.log.syslog.facility = 9
;suhosin.log.syslog.priority = 1
;suhosin.log.script = 0
;suhosin.log.phpscript = 0
;suhosin.log.script.name =
;suhosin.log.phpscript.name =
;suhosin.log.use-x-forwarded-for = off

; Executor Options
;suhosin.executor.max_depth = 0
;suhosin.executor.include.max_traversal = 0
;suhosin.executor.include.whitelist =
;suhosin.executor.include.blacklist =
;suhosin.executor.func.whitelist =
;suhosin.executor.func.blacklist =
;suhosin.executor.eval.whitelist =
;suhosin.executor.eval.blacklist =
;suhosin.executor.disable_emodifier = off
;suhosin.executor.allow_symlink = off

; Misc Options
;suhosin.simulation = off
;suhosin.apc_bug_workaround = off
;suhosin.sql.bailout_on_error = off
;suhosin.sql.user_prefix =
;suhosin.sql.user_postfix =
;suhosin.multiheader = off
;suhosin.mail.protect = 0
;suhosin.memory_limit = 0

; Transparent Encryption Options
;suhosin.session.encrypt = on
;suhosin.session.cryptkey =
;suhosin.session.cryptua = on
;suhosin.session.cryptdocroot = on
;suhosin.session.cryptraddr = 0
;suhosin.session.checkraddr = 0
;suhosin.cookie.encrypt = on
;suhosin.cookie.cryptkey =
;suhosin.cookie.cryptua = on
;suhosin.cookie.cryptdocroot = on
;suhosin.cookie.cryptraddr = 0
;suhosin.cookie.checkraddr = 0
;suhosin.cookie.cryptlist =
;suhosin.cookie.plainlist =

; Filtering Options
;suhosin.filter.action =
;suhosin.cookie.max_array_depth = 100
;suhosin.cookie.max_array_index_length = 64
;suhosin.cookie.max_name_length = 64
;suhosin.cookie.max_totalname_length = 256
;suhosin.cookie.max_value_length = 10000
;suhosin.cookie.max_vars = 100
;suhosin.cookie.disallow_nul = on
;suhosin.get.max_array_depth = 50
;suhosin.get.max_array_index_length = 64
;suhosin.get.max_name_length = 64
;suhosin.get.max_totalname_length = 256
;suhosin.get.max_value_length = 512
suhosin.get.max_vars = 20000
;suhosin.get.disallow_nul = on
;suhosin.post.max_array_depth = 100
;suhosin.post.max_array_index_length = 64
;suhosin.post.max_name_length = 64
;suhosin.post.max_totalname_length = 256
;suhosin.post.max_value_length = 65000
;suhosin.post.max_vars = 200
;suhosin.post.disallow_nul = on
;suhosin.request.max_array_depth = 100
;suhosin.request.max_array_index_length = 64
;suhosin.request.max_totalname_length = 256
;suhosin.request.max_value_length = 65000
;suhosin.request.max_vars = 200
;suhosin.request.max_varname_length = 64
;suhosin.request.disallow_nul = on
;suhosin.upload.max_uploads = 25
;suhosin.upload.disallow_elf = on
;suhosin.upload.disallow_binary = off
;suhosin.upload.remove_binary = off
;suhosin.upload.verification_script =
;suhosin.session.max_id_length = 128

Thanks a lot!
Logged

Nibbler

  • Guest
Re: [Solved]: batch sreen over and over again
« Reply #13 on: April 29, 2009, 05:19:23 pm »

Relevant settings are suhosin.post.max_vars and suhosin.request.max_vars
Logged

mrbshouse

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: [Solved]: batch sreen over and over again
« Reply #14 on: December 13, 2009, 05:09:03 am »

I've used coppermine a few times before and on a fresh instal and after following all the instructions in as many relevant threads as i could find i'm posting here.

after trying everything i'm at my wits end.  I  was able to up the values to 500 for suhosin.post.max_vars and suhosin.request.max_vars even suhosin.get.max_vars = 500  but that's not working for me.

after bumping up the values to 1000 I was able to finally batch add the 190 or so images.   Given the harsh tone of some of the replies here I was hesitant to post here, but an issue that is created with a fantastico install is something that will limit the scripts use.  It would be nice if there were some details on why so many vars are needed  1000 for 190 files???   

how do you change the values...not much info is out there so here is the deal

locate php.ini by ssh accessing your hosting.  if your on shared you  will need to contact support, for dedicated or VPS you should be able to log into ssh as the root.  enter the comand  "locate php.ini" and you will be show a list of where the file can be found.   in my case at usr/lib/php.ini  I found a program at http://winscp.net/ that allowed me a ftpish look at the root folder via an ssh connection.

I copied   usr/lib/php.ini to my local drive, opened it in notepad and looked for the line:
"extension="suhosin.so"". 

Directly below that I pasted :
suhosin.get.max_vars = 1000
suhosin.post.max_vars = 1000
suhosin.request.max_vars = 1000

Save the file then using winscp rename the current file php.ini to php2.ini as a backup, then upload the edited version.  Reboot your server to recompile the php settings. 

step by step this is what worked for me and this is the only place i know of that now details each step. 

I'd like to know if i've just created a security or performance issue
Logged

ferreiraactiva

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: [Solved]: batch sreen over and over again
« Reply #15 on: December 13, 2009, 12:42:35 pm »

Hello:

Once I have started this discussion let me give my final solution. According to the sugestion by joachim I have contact my web hoster and they send me a php.ini file with just one line suhosin.get.max_vars = 1000. So every time i get the same problem I upload this one line php.ini file and replace the original one on the server, make the pictures batched then I upload the original file and replace it on the server. I am not an expert but I believe that it is better to have the original php.ini file with more variables than the one with only one line.
So every the problem pops up I do this wich I believe its for security reasons and not for performace.
Best regards for all.

Zd
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4886
    • Windsurf.me
Re: [Solved]: batch sreen over and over again
« Reply #16 on: December 13, 2009, 05:14:11 pm »

The one line file is meant not to replace the existing one, but to override just that one setting. As you have access to the original php.ini, just edit that one line in the original.
Logged
It is a mistake to think you can solve any major problems just with potatoes.
Pages: [1]   Go Up
 

Page created in 0.03 seconds with 20 queries.