Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 ... 4 5 6 7 [8] 9   Go Down

Author Topic: Flash Media Player plugin with visual integration (play flv/mp4/mp3/aac files)  (Read 176449 times)

0 Members and 1 Guest are viewing this topic.

tonyhenrie

  • Coppermine newbie
  • Offline Offline
  • Posts: 3

Having trouble uploading video content to Coppermine. Not sure if it's a Coppermine issue or a FMP issue. My site is a WP 3.5.1 site with phpBB 3.0.11 and Coppermine 1.5.22 integrated. I have your FMP, Open Search, Online Stats, and Social Sharing (in that order) plugins activated. File upload limit is set at 600MB in both Coppermine config and php.ini.

Site is westerntrailrider.com/coppermine

Critical Error message is from coppermine/db_input.php, line 71, indicating  missing parameter:

code:
if (!$superCage->get->keyExists('event') && !$superCage->post->keyExists('event')) {
    cpg_die(CRITICAL_ERROR, $lang_errors['param_missing'], __FILE__, __LINE__);

Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15759

What file size has the file you try to upload? Does it work with smaller files? Did you used the flash uploader or the simple upload form? Using FTP + Coppermine's batch-add feature is recommended for large files.
Logged

LnQ

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38

I Have converted a file with Handbreake to MP4: Presents Legacy: Classsic
Installed Flash Media Player (flash_media_player): v2.0

And copyed the "curve" theme to the skin folder under the plugin.
\plugins\flash_media_player\skins\curve

but getting this error???
Video not found or access denied:
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15759

And copyed the "curve" theme to the skin folder under the plugin.
\plugins\flash_media_player\skins\curve
Why? Please undo.


getting this error???
Video not found or access denied:
Please post a link to your gallery where you get this error.
Logged

beyka

  • Coppermine newbie
  • Offline Offline
  • Posts: 1

Is there a way to add an 'embed button' to the player?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15759

I haven't put much effort into this issue, but I wasn't successful to add a working embed button.
Logged

LewisR

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 15
    • Lewis' Blog

Plugin version 2.2 attached here (Αndré, please feel free to move to your initial post and edit this, as appropriate). I've upgraded the JW Player from version 6.1.2972 (in plugin version 2.1) to 6.7.4071 (released 2013-11-07). Full changelog for JW Player 6 is here.

If you've had issues with MP4 files not playing, this update likely will not help (I finally threw in the towel and converted my MP4's to FLV). However, there have been some major enhancements since 6.1, including full screen playing when iframes are supported, and skinning for mobile devices.

Enjoy.
Logged
Lewis Rosenthal, CNA, CLE, CLP, CWTS, EA
IT Consultant / Accountant

LewisR

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 15
    • Lewis' Blog

Ugh...

Just realized that I hadn't updated the codebase.php. Upon opening it, I see the copyright data and versioning. Please delete my previous post & file, if appropriate, or tweak as you see fit, André.

My apologies.
Logged
Lewis Rosenthal, CNA, CLE, CLP, CWTS, EA
IT Consultant / Accountant

MarioLaul

  • Coppermine newbie
  • Offline Offline
  • Posts: 18

i have not working this plugin, i see video icon, but when i push this, not opening i see white background on filmstripe.
Logged

LewisR

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 15
    • Lewis' Blog

Hi, Mario...

Is this problem on just a single video or all? What format(s) are you using, and what other details (size, geometry, etc.)? I've found the player to be particular about some things, and even formats which are supposed to be supported often (for seemingly no reason) do not play.

Cheers
Logged
Lewis Rosenthal, CNA, CLE, CLP, CWTS, EA
IT Consultant / Accountant

MarioLaul

  • Coppermine newbie
  • Offline Offline
  • Posts: 18

This problem on for all videos. I use .MP4 format and video size is 1104x832. Thank you very much:) i very wait solutions :)
Logged

LewisR

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 15
    • Lewis' Blog

Mario, which version of the plugin are you using? The one I posted in November or an earlier one? I'll try to have a look at this today, as I have a couple videos to get up on my own server.

Cheers
Logged
Lewis Rosenthal, CNA, CLE, CLP, CWTS, EA
IT Consultant / Accountant

MarioLaul

  • Coppermine newbie
  • Offline Offline
  • Posts: 18

yeah i use version 2.2
Logged

LewisR

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 15
    • Lewis' Blog

Great. Thanks. Just wanted to make sure.

Cheers
Logged
Lewis Rosenthal, CNA, CLE, CLP, CWTS, EA
IT Consultant / Accountant

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 784
    • GMC Design Photo Gallery

Mario,
As in thread http://forum.coppermine-gallery.net/index.php/topic,60195.msg372794/topicseen.html#msg372794, and based on what I found there - I would try using this too with the curve theme - either setting in config or in the url..
(You didn't have a link posted for me to try it... I'm not sure whre in your gallery an example of this one is...)

Both of these plugins (Flash Media Player and Remote Videos) involve imbedding an object in the webpage with the flash player. It wouldn't surprise me if the same issue in the theme is causing both problems...
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

MarioLaul

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Logged

LewisR

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 15
    • Lewis' Blog

I would have to agree that this has something to do with your theme or some other setting. I downloaded the mp4 and pushed it to my server:

http://www.2rosenthals.net/coppermine/displayimage.php?album=22&pid=658#top_display_media

It seems to play fine for me, Mario.
Logged
Lewis Rosenthal, CNA, CLE, CLP, CWTS, EA
IT Consultant / Accountant

MarioLaul

  • Coppermine newbie
  • Offline Offline
  • Posts: 18

yes, when you use floog themes, video does not working...i have floog themes.
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 784
    • GMC Design Photo Gallery

The floog theme isn't provided by the Coppermine dev team... It was/is a user contribution...
See thread http://forum.coppermine-gallery.net/index.php/topic,66371.msg341638.html#msg341638.
Specifically the note from the author:
Quote
As always, the theme is designed for use in my own gallery. In hope it will be usefull to others, I am sharing it here. Use at your own risk.
The author hasn't been active here in almost 3 years.
There is also a link to a curve-floog theme that addresses some other issues. You might want to try that as an alternative.

It is possible one of the other devs may recognize the issue, and be able to help... But no guarantees.
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15759

As it seems to be a theme issue, please don't clutter any plugin threads, but start a new thread in the themes board describing your issue. Thanks.
Logged
Pages: 1 ... 4 5 6 7 [8] 9   Go Up
 

Page created in 0.167 seconds with 21 queries.