Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Random Image and ExpressionEngine  (Read 5235 times)

0 Members and 1 Guest are viewing this topic.

medic119

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
    • http://www.seadoc.net
Random Image and ExpressionEngine
« on: May 19, 2004, 05:07:12 pm »

I am using the SSI.php file to include a random image on my site. (I don't have any private albums)
I recently moved to ExpressionEngine which is a completely PHP based Dynamically driven CMS.

My problem comes when doing the includes for the site.  EE allows you to define processes to be run per page wither on generation (Input) or after EE PHP has been parsed (Output)

I have included the sssi.php file in an "input" option template and it seems to parse in just fine.  I don't receive any errors.  The problems occur when I try to use any of the SSI commands.

I created a second template and tried both the Input and output parsing options, without success.  It seems issi.php terminates all php in the page anytime a call is made "Fatal error: Call to undefined function: cpg_thumb() in /home/user/public_html/core.functions.php(519) : eval()'d code on line 5"

I also posted this over on the EE forums, but I don't think its an EE problem as I have parsed other add-in PHP.
Does anyone have any ideas on how to fix this short of making a EE "module" or plugin (which would be cool).
Logged
[size=12]Doc, NREMT-Paramedic[/size]
Far From Perfect
"So Shut Up, Live, Travel, Adventure, Bless, And Don't Be Sorry." - Jack Kerouac

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Random Image and ExpressionEngine
« Reply #1 on: May 20, 2004, 06:58:10 am »

I'm not sure what to say: I don't know the cms you're talking about, but apparently the function defined in the inlcude at some stage isn't there when called...
As a workaround I suggest you put the code of the file ssi.php into your custom script area (instead of just including it). This will create some code overhead, but shouldn't be dramatic.
You have to understand that ssi.php goes unsupported because it's outdated.

GauGau
Logged

medic119

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
    • http://www.seadoc.net
Re: Random Image and ExpressionEngine
« Reply #2 on: May 21, 2004, 04:49:24 am »

Yea, I know its unsuppored.
Thanks for the hints though.  Maybe I can get it working somehow.

Any replacement for ssi yet?
Logged
[size=12]Doc, NREMT-Paramedic[/size]
Far From Perfect
"So Shut Up, Live, Travel, Adventure, Bless, And Don't Be Sorry." - Jack Kerouac

Tarique Sani

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 2712
    • http://tariquesani.net
Re: Random Image and ExpressionEngine
« Reply #3 on: May 21, 2004, 06:31:35 am »

Any replacement for ssi yet?

The RSS feed...
Logged
SANIsoft PHP applications for E Biz
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 20 queries.