Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: After upgrading from 1.4.19 to 1.4.25 I can't change language or upload pics  (Read 4051 times)

0 Members and 1 Guest are viewing this topic.

**Mathias**

  • Coppermine newbie
  • Offline Offline
  • Posts: 2

Hi!

After I upgraded from 1.4.19 to 1.4.25 I can't change language from the settings page. When I select English and click 'save', it's still in Swedish although it said "settings updated".

Also, I can't seem to upload pictures anymore. After choosing the picture to upload and click 'upload' it says "upload success" and I get to choose an album to put it in. When I did that and clicked 'next', I got an error: "Critical error - An error occurred while trying to connect to the database" (or something like that, I'm not sure exactly since I can't switch to English). This error message also appears when I try to display a picture in the gallery, i.e. when I go to displayimage.php.

I have read the docs file but didn't find anything helpful there. Any ideas?

Link to my gallery (In Swedish since I can't change to English): http://therasmusworld.net/gallery
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4808
    • Windsurf.me

We have a one question per thread policy so I will deal with the simple question, the one of language.

For me, the gallery is in English which suggests that you have a cookie on your machine which is selecting Swedish. Simply clear the cookie set by coppermine and you will see your site in the language set in config.

The following section of the docs explains it all.

http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#admin_language

As for your upload issues, start a new thread in the uploading section of the forums doing everything outlined in the docs here.

http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_support
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de

To reset your cookie, try accessing http://therasmusworld.net/gallery/?lang=xxx
To force the usage of English, try http://therasmusworld.net/gallery/?lang=english

Moving from the uploads sub-board to misc, as this thread only deals with your language issues (you have been told about board rules already, so I won't).
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 19 queries.