Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Error executing ImageMagick - Return value: 1 latest version 1.4x  (Read 8778 times)

0 Members and 1 Guest are viewing this topic.

mavensophie

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 12
    • Listbuilding With Sophie

I have an installation on one site by hostgator: the software came up without me changing anything with imagemagick error 1
I installed coppermine gallery on another site, worked for a month, then came up with the same error. The staff reinstalled imagemagick, same error.
I installed coppermine gallery on a third server, first it was error 127, found the correct path to imagemagick, but it still comes up error 1

I have pre-processed the pictures with irfanview on my local machines, uploaded them, still error 1. made sure jpeg handling is installed, still error 1.

tried gd2, got error message: Unable to create thumbnail or reduced size image.

I have run the test.php in a 2007 support thread... nothing happened.

I am at my wits end. What could be the problem? I have a client who shoots more than a thousand pictures a month... and he is yelling at me.

Please help. Thank you.
Logged
Webmaster, internet marketer, coach

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Error executing ImageMagick - Return value: 1 latest version 1.4x
« Reply #1 on: October 28, 2009, 03:09:56 am »

http://forum.coppermine-gallery.net/index.php/topic,55415.msg270616.html#msg270616
Make sure all folders under and including "albums" dirs are 777 or 755
Make sure you are not exceeding your upload or storage limits.
Hoe that solves it for you.  :)
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

mavensophie

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 12
    • Listbuilding With Sophie
Re: Error executing ImageMagick - Return value: 1 latest version 1.4x
« Reply #2 on: October 28, 2009, 02:56:45 pm »

this last hosting account is a 550 dollar a month account with its own server...
commandline use of the 'convert' tool works

#file screenshot-1.png
        screenshot-1.png: PNG image data, 649 x 194, 8-bit/color RGB, non-interlaced

#convert -thumbnail 200x200 -format jpg screenshot-1.png screenshot.jpg

#file screenshot.jpg
screenshot.jpg: JPEG image data, JFIF standard 1.01

Same was the situation on another account; commandline works, through coppermine it doesn't.
Logged
Webmaster, internet marketer, coach

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4886
    • Windsurf.me
Re: Error executing ImageMagick - Return value: 1 latest version 1.4x
« Reply #3 on: October 28, 2009, 06:00:05 pm »

Are you saying you used your hosts built in installer? I am guessing that is true as imagemagik was set by default and this is one sign of an install done through such installers.

If that is the case, download a fresh copy from this very site and follow the upgrade instructions.

Once you have done that, do everything outlined here.

http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_support

It is obvious to me that there is a permissions or ownership issue, so do as suggested and we can look into it.

If you used your hosts installer you will probably find that it set the ownership of the files incorrectly. When you run the command line you have root rights so that takes precedence, but when coppermine tries to do it it does not have rights as it is in a different group.

In future, please obey the board rules and post a link to your gallery.

http://forum.coppermine-gallery.net/index.php/topic,55415.0.html
Logged
It is a mistake to think you can solve any major problems just with potatoes.

mavensophie

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 12
    • Listbuilding With Sophie
Re: Error executing ImageMagick - Return value: 1 latest version 1.4x
« Reply #4 on: October 28, 2009, 07:25:34 pm »

I changed the permissions of the uploaded folders with images in them to 777, and that resolved the issue.

the gallery is at http://www.portraitsofnewyork.com

thank you for the help
Logged
Webmaster, internet marketer, coach

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1545
  • aka 'i-imagine'
    • Home Page
Re: Error executing ImageMagick - Return value: 1 latest version 1.4x
« Reply #5 on: October 28, 2009, 07:51:36 pm »

@mavensophie,

Your gallery version is out-dated and vulnerable to hacking....(and almost antique)

<!--Coppermine Photo Gallery 1.4.18 (stable)-->

Upgrade it today.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Error executing ImageMagick - Return value: 1 latest version 1.4x
« Reply #6 on: October 29, 2009, 08:18:43 am »

@Everybody in this thread: you're all trying to help, thank your for that. But the "official" and important statement is the one Phill has made: auto-installers are bad and go unsupported from us.

@mavensophie: Perform an upgrade to the most recent stable release (currently cpg1.4.25) as suggested in the docs that come with coppermine, section "upgrading". Everything else doesn't apply in this case. If you still have issues after having done that, do exactly as suggested in the docs, section "asking for support on upload issues". You have posted all sort of other, unrelated stuff in your initial posting that is therefore quite irrelevant.
Logged

mavensophie

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 12
    • Listbuilding With Sophie
Re: Error executing ImageMagick - Return value: 1 latest version 1.4x
« Reply #7 on: October 29, 2009, 01:56:43 pm »

THANK YOU. I am uploading the new version manually now, and the changing the uploaded album permissions solved my issue. thank you for your help Please close this thread
Logged
Webmaster, internet marketer, coach

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Error executing ImageMagick - Return value: 1 latest version 1.4x
« Reply #8 on: November 02, 2009, 12:02:48 am »

Please close this thread
Please resolve your thread as suggested per board rules.
Logged

mavensophie

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 12
    • Listbuilding With Sophie
Re: Error executing ImageMagick - Return value: 1 latest version 1.4x
« Reply #9 on: November 02, 2009, 12:56:30 am »

ok, SOLUTION:  the problem was that the newly uploaded image directories that I uploaded into the albums directory were the default 755 permission, when I changed them to 777 the Imagemagick error message disappeared.

this solved my problem.
Thank you for your help, especially the guy who suggested I change my folder permissions.  And thank you to Joachim for keeping us all straight.
Logged
Webmaster, internet marketer, coach
Pages: [1]   Go Up
 

Page created in 0.026 seconds with 19 queries.