Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Überhaupt keine E-Mailfunktionen  (Read 6387 times)

0 Members and 1 Guest are viewing this topic.

bastelkoenig

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Überhaupt keine E-Mailfunktionen
« on: October 22, 2009, 11:21:03 pm »

Hallo,

habe vor kurzem cpg 1.4.25 installiert. Jetzt, da ich die Registrierung oder auch die e-cards ausprobiere, stelle ich fest, das in keinem Fall eine E-Mail versandt wurde. Dazu ist zu sagen, dass ich meine User selber freischalte. Dem Registrierenden wird angezeigt, dass er nach der Freischaltung eine E-Mail erhält, dass läuft auch nicht.
Habe schon über die Suche recherchiert, aber nix gefunden. In den E-Mail-Einstellungen habe ich es ohne Einträge, aber auch mit den smtp-Daten meines Providers versucht, leider vergeblich.
Die Seite ist unter http://walden24.de/galerie2 zu finden. Debug-Modus ist an. Mein Provider ist Host Europe.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Überhaupt keine E-Mailfunktionen
« Reply #1 on: October 23, 2009, 08:03:12 am »

Coppermine verwendet die eMail-Funktionalität des Servers (also letztendlich die Funtion mail(), die in PHP eingebaut ist) und hat keine eigene eMail-Funktion. Was daher zu nutzen ist an Deiner Stelle (sendmail oder SMTP) und welche Einstellungen zu treffen sind erfragst Du daher am besten beim Webhoster; wir können Dir da wenig helfen. Ob Dein Server überhaupt eMails versenden kann ist nicht sicher - manche Webhoster sind da sehr vorsichtig, um den Mißbrauch durch Spammer zu minimieren. Coppermine ist da stupide und fragt auch überhaupt nicht nach, sondern setzt stumpf das Mail-Kommando an PHP ab (und damit an's Mailsystem auf dem Server). Gibt das Mailsystem eine Fehlermeldung zurück, dann zeigt Coppermine diese an. Gibt das Mailsystem keine Fehlermeldung zurück (das ist Konfigurationssache des Webservers, nicht von Coppermine), dann "weiss" Coppermine auch nicht, dass die Mail nicht gesendet wurde und beschwert sich daher auch nicht.
Es können auch noch zahlreiche andere Faktoren mitspielen (z.B. eine ungültige Versender-Mailkennung, die in einer Blacklist kleben bleibt), aber auch Client-seitige Fehler. Unmöglich, Dir da weiter zu helfen, da wir auf keinen der Faktoren EInblick oder Einfluß haben.
Logged

bastelkoenig

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Überhaupt keine E-Mailfunktionen
« Reply #2 on: October 23, 2009, 05:39:07 pm »

Danke, werde mal im Forum meines Webhosters stöbern...
Logged

bastelkoenig

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Überhaupt keine E-Mailfunktionen
« Reply #3 on: October 23, 2009, 05:51:19 pm »

Ach ja, in welcher Datei von Coppermine werden die Einstellungen gespeichert? mailer.inc.php, phpmailer.lang-en.php...?
Kann ja sein dass ich Änderungen vornehmen muss.

Mein Hoster sagt dazu folgendes:

Quote
Damit per PHP E-Mails versendet werden können, muss eine gültige Absenderadresse angegeben werden.

Soll über PHP eine Mail versendet werden, muss mit dem Parameter "-f" eine gültige Absenderadresse angegeben werden. Bitte beachten Sie, dass diese E-Mail-Adresse innerhalb des Produkts angelegt sein muss! Die Syntax lautet "-f absender@hier-bitte-ihren-domainnamen-einsetzen.de". Fehlt diese Information kann kein Mailversand erfolgen und die mail()-Funktion liefert eine Fehlermeldung.

Dieser Parameter muss der E-Mail-Funktion im PHP-Quelltext übergeben werden. Dies könnte z.B. so aussehen:
mail ($empfänger, $betreff, $nachricht, $headers, "-f absender@hier-bitte-ihren-domainnamen-einsetzen.de");
[quote/]

Diese Einstellung muss ich irgendwo unterbringen können.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Überhaupt keine E-Mailfunktionen
« Reply #4 on: October 23, 2009, 08:06:52 pm »

Schau in include/mailer.inc.php Zeile 514 ff.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Überhaupt keine E-Mailfunktionen
« Reply #5 on: October 24, 2009, 02:44:33 pm »

Der Versender wird bereits mit angehängt; stelle sicher, dass Du in den Einstellungen von Coppermine die Email-Adresse gültig eingegeben hast.
Logged

bastelkoenig

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Überhaupt keine E-Mailfunktionen
« Reply #6 on: October 25, 2009, 01:16:27 am »

Läuft. Manchmal ist man bloß zu dusselig...
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Überhaupt keine E-Mailfunktionen
« Reply #7 on: October 25, 2009, 12:21:46 pm »

Was genau war jetzt die Lösung?
Logged

bastelkoenig

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Überhaupt keine E-Mailfunktionen
« Reply #8 on: October 25, 2009, 06:28:16 pm »

Man muss bei Host Europe in der Domainkonfiguration unter Skripte eine Standard-Mailadresse einstellen. Diese Adresse setzt man in cpg in die Admin E-Mail unter Allgemeinen Einstellungen. Die smtp-Einstellungen bleiben leer.
Logged

chrkro

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Überhaupt keine E-Mailfunktionen
« Reply #9 on: November 11, 2009, 11:03:21 am »

Hey alles zusammen  ;)

also ich habe seit gestern Abend meine erste Coppermine Gallery online!  :D
Haber aber leider das selbe Problem. Ich habe darmals schon ein Community Script benutzt was auch eMails über PHP versendet hat!
Also dürfte eig. kein Einstellungs Problem sein. :(

Hat vielleciht noch jemand eine Idee? :)

Danke schonmal!!  ;)
Gruß Chriiis
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Überhaupt keine E-Mailfunktionen
« Reply #10 on: November 11, 2009, 11:56:50 am »

Haber aber leider das selbe Problem.
Wenn du dasselbe Problem hast, trifft auch die gleiche Lösung für dich zu. Ist das nicht der Fall, starte dein eigens Thema unter Einhaltung der Forenregeln. Danke.
Logged
Pages: [1]   Go Up
 

Page created in 0.076 seconds with 20 queries.