Advanced search  


cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.

Pages: [1]   Go Down

Author Topic: [Solved]: CPM Fetch problem  (Read 6088 times)

0 Members and 1 Guest are viewing this topic.


  • Coppermine newbie
  • Offline Offline
  • Posts: 8
[Solved]: CPM Fetch problem
« on: October 06, 2009, 01:51:32 pm »

I'm working on a new layout for my website but I have problems with cpm fetch...
I cannot see the images, just a code...
Here's the page:

I used the second code provided by cpm fetch during the installation because it describes exactly my case:

Code: [Select]
include "./gallery/cpmfetch/cpmfetch.php";
$objCpm = new cpm("./gallery/cpmfetch/cpmfetch_config.php");
« Last Edit: October 07, 2009, 09:38:10 am by Joachim Müller »

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
Re: CPM Fetch problem
« Reply #1 on: October 06, 2009, 05:07:38 pm »

That's not very surprising: PHP code is not parsed on an HTML page. That's why the code doesn't get executed on the server and is just being sent to the client's browser, where it is being treated as text and therefor shows through. Not related to cpmFetch in itself, but a general issue for you (or rather "expected behaviour"): since cpmFetch is PHP-driven, you can only use it on PHP pages.
Rename to using your FTP app, then try again, accessing in your browser should then do the trick.


  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: CPM Fetch problem
« Reply #2 on: October 06, 2009, 05:47:54 pm »

Thank you so much, now it works!   :)
Pages: [1]   Go Up

Page created in 0.017 seconds with 20 queries.