Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 [2]   Go Down

Author Topic: admin cannot have a user gallery?  (Read 14728 times)

0 Members and 1 Guest are viewing this topic.

domestictuner

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: admin cannot have a user gallery?
« Reply #20 on: September 24, 2009, 06:30:38 am »

This is the tailend of the debug info, it mentions safe mode but doesn't appear to have the values listed.

==========================
VERSION INFO :
------------------
PHP version: 5.2.10 - OK
------------------
mySQL version: 5.0.81-community
------------------
Coppermine version: 1.4.25(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.34 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support:
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XPM Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
module doesn't exist
==========================
Module: zlib
------------------
module doesn't exist
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
==========================
email
------------------
Directive | Local Value | Master Value |  |  |  |  |  |  |  |
==========================
Size and Time
------------------
Directive | Local Value | Master Value |  |  |  |  |  |  |  |
==========================
Page generated in 0.037 seconds - 14 queries in 0.001 seconds - Album set : ; Meta set: ;
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: admin cannot have a user gallery?
« Reply #21 on: September 24, 2009, 07:46:24 am »

Your webhost appears to have disabled phpinfo and all subsequent information. Ask them (your webhost) how to retrieve the data then alternatively. It's very likely that your webhost has applied other security-related restrictions that have an impact on your gallery. Demand to know what they did exactly (in comparison to a vanilla PHP install).
Logged

domestictuner

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: admin cannot have a user gallery?
« Reply #22 on: September 27, 2009, 02:46:31 am »

i have found the phpinfo, is there any particular values i am looking for other than the safe modes?

in PHP Core:

safe_mode   Off   Off
safe_mode_exec_dir   no value   no value
safe_mode_gid   Off   Off
safe_mode_include_dir   no value   no value

in standard:

safe_mode_allowed_env_vars   PHP_   PHP_
safe_mode_protected_env_vars   LD_LIBRARY_PATH   LD_LIBRARY_PATH

Thank you for your help.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: admin cannot have a user gallery?
« Reply #23 on: September 27, 2009, 11:38:33 am »

Well, seems like you don't have safe_mode enabled PHP-sided, so it's bad that you have enabled silly_safe_mode coppermine sided. You shouldn't have done so in the first place. I'm not sure that what happens if you just turn it off (quite frankly: I have never tried). Try for yourself and report back please.
Logged

domestictuner

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: admin cannot have a user gallery?
« Reply #24 on: September 27, 2009, 11:34:11 pm »

Well, seems like you don't have safe_mode enabled PHP-sided, so it's bad that you have enabled silly_safe_mode coppermine sided. You shouldn't have done so in the first place. I'm not sure that what happens if you just turn it off (quite frankly: I have never tried). Try for yourself and report back please.

should i delete the silly safe mode entry or change the constant to 0?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: admin cannot have a user gallery?
« Reply #25 on: September 27, 2009, 11:38:06 pm »

Comment it out by putting two slashes in front of it.
Logged

domestictuner

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: admin cannot have a user gallery?
« Reply #26 on: September 28, 2009, 06:33:05 am »

commented out, no change to issue

in debug mode this notice is displayed
/bridge/udb_base.inc.php

    * Notice line 149: Undefined property: cpg_udb::$multigroups
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: admin cannot have a user gallery?
« Reply #27 on: September 28, 2009, 10:27:46 am »

Leave notices_display turned off unless you're a coder and know what the notices mean
Logged

domestictuner

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: admin cannot have a user gallery?
« Reply #28 on: October 01, 2009, 12:58:07 am »

any other ideas?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: admin cannot have a user gallery?
« Reply #29 on: October 01, 2009, 07:34:48 am »

I don't know: the gallery http://www.ccclassics.org/gallery/ is in maintenance mode, so there's little left for us to do.
Logged
Pages: 1 [2]   Go Up
 

Page created in 0.022 seconds with 20 queries.