Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: "Template Error" beim Anzeigen einer Kategorie  (Read 6120 times)

0 Members and 1 Guest are viewing this topic.

tobisnet

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
[Solved]: "Template Error" beim Anzeigen einer Kategorie
« on: September 29, 2009, 10:07:22 pm »

Hallo,

ich nutze Coppermine schon einige Jahre, aber vor kurzem ist mir aufgefallen, das ich beim Link auf eine Kategorie einen Template Error bekomme:

Code: [Select]
Template error
Failed to find block 'breadcrumb'(#(<!-- BEGIN breadcrumb -->)(.*?)(<!-- END breadcrumb -->)#s) in :

<!-- BEGIN breadcrumb_user_gal -->
        <tr>
                <td colspan="3" class="tableh1">
                <table width="100%" cellpadding="0" cellspacing="0" border="0">
                <tr>
                        <td align="left"><span class="statlink"><b>{BREADCRUMB}</b></span></td>
                        <td align="right"><span class="statlink">{STATISTICS}</span></td>
                </tr>
                </table>
                </td>
        </tr>
<!-- END breadcrumb_user_gal -->

Beispiellink zu einer meiner Kategorien:
http://www.siggis-hobbyradler.de/coppermine/index.php?cat=4

Coppermine Version 1.4.12

Die Hauptseite wird fehlerfrei angezeigt auch mit den beiden breadcrumb's, die ich in den Einstellungen unter "Ansicht Albenliste/Inhalt der Hauptseite" eingestellt habe:
Code: [Select]
slider/breadcrumb/catlist/breadcrumb/alblist/lastup,2
Ich habe auch schon die Suche bemüht, aber der gefundene Beitrag hat mir nichts genutzt: http://forum.coppermine-gallery.net/index.php/topic,11005.0.html

Vielen Dank für jede Unterstützung und super Tool !!!

Schönen gruß,
Tobi
« Last Edit: September 30, 2009, 10:51:10 am by Joachim Müller »
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: "Template Error" beim Anzeigen einer Kategorie
« Reply #1 on: September 29, 2009, 10:46:05 pm »

Coppermine Version 1.4.12
Na dann ist schleunigst ein Update notwendig. Bei mir tritt der Fehler auf deiner Seite nicht auf.
Logged

tobisnet

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: "Template Error" beim Anzeigen einer Kategorie
« Reply #2 on: September 29, 2009, 11:44:21 pm »

OK, Update ist gemacht: Coppermine Photo Gallery 1.4.25 (stable)

Aber bei mir ist der Fehler immer noch da  ??? - in diversen Browsern.

Wieso bei dir nicht  ???
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: "Template Error" beim Anzeigen einer Kategorie
« Reply #3 on: September 30, 2009, 07:54:20 am »

zip Deine theme.php und füge sie zu Deinem nächsten Post.

tobisnet

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: "Template Error" beim Anzeigen einer Kategorie
« Reply #4 on: September 30, 2009, 07:59:42 am »

OK - hier ist sie, aber eigentlich unverändert.

Ich habe nur am template.html und style.css geändert.
Logged

tobisnet

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: "Template Error" beim Anzeigen einer Kategorie
« Reply #5 on: September 30, 2009, 08:06:44 am »

Der Vollständigkeit halber auch noch die beiden von mir geänderten Dateien template.html und style.css.

Danke für eure Unterstützung.
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: "Template Error" beim Anzeigen einer Kategorie
« Reply #6 on: September 30, 2009, 08:31:30 am »

Da ist ja nicht viel drin. Könnte noch ein Plugin sein, das Probleme macht... mal alle deaktivieren.

tobisnet

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: "Template Error" beim Anzeigen einer Kategorie
« Reply #7 on: September 30, 2009, 08:35:21 am »

Hab jetzt alle Plugins deaktiviert, leider ohne Erfolg:

http://www.siggis-hobbyradler.de/coppermine/index.php?cat=5

 :(
Logged

tobisnet

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: "Template Error" beim Anzeigen einer Kategorie
« Reply #8 on: September 30, 2009, 08:41:42 am »

Hab das Problem gefunden  :D
Das doppelte Verwenden des breadcrumb's in den Einstellungen unter "Ansicht Albenliste/Inhalt der Hauptseite" ist Schuld:

slider/breadcrumb/catlist/breadcrumb/alblist/lastup,2

Wenn ich den lösche gehts.

Aber wieso kann ich den breadcrumb nicht doppelt einbinden ?
Wo es doch auf der Galeriehauptseite keine Probleme macht ????
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: "Template Error" beim Anzeigen einer Kategorie
« Reply #9 on: September 30, 2009, 10:50:57 am »

Aber wieso kann ich den breadcrumb nicht doppelt einbinden ?
Die Frage "wieso" stellt sich nicht: Coppermine wurde halt nicht so programmiert, d.h. eine doppelte Verwendung ist nicht vorgesehen. Daher stellt sich auch die Frage
Wo es doch auf der Galeriehauptseite keine Probleme macht ????
nicht wirklich: das ist purer Zufall, das das dort funktioniert. Ich werde auf jeden Fall eine entsprechende Anmerkung in der Doku verfassen, dass keine doppelten Einträge in diesem Feld getätigt werden dürfen.
Logged

tobisnet

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: [Solved]: "Template Error" beim Anzeigen einer Kategorie
« Reply #10 on: September 30, 2009, 10:59:42 am »

OK, damit wäre das geklärt. War halt mein Fehler.

Danke für die Mühe.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.