Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: Batch problems  (Read 11364 times)

0 Members and 1 Guest are viewing this topic.

albertor

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Batch problems
« on: September 16, 2009, 04:13:03 pm »

Hi everyone I have Coppermine Photo Gallery 1.4.19 (stable) and lately i have the problem that when i click on Batch Add Files the page doesnt load and take me to a white page with this error:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, postmaster@m1n.it and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.



Everything else works fine but i just cant batch my pics

Anyone can help me please?
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1527
  • aka 'i-imagine'
    • Home Page
Re: Batch problems
« Reply #1 on: September 16, 2009, 04:26:26 pm »

onthepike

  • Guest
Re: Batch problems
« Reply #2 on: September 16, 2009, 04:30:22 pm »

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Batch problems
« Reply #3 on: September 16, 2009, 05:27:13 pm »

Gallery is outdated. "Powered by Coppermine" footer is not readible. Additionally, the thread starter hasn't done as suggested in the docs, section "asking for support on upload issues" although he is clearly doing that (batch-add process is part of the upload process). Do as suggested (upgrading & restoring footer & providing the needed details according to docs) .
Logged

albertor

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Batch problems
« Reply #4 on: October 10, 2009, 11:38:31 pm »

Hi I have now restored the footer color and created a user for you in order to see the problem.
www.m1n.it/gallery
Username: user
Pass: user

the problem Is when i click on batch add file it doesnt load the page and I get to a white page with this error "Gateway Time-out
The gateway did not receive a timely response from the upstream server or application"

My gallery version is 1.4.25

please anyone can help?

thank you
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4863
    • Windsurf.me
Re: Batch problems
« Reply #5 on: October 10, 2009, 11:47:03 pm »

Have you read the "asking for support on upload issues" section of the docs?

Please do everything outlined there.

ALTER TABLE `CPG_usergroups` ADD `num_file_upload` TINYINT(4) DEFAULT '5' NOT NULL;
ALTER TABLE `CPG_usergroups` ADD `num_URI_upload` TINYINT(4) DEFAULT '3' NOT NULL;

Logged
It is a mistake to think you can solve any major problems just with potatoes.

albertor

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Batch problems
« Reply #6 on: October 10, 2009, 11:55:26 pm »

i have seen the page but none of the error mentioned there seem to be like mine
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4863
    • Windsurf.me
Re: Batch problems
« Reply #7 on: October 10, 2009, 11:56:43 pm »

But you have not done as requested in that section of the docs. We need you to do exactly as suggested to get coppermine setup in a particular way.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

albertor

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Batch problems
« Reply #8 on: October 11, 2009, 12:00:43 am »

sorry mabe i dot get it you mea this?

When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested. If you want fast results, you should disable admin approval for the group the test user is in, so supporters can tell instantly what is wrong without needing to double-check.

Logged

albertor

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Batch problems
« Reply #9 on: October 11, 2009, 01:03:56 am »

I activate the debug mode and this is what i get:

Code: [Select]
USER:
------------------
Array
(
    [ID] => 599581370c6a51b8cd564e0db8c06ac4
    [am] => 1
    [lang] => english
    [liv] => Array
        (
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => m1n
    [groups] => Array
        (
            [0] => 1
        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM cpg14x_filetypes; (0.002s)
    [1] => select * from cpg14x_plugins order by priority asc; (0.002s)
    [2] => delete from `Sql209208_2`.cpg14x_sessions where time<1255212044 and remember=0; (0.002s)
    [3] => delete from `Sql209208_2`.cpg14x_sessions where time<1254006044; (0.002s)
    [4] => select user_id from `Sql209208_2`.cpg14x_sessions where session_id = '07f1bc39f3f1bd358925dc4d083195c9' (0.002s)
    [5] => select user_id as id, user_password as password from `Sql209208_2`.cpg14x_users where user_id=1 (0.002s)
    [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `Sql209208_2`.cpg14x_users AS u INNER JOIN `Sql209208_2`.cpg14x_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0.002s)
    [7] => SELECT user_group_list FROM `Sql209208_2`.cpg14x_users AS u WHERE user_id='1' and user_group_list <> ''; (0.001s)
    [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg14x_usergroups WHERE group_id in (1) (0.001s)
    [9] => SELECT group_name FROM  cpg14x_usergroups WHERE group_id= 1 (0.001s)
    [10] => update `Sql209208_2`.cpg14x_sessions set time='1255215644' where session_id = '07f1bc39f3f1bd358925dc4d083195c9' (0.001s)
    [11] => SELECT user_favpics FROM cpg14x_favpics WHERE user_id = 1 (0.008s)
    [12] => DELETE FROM cpg14x_banned WHERE expiry < '2009-10-11 01:00:44' (0.001s)
    [13] => SELECT * FROM cpg14x_banned WHERE (ip_addr='38.105.174.138' OR ip_addr='38.105.174.138' OR user_id=1) AND brute_force=0 (0.001s)
    [14] => SELECT group_id, group_name FROM cpg14x_usergroups WHERE 1 (0.001s)
    [15] => UPDATE cpg14x_usergroups SET has_admin_access = '1' WHERE group_id = '1' LIMIT 1 (0.001s)
    [16] => UPDATE cpg14x_usergroups SET group_name='Administrators',group_quota='0',can_rate_pictures='1',can_send_ecards='1',can_post_comments='1',can_upload_pictures='1',pub_upl_need_approval='0',can_create_albums='1',priv_upl_need_approval='0',upload_form_config='3',custom_user_upload='0',num_file_upload='5',num_URI_upload='3' WHERE group_id = '1' LIMIT 1 (0.001s)
    [17] => UPDATE cpg14x_usergroups SET group_name='Registered',group_quota='1024',can_rate_pictures='1',can_send_ecards='1',can_post_comments='1',can_upload_pictures='1',pub_upl_need_approval='1',can_create_albums='1',priv_upl_need_approval='1',upload_form_config='0',custom_user_upload='0',num_file_upload='1',num_URI_upload='0' WHERE group_id = '2' LIMIT 1 (0.001s)
    [18] => UPDATE cpg14x_usergroups SET group_name='Guests',group_quota='0',can_rate_pictures='1',can_send_ecards='0',can_post_comments='0',can_upload_pictures='0',pub_upl_need_approval='1',can_create_albums='0',priv_upl_need_approval='1',upload_form_config='3',custom_user_upload='0',num_file_upload='5',num_URI_upload='3' WHERE group_id = '3' LIMIT 1 (0.001s)
    [19] => UPDATE cpg14x_usergroups SET group_name='Banned',group_quota='0',can_rate_pictures='0',can_send_ecards='0',can_post_comments='0',can_upload_pictures='0',pub_upl_need_approval='0',can_create_albums='0',priv_upl_need_approval='0',upload_form_config='0',custom_user_upload='0',num_file_upload='0',num_URI_upload='0' WHERE group_id = '4' LIMIT 1 (0.001s)
    [20] => SELECT COUNT(*) FROM cpg14x_pictures WHERE approved = 'NO' (0.001s)
    [21] => SELECT * FROM cpg14x_usergroups WHERE 1 ORDER BY group_id (0.002s)
)

==========================
GET :
------------------
Array
(
)

==========================
POST :
------------------
Array
(
    [group_id] => Array
        (
            [0] => 1
            [1] => 2
            [2] => 3
            [3] => 4
        )

    [group_name_1] => Administrators
    [group_quota_1] => 0
    [can_rate_pictures_1] => 1
    [can_send_ecards_1] => 1
    [can_post_comments_1] => 1
    [can_upload_pictures_1] => 1
    [pub_upl_need_approval_1] => 0
    [can_create_albums_1] => 1
    [priv_upl_need_approval_1] => 0
    [custom_user_upload_1] => 0
    [num_file_upload_1] => 5
    [num_URI_upload_1] => 3
    [group_name_2] => Registered
    [group_quota_2] => 1024
    [can_rate_pictures_2] => 1
    [can_send_ecards_2] => 1
    [can_post_comments_2] => 1
    [can_upload_pictures_2] => 1
    [pub_upl_need_approval_2] => 1
    [can_create_albums_2] => 1
    [priv_upl_need_approval_2] => 1
    [custom_user_upload_2] => 0
    [num_file_upload_2] => 1
    [num_URI_upload_2] => 0
    [group_name_3] => Guests
    [group_quota_3] => 0
    [can_rate_pictures_3] => 1
    [can_send_ecards_3] => 0
    [can_post_comments_3] => 0
    [can_upload_pictures_3] => 0
    [pub_upl_need_approval_3] => 1
    [can_create_albums_3] => 0
    [priv_upl_need_approval_3] => 1
    [custom_user_upload_3] => 0
    [num_file_upload_3] => 5
    [num_URI_upload_3] => 3
    [group_name_4] => Banned
    [apply_modifs] => Apply modifications
    [upload_form_config_1] => 3
    [upload_form_config_2] => 0
    [upload_form_config_3] => 3
    [upload_form_config_4] => 0
)

==========================
VERSION INFO :
------------------
PHP version: 5.2.11 - OK
------------------
mySQL version: 5.0.82sp1-log
------------------
Coppermine version: 1.4.25(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.34 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support: 1
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XPM Support:
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 5.0.77
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib/mysql -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version 1.2.3
Linked Version 1.2.3
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | system,popen,dl,passthru,proc_open,shell_exec | system,popen,dl,passthru,proc_open,shell_exec
file_uploads | On | On
include_path | .:/php5/lib/php/ | .:/php5/lib/php/
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | me@localhost.com | me@localhost.com
sendmail_path | /usr/sbin/sendmail -t -i  | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 120 | 120
max_input_time | -1 | -1
upload_max_filesize | 25M | 25M
post_max_size | 30M | 30M
==========================
Page generated in 0.307 seconds - 22 queries in 0.037 seconds - Album set : ; Meta set: ;
« Last Edit: October 11, 2009, 11:04:14 am by Phill Luckhurst »
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4863
    • Windsurf.me
Re: Batch problems
« Reply #10 on: October 11, 2009, 11:03:12 am »

Maybe it has to be spelt out.

Quote
4.11.4 Upload troubleshooting
If you are experiencing issues with coppermine's upload process, temporarily change your coppermine settings as suggested below to get more detailed error messages. This applies to all upload methods, not only HTTP uploads.

Log in as admin
Go to your coppermine page and log in as admin
Go to the config screen
Scroll to the bottom of the page
Expand the "Maintenance settings" section by clicking on it
Enable debug mode for everyone
(set Enable debug mode to "Yes: Everyone")
Leave display of notices switched off
(notices are only meant for developers. If you have idea what they mean, leave them off.)
Save the new settings by clicking on "Save new configuration"
Go to the "groups" panel
Set the upload form configuration for all groups to "Single file uploads only"

set File upload boxes to "1" (1)
set URI upload boxes to "0" (2)
set No. of boxes to "fixed" (3)
Save your new settings
(click on "Apply Modifications")
Then try to upload (using http uploads, even if you experienced troubles using another upload method) - you should get a more detailed error message that tells you what exactly goes wrong with your uploads. If the error message doesn't mean anything to you, search the support board for the error message you get.

4.11.5 Asking for support on upload issues
When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested. If you want fast results, you should disable admin approval for the group the test user is in, so supporters can tell instantly what is wrong without needing to double-check.

When people have issues with uploading and decide to post their question on the Coppermine support board, they usually are told to read this upload troubleshooting section. Many of them fail to do so properly, which results in frustration both for users as well as supporters. To make this absolutely clear: the above mentioned steps are absolutely mandatory, no matter what skill level you have, no matter what upload method you have troubles with. Failing to do exactly as suggested will result in your request for help being ignored. Yes, this applies to you. We mean it!

Logged
It is a mistake to think you can solve any major problems just with potatoes.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Batch problems
« Reply #11 on: October 11, 2009, 09:08:57 pm »

I activate the debug mode and this is what i get
Are you doing this on purpose? From the docs that we have told you to read, let me quote your quote from the docs, highlighting what you obviously failed to read:
sorry mabe i dot get it you mea this?

When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested. If you want fast results, you should disable admin approval for the group the test user is in, so supporters can tell instantly what is wrong without needing to double-check.
Logged

albertor

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Batch problems
« Reply #12 on: October 12, 2009, 12:01:54 am »

hi guys sorry but i really was no there with my head while i was doing that... i have removed the debug and now for somereason i was able to go on batch and do only one upload. No w i tried again to go on batch and i have the same problem

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Batch problems
« Reply #13 on: October 12, 2009, 08:17:27 am »

You still haven't done as suggested. Nobody said that you're suppossed to toggle the debug_mode setting on and off. For the last time: do exactly as suggested in the docs, section "asking for support on upload issues". If you don't, we won't be able to help you, sorry.
Logged

albertor

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Batch problems
« Reply #14 on: October 14, 2009, 08:05:10 pm »

hello again let's give another try  shall we? ;D

When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested. done

If you want fast results, you should disable admin approval for the group the test user is in, so supporters can tell instantly what is wrong without needing to double-check. done

www.m1n.it/gallery
User: user
Pass: user
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4863
    • Windsurf.me
Re: Batch problems
« Reply #15 on: October 14, 2009, 08:29:05 pm »

I cannot be bothered if you cannot do what is asked of you. I'm out of here. ::)

 `num_file_upload`  '5'
 `num_URI_upload` '3'
Logged
It is a mistake to think you can solve any major problems just with potatoes.

albertor

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Batch problems
« Reply #16 on: October 14, 2009, 08:38:44 pm »

changed that also sorry i missed that
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Batch problems
« Reply #17 on: October 14, 2009, 09:40:11 pm »

Too late. You had a last chance and you ruined it. I'm out of this thread as well.
Logged

albertor

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Batch problems
« Reply #18 on: October 14, 2009, 09:50:16 pm »

Thanks guys
Logged

albertor

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Batch problems
« Reply #19 on: October 14, 2009, 10:16:16 pm »

Anyone else can help please?
Logged
Pages: [1] 2   Go Up
 

Page created in 0.03 seconds with 19 queries.