Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Closed]: Still trouble with the LightBox plugin under 1.4.25  (Read 4476 times)

0 Members and 1 Guest are viewing this topic.

Joep28

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
[Closed]: Still trouble with the LightBox plugin under 1.4.25
« on: September 01, 2009, 05:37:43 pm »

Hi Guys,

I know this is a question that has been asked multiple times here, but i just can't find an solution for my/this problem.
I'm running 1.4.25  (stable) and installed only one plugin.
This plugin is the Lightbox V1.2 and i downloaded it from the plugin page.
The problem is that i have the "well-known" radom picture error.
Ofcourse i looked and searched this forum, but it seems that all the answers i found are not related to my version of coppermine.
It also seems that this bug was solved in version 1.4.21 and later, but i still have this error.  http://forum.coppermine-gallery.net/index.php/topic,52160.0.html


For the record, my gallery is not connected to the internet, but if it is wanted for troubleshooting, i can arange something. :)

Thanks again.



« Last Edit: September 10, 2009, 10:45:40 am by Joachim Müller »
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1510
  • aka 'i-imagine'
    • Home Page
Re: Still trouble with the LightBox plugin under 1.4.25
« Reply #1 on: September 01, 2009, 05:44:15 pm »

That refers to the LightBox mod.. You say you have the plugin, therefore read this in the plugin thread....

http://forum.coppermine-gallery.net/index.php/topic,59013.msg291198.html#msg291198

works fine for me with cpg 1.4.25

Without a link that's all I can provide

Joep28

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Still trouble with the LightBox plugin under 1.4.25
« Reply #2 on: September 01, 2009, 07:16:19 pm »

Hi,
Thanks for the reply.
I already saw the link that you refered to, but my functions.inc.php looks different then the one displayed in that post.
Also i think it already contains some extra/changed code to prevent this bug from happening in my version.
Logged

Joep28

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Still trouble with the LightBox plugin under 1.4.25
« Reply #3 on: September 06, 2009, 12:05:42 pm »

Well, this sunday morning i decided to check my functions.inc.php file again, and it seems i missed/overlooked an important step.  :-[

I had to change one line in the functions.inc.php config from:

Code:

$query = "SELECT $select_columns FROM {$CONFIG['TABLE_PICTURES']} WHERE approved = 'YES' $META_ALBUM_SET ORDER BY RAND() LIMIT $limit2";


change to

Code:

$query = "SELECT $select_columns FROM {$CONFIG['TABLE_PICTURES']} WHERE approved = 'YES' $META_ALBUM_SET ORDER BY RAND() $limit";

After that my random pics where shown again.  :)

What i don't understand is that this problem should be solved a long time ago.??
Anyway, it seems to work now.
topic can be closed.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Still trouble with the LightBox plugin under 1.4.25
« Reply #4 on: September 10, 2009, 10:46:46 am »

topic can be closed.
Well, why don't you do as suggested per board rules and tag the thread accordingly?
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 19 queries.