Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Critical Error across entire gallery post-upgrade  (Read 7628 times)

0 Members and 1 Guest are viewing this topic.

keyskeeper

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Critical Error across entire gallery post-upgrade
« on: August 14, 2009, 04:12:00 pm »

I upgraded my gallery from 1.4.23 to 1.4.25 and can no longer access it at all.  It gives me a "Critical error: There was an error while processing a database query." message.  I turned debug mode on via phpMyAdmin and received this message:

Quote
While executing query "SELECT count(*) FROM   WHERE owner=2" on 0

mySQL error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE owner=2' at line 1


File: [..]/include/functions.inc.php - Line: 248 

Searching the docs and board have failed to turn up anything that looks similar.  URL is http://ihwmedia.net/index.php.  Thanks!
Logged

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9094
  • aka Frantz
    • Ma galerie
Re: Critical Error across entire gallery post-upgrade
« Reply #1 on: August 14, 2009, 04:16:55 pm »

works as expected for me  ???
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

keyskeeper

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Critical Error across entire gallery post-upgrade
« Reply #2 on: August 14, 2009, 08:06:18 pm »

I'm still getting the same error - perhaps because I'm still logged in from before I performed the update?
Logged

Nibbler

  • Guest
Re: Critical Error across entire gallery post-upgrade
« Reply #3 on: August 14, 2009, 08:10:46 pm »

Clear your cookies then.
Logged

keyskeeper

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Critical Error across entire gallery post-upgrade
« Reply #4 on: August 15, 2009, 10:24:38 pm »

I did, and when I log in again I get the same error.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4886
    • Windsurf.me
Re: Critical Error across entire gallery post-upgrade
« Reply #5 on: August 15, 2009, 11:15:05 pm »

Clear your browsers cache. Your site works well for me.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

onthepike

  • Guest
Re: Critical Error across entire gallery post-upgrade
« Reply #6 on: August 16, 2009, 12:08:10 am »

It works fine for me as well, however the problem seems to persist upon Admin login. Does the issue remain using a guest or another login? Can anyone else log in?

Also, if you use any thrid-party cleaning applications, such as "CCleaner" for example, you will need to manually delete the cookie yourself, or remove the cookie from the "protected" list. Clearing the cache will not delete these cookies.
Logged

Nibbler

  • Guest
Re: Critical Error across entire gallery post-upgrade
« Reply #7 on: August 16, 2009, 12:14:02 am »

Must be related to some mod you have applied (Stramm's modpack maybe) since that query is not a normal part of Coppermine. Remember to fully reapply mods after updating Coppermine.
Logged

keyskeeper

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Critical Error across entire gallery post-upgrade
« Reply #8 on: August 16, 2009, 05:20:15 pm »

Great!  I didn't think I had the mod pack enabled, but reuploaded and upgraded anyway to check and it's now working.  Thanks!
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.