Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Closed]: Lost Admin Permissions  (Read 6684 times)

0 Members and 1 Guest are viewing this topic.

Bones17

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
[Closed]: Lost Admin Permissions
« on: August 11, 2009, 07:57:34 pm »

ok, i was having bridging problems with coppermine and phpbb3 but then i realized i had set up slightly different passwords for coppermine and phpbb3
so i changed my coppermine password to match my phpbb3 password and now i cant log in as an admin, but it logs me in as a user.

i really know nothing about this stuff... so be kind :)
« Last Edit: August 12, 2009, 07:27:42 am by Joachim Müller »
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4850
    • Windsurf.me
Re: Lost Admin Permissions
« Reply #1 on: August 11, 2009, 09:10:50 pm »

Searching the forum for "lost admin password" brings up hundreds of threads dealing with this very question. Such as this, the very first answer.

http://forum.coppermine-gallery.net/index.php/topic,52213.0.html

It is also mandatory for you to post a link to your gallery. Please bear this in mind for the future and please try using the search function.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Bones17

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Lost Admin Permissions
« Reply #2 on: August 11, 2009, 09:20:35 pm »

sorry... i should have mentioned that i read all that already... i still cant access the admin panel thingy.
my password works to log in, but not as an admin....
here is my gallery
www.ladybonesonline.com/gallery

seriously, i've read everything.... i can't find anything that helps!
Logged

Bones17

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Lost Admin Permissions
« Reply #3 on: August 11, 2009, 09:21:06 pm »

oh, and when i request to send password reminder, it says critical error
Logged

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9096
  • aka Frantz
    • Ma galerie
Re: Lost Admin Permissions
« Reply #4 on: August 11, 2009, 09:24:26 pm »

your gallery seems running cpg 1.5.0
The cpg1.5.* serie is still in alpha stage and is not suported. downgrade to the latest stable version (cpg1.4.25 on this moment)
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

Bones17

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Lost Admin Permissions
« Reply #5 on: August 11, 2009, 09:28:13 pm »

how do i do that???
Logged

Bones17

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Lost Admin Permissions
« Reply #6 on: August 11, 2009, 10:29:14 pm »

is downgrading my only option?? if so, how do i do it??? i tried to download 1.4 but it wont open...???
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1510
  • aka 'i-imagine'
    • Home Page
Re: Lost Admin Permissions
« Reply #7 on: August 11, 2009, 10:43:22 pm »

No support means no support - if you can't fix ver. 1.5.1 yourself, then follow the steps in the 1.4x docs for upgrading.

Upgrading Instructions

I have just now downloaded cpg1.4.25 and unzipped with no problem from here:
[edit] SourceForge Link  link deactivated, to avoid duplicate  [/edit]
« Last Edit: August 11, 2009, 11:02:46 pm by i-imagine »
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4850
    • Windsurf.me
Re: Lost Admin Permissions
« Reply #8 on: August 11, 2009, 10:46:11 pm »

How did you install 1.5?

1.5 is only in the alpha stage, goes unsupported at the moment and is only meant for experienced users to test.

You can download 1.4.25 from here.

http://sourceforge.net/projects/coppermine/files/

Click on the all files>1.4.25 (stable)>cpg1.4.25.zip file and then follow the install instructions from the docs, or ust one of the other archives if you know how to use them.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Bones17

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Lost Admin Permissions
« Reply #9 on: August 11, 2009, 10:48:00 pm »

i didnt know i downloaded 1.5... that other guy said i did tho.
i tried to download 1.4 but when i try to unzip it it says there is a problem with the file...
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4850
    • Windsurf.me
Re: Lost Admin Permissions
« Reply #10 on: August 11, 2009, 10:52:09 pm »

Download it again or try one of the other archives. I've just tested the zip and it works fine for me.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Bones17

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Lost Admin Permissions
« Reply #11 on: August 11, 2009, 11:00:01 pm »

its saying tis not a valid archive.... i downloaded it a second time with the same error.
what now???
i'm getting so frustrated :(
Logged

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
Re: Lost Admin Permissions
« Reply #12 on: August 12, 2009, 06:33:05 am »

http://sourceforge.net/projects/coppermine/files/ --> All Files --> Coppermine --> 1.4.25 (stable) --> cpg1.4.25.zip
Logged
Read Docs and Search the Forum before posting. - Soporte en español
--*--
Fabricio Ferrero's Website

Catching up! :)

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Lost Admin Permissions
« Reply #13 on: August 12, 2009, 07:25:58 am »

You can't actually downgrade from cpg1.5.x to cpg1.4.x -  you need to delete the cpg1.5.x install and start over with cpg1.4.x., as per docs.
We have a strict "one question per thread" policy that you agreed to respect when signing up and your original question was about recovering from a lost admin password. So this thread has already drifted enough. Locking.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.