Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Upgrading 1.4.9 to 1.4.25 - Fatal Error / codebase  (Read 8037 times)

0 Members and 1 Guest are viewing this topic.

veronicamae

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Upgrading 1.4.9 to 1.4.25 - Fatal Error / codebase
« on: July 26, 2009, 10:46:40 pm »

So...I finally bite the bullet to try to upgrade my software and after doing so, I get this error:

Fatal error: Call to undefined function: cpg_fetch_icon() in /home/.anatoly/starbuckqaf/idina-here.com/gallery/plugins/onlinestats/codebase.php on line 97

http://www.idina-here.com/gallery

I ran the update.php...yes, I read the documentation.

I'm pretty code-stupid so the more detailed the questions/solutions you may have for me, the better.  I'm really sorry for my lack of expertise in this field.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upgrading 1.4.9 to 1.4.25 - Fatal Error / codebase
« Reply #1 on: July 27, 2009, 08:35:02 am »

You're trying to use the plugin onlinestats for cpg1.5.x (because only that plugin is trying to attempt the cpg1.5.x-only function cpg_fetch_icon that the error message complains about. Use the plugin that was designed for your version of coppermine. This is in no way related to upgrading!
Logged

veronicamae

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upgrading 1.4.9 to 1.4.25 - Fatal Error / codebase
« Reply #2 on: July 27, 2009, 03:24:02 pm »

OK...The error happened while upgrading.  Hence, me posting about it here.

I didn't realize there was an issue with what I was using.  I first installed the 1.5.x but then found out it was alpha and should use 1.4.25, which I did.  So, is there a specific file I need to be replacing or removing?  Because I just put the 1.4.25 plugin folder in - again (even tho it was already there) and the error remains.
Logged

veronicamae

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upgrading 1.4.9 to 1.4.25 - Fatal Error / codebase
« Reply #3 on: July 27, 2009, 04:06:42 pm »

OK, I put the plugins folder from my original back up on, and that seems to work!  The 1.4.25 plugins didn't seem to.  Do I need to get the 1.4.25 plugins working properly to be secure (as I think the old version of CMG was allowing hackings of my site)?  If not, I'll leave the old ones in place.

Thanks for pointing me in the right direction, terse as though your answer may have been. ;)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upgrading 1.4.9 to 1.4.25 - Fatal Error / codebase
« Reply #4 on: July 28, 2009, 07:45:21 am »

I don't understand your last posting. Please review.
Logged

veronicamae

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upgrading 1.4.9 to 1.4.25 - Fatal Error / codebase
« Reply #5 on: July 28, 2009, 05:00:33 pm »

My apologies.

You stated that I was using the incorrect onlinestats plugin.  When I installed the correct plugin for 1.4.25, which is the software I'm running, the error persisted.

However, when I installed the plugin from the 1.4.9 version, the error was resolved and the gallery functions normally.

My question is this:  Do I need to be using the plugin from 1.4.25 to be 100% secure and/or will it cause problems to use the older plugin with newer software?

(And if I need to use the 1.4.25 plugin, that leads me back to having an error, which will need resolution.)
Logged

Nibbler

  • Guest
Re: Upgrading 1.4.9 to 1.4.25 - Fatal Error / codebase
« Reply #6 on: July 28, 2009, 05:09:17 pm »

The plugin is the same for all 1.4 versions. There is no 1.4.9 version or 1.4.25 version. It's the same thing.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.