Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Modpack 1.4.24 isn't working  (Read 6125 times)

0 Members and 1 Guest are viewing this topic.

rozitcha

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
    • Kate Winslet Fan
Modpack 1.4.24 isn't working
« on: July 07, 2009, 03:25:34 am »

I've installed 1.4.25 version of Coppermine and 1.4.24 version of Stramm's Modpack, but it's totally messed up. I would like to know if the two work together and if it takes a while for it to be solved.

BTW, I've started another thread with the same name, but they marked it as "solved" and it's not solved, I simply downgraded both Coppermine and Stramm's.

My site is http://katewinsletphotos.com (you have to be registered to view the pics), but it's currently with version 1.4.21 of Coppermine.
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Modpack 1.4.24 isn't working
« Reply #1 on: July 07, 2009, 01:55:59 pm »

Should work... there's just a little bug fix in the 1.4.25 release

rozitcha

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
    • Kate Winslet Fan
Re: Modpack 1.4.24 isn't working
« Reply #2 on: July 07, 2009, 04:39:49 pm »

Should work... there's just a little bug fix in the 1.4.25 release

Should I or should I not upgrade to 1.4.25, then?
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Modpack 1.4.24 isn't working
« Reply #3 on: July 07, 2009, 05:45:18 pm »

1.4.24 is the latest security fix and it's mandatory to upgrade.

rozitcha

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
    • Kate Winslet Fan
Re: Modpack 1.4.24 isn't working
« Reply #4 on: July 07, 2009, 06:02:52 pm »

1.4.24 is the latest security fix and it's mandatory to upgrade.

Alright. Thank you! How long does it take for all the thumbs to be fixed with the modpack?
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Modpack 1.4.24 isn't working
« Reply #5 on: July 07, 2009, 06:30:49 pm »

Recreating thumbs you mean? That's a question of server power.

marcies

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Modpack 1.4.24 isn't working
« Reply #6 on: July 07, 2009, 06:54:18 pm »

I've installed 1.4.25 version of Coppermine and 1.4.24 version of Stramm's Modpack, but it's totally messed up. I would like to know if the two work together and if it takes a while for it to be solved.

BTW, I've started another thread with the same name, but they marked it as "solved" and it's not solved, I simply downgraded both Coppermine and Stramm's.

My site is http://katewinsletphotos.com (you have to be registered to view the pics), but it's currently with version 1.4.21 of Coppermine.

Did you check your thumbnails settings? I noticed that it reverted to the regular coppermine settings when I did this so i had to reset the settings for the Stramm modpack to work.
Also you can do that 1.4.25 fix manually. So everything will be upgraded to 1.4.25.

Manual patch:
For those who want to apply the fix manually to their Coppermine 1.4.24 installation, edit include/init.inc.php with a plain text editor (notepad.exe is fine), find:
Code:

$keysToSkip = array('_POST', '_GET', '_COOKIE', '_REQUEST', '_SERVER', 'HTML_SUBST', 'keysToSkip', 'register_globals_flag', 'cpgdebugger', 'key');

and replace with:
Code:

$keysToSkip = array('_POST', '_GET', '_COOKIE', '_REQUEST', '_SERVER', '_FILES', 'HTML_SUBST', 'keysToSkip', 'register_globals_flag', 'cpgdebugger', 'key');

Logged

rozitcha

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
    • Kate Winslet Fan
Re: Modpack 1.4.24 isn't working
« Reply #7 on: July 07, 2009, 07:19:51 pm »

Did you check your thumbnails settings? I noticed that it reverted to the regular coppermine settings when I did this so i had to reset the settings for the Stramm modpack to work.
Also you can do that 1.4.25 fix manually. So everything will be upgraded to 1.4.25.

Manual patch:
For those who want to apply the fix manually to their Coppermine 1.4.24 installation, edit include/init.inc.php with a plain text editor (notepad.exe is fine), find:
Code:

$keysToSkip = array('_POST', '_GET', '_COOKIE', '_REQUEST', '_SERVER', 'HTML_SUBST', 'keysToSkip', 'register_globals_flag', 'cpgdebugger', 'key');

and replace with:
Code:

$keysToSkip = array('_POST', '_GET', '_COOKIE', '_REQUEST', '_SERVER', '_FILES', 'HTML_SUBST', 'keysToSkip', 'register_globals_flag', 'cpgdebugger', 'key');

Thank you so much for your help! I just need to know whether the Stramm's 1.4.24 works together with Copp's 1.4.25 or not.
Logged

marcies

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Modpack 1.4.24 isn't working
« Reply #8 on: July 07, 2009, 09:00:49 pm »

Yes they should work. I did this for dan-radcliffe.net
Logged

rozitcha

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
    • Kate Winslet Fan
Re: Modpack 1.4.24 isn't working
« Reply #9 on: July 07, 2009, 10:09:56 pm »

Yes they should work. I did this for dan-radcliffe.net

Thank you once again for all your help!
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 20 queries.